GPS NAV

This forum is dedicated to software development related to MultiWii.
It is not the right place to submit a setup problem.
Software download

Re: GPS NAV

Postby wareck » Tue Aug 11, 2015 11:02 am

you have to enable this feature in config.h

//#define USE_MSP_WP

If it's not enable, all navigation feature will not be available in GUI

For the GPS, higher rate you put, higher noise and bad value are sended.
For me, best rate is 57200 bauds with last neo6/neo7 or neo8 gps
User avatar
wareck
 
Posts: 36
Joined: Tue May 22, 2012 10:14 pm
Location: Charleville-Mezieres

Re: GPS NAV

Postby ravid824 » Fri Aug 14, 2015 8:15 pm

Thank you much.
It resolved my issue.
ravid824
 
Posts: 26
Joined: Wed Jul 29, 2015 3:59 am
Location: California

Re: GPS NAV

Postby Cbronson » Mon Sep 28, 2015 12:15 am

ezio wrote:
dawagner wrote:I have the Multiwii pro 3.0 with version 2.3, when I connect to the ez-gui the mission planner disappears. Do I have to comment this out in the sketch file for the mission planner stuff to work. Or does mission planner just not work with 2.3?

You have to have this firmware
http://eosbandi.com/downloads/


I'm having the same problem. I've got the folder you said he needs but what do I do with it?
Cbronson
 
Posts: 2
Joined: Sun Sep 06, 2015 1:43 pm

Re: GPS NAV

Postby GUSHELFER » Wed Sep 30, 2015 1:02 pm

We can not always locate in the most appropriate position for a mission , I ask, be possible to rotate the perspective we have on the notebook view GPS ???
if my translator is not good, this is what I mean ...
https://youtu.be/CWBs6ZK03qA
GUSHELFER
 
Posts: 14
Joined: Mon Apr 07, 2014 5:31 pm

Re: GPS NAV

Postby edsimmons3 » Wed Sep 30, 2015 2:05 pm

Which software are you using? Do you want map rotation in EZgui?
edsimmons3
 
Posts: 100
Joined: Thu Sep 10, 2015 11:29 am

Re: GPS NAV

Postby GUSHELFER » Fri Oct 02, 2015 1:17 pm

Yes !! With EZ -GUI works , but WinGUI 2.3 pre10 ( eosbandi ) ... not that function . :(
GUSHELFER
 
Posts: 14
Joined: Mon Apr 07, 2014 5:31 pm

Re: GPS NAV

Postby vukasin » Wed Feb 03, 2016 4:45 pm

Hi,

I have tried the GPS mission, but I got strange behavior, this is the mission that have been uploaded to my quad:
quad-misija1.jpg


but the quad went the other way, and got circling and circling (marked with red) until I flipped off the mission mode, and took the control of quad, because I got scared that the quad would land in the treetops (number 7 is land WP).
[youtube]https://www.youtube.com/watch?v=WPQ-BjGIQJs[/youtube]

That ended badly :) but that was my fault :)

Why the quad went there and got circling around, instead flight the mission?
vukasin
 
Posts: 2
Joined: Wed Feb 03, 2016 4:28 pm

Re: GPS NAV

Postby wareck » Thu Feb 04, 2016 12:27 am

Hi
is your GPS right oriented ?
(if the quad see moving backward until forward, it may do like you)

You nust double check that GPS pointing forward.
For this use wingui and see that dark line point to the right direction
User avatar
wareck
 
Posts: 36
Joined: Tue May 22, 2012 10:14 pm
Location: Charleville-Mezieres

Re: GPS NAV

Postby GUSHELFER » Sat Feb 06, 2016 3:55 pm

11ST: poshold ok
The 2nd poshold ok, then gps poshold
The 3rd when gps poshold ok, then rth
The 4th when rth ok, then wp.
GUSHELFER
 
Posts: 14
Joined: Mon Apr 07, 2014 5:31 pm

Re: GPS NAV

Postby vukasin » Sat Feb 06, 2016 6:00 pm

Well, I think I found the cause, Multiwii used only integrated compass on the board, not from the GPS board. When the load (throttle) increase, the compass turns east...almost 90 degress. I need to move the board up and away from power distribution.

Thank you wareck :)
vukasin
 
Posts: 2
Joined: Wed Feb 03, 2016 4:28 pm

GPS NAV

Postby ezio » Wed Feb 10, 2016 8:02 am

vukasin wrote:Well, I think I found the cause, Multiwii used only integrated compass on the board, not from the GPS board. When the load (throttle) increase, the compass turns east...almost 90 degress. I need to move the board up and away from power distribution.

Thank you wareck :)

Or try to twist the main power wires. It helps a little.
User avatar
ezio
 
Posts: 827
Joined: Sun Apr 01, 2012 11:03 pm
Location: Paris

Re: GPS NAV

Postby GUSHELFER » Sat Mar 12, 2016 3:08 am

I directly remove the power distributor plate and directly connect the cables only. of a pair . 2 forward, two back, and both then straight to the lipo , the union of both pairs , by the side of the frame , zero interference mag.me gave very good results !!!
GUSHELFER
 
Posts: 14
Joined: Mon Apr 07, 2014 5:31 pm

Wingui

Postby nickschaos81 » Wed Jun 29, 2016 5:25 am

I have a dumb question.... but in the wingui Nav (mission) menu. When you create waypoints , there are 4 boxes that you can add a value to ... but i can find no description or explanation on what they are for or what they do. I have browsed this forum but either missed it or its not pointed out. Any Ideas?

Side note, just installed patriks multiwii airplane, it works great. I have no complaints .... yet.
Also curious if patrik emilsson has a current version of code for his multwii head tracker. All links on his site point to 404 , would like to try to get a multiwii pro to run headtracking.
Why? because i have one thats just sitting , and why not... cool project i think.
thanks
nickschaos81
 
Posts: 7
Joined: Thu Jun 11, 2015 3:33 am

Re: GPS NAV

Postby Berlin_Crash_Pilot » Wed Dec 28, 2016 12:13 am

can anyone give me an hint where the WinGUI does store the stallite map files if I hit the FETCH MAP button ?

Thanks in advance.
User avatar
Berlin_Crash_Pilot
 
Posts: 6
Joined: Fri Dec 02, 2016 11:12 am
Location: Berlin

Re: EOSBandi

Postby synersignart » Wed Mar 22, 2017 10:20 am

Question guys is EOSBandi still active . I've notice some maps are breaking up.
User avatar
synersignart
 
Posts: 38
Joined: Wed Mar 22, 2017 3:57 am

Previous

Return to Software development

Who is online

Users browsing this forum: No registered users and 4 guests