MultiWii v1.pre7 released

This forum is dedicated to software development related to MultiWii.
It is not the right place to submit a setup problem.
Software download
kodox
Posts: 12
Joined: Thu Mar 10, 2011 8:07 am

Re: MultiWii v1.pre7 released

Post by kodox »

Black Thunder wrote:
Black Thunder wrote:Hi guys,

I have a strange problem with stable mode. When flying in normal mode my quad is really stable. But after I switch on stable mode, front left motor immediately spins at full speed, when throttle is applied. The other 3 motors are spinning as they are expected to. ACC is already calibrated and shows correct values. Any ideas how to solve the problem?

Thanks in advance ;)


Problem still exists, but I've tried v1.6 and there stable mode works normally. So maybe there is a bug in v1.7pre?


hi , im also have the same problem when turn on stable mode.
im flying quad with home made aluminum frame. now using default v1pre7, without stable mode flying rock sport!!..

JussiH
Posts: 39
Joined: Thu Jan 20, 2011 1:16 am

Re: MultiWii v1.pre7 released

Post by JussiH »

When you have good PID and can hover level in acro mode, you then need to trim Autolevel.

Procedure:

Disarm copter

Move throttle to full

Use pitch/roll stick to trim level mode: Each time you move the stick fully in one direction you add one click of trim in that direction. The LED on your board blinks one time for each click you apply.

Lower throttle

Arm copter, fly

Repeat procedure until you can hover level in stable mode!

Here is my latest autolevel test with Flyduino and FreeFlight IMU on my quad. Flying with unbalanced load in form of a 172 gram battery strapped to one arm:

http://www.youtube.com/watch?v=5pvjKDa6dC4

This is still with stock PID, so wiht some additional tuning, I think I can get it even more stable than this.

Alex...Pre 1.7 is a masterpiece! Autolevel is indeed working very well now....

kodox
Posts: 12
Joined: Thu Mar 10, 2011 8:07 am

Re: MultiWii v1.pre7 released

Post by kodox »

WOW!!
thanks 420RcPilot :D . now i know how to trim in stable mode. ver 1pre7 is really awesome. big thanks to alex.
im flying in stable mode now.. yahoooo :lol: ..
will upload video later..

User avatar
captaingeek
Posts: 228
Joined: Fri Jan 28, 2011 6:42 pm

Re: MultiWii v1.pre7 released

Post by captaingeek »

nice going!! which arduino board would you recommend these days if you want to use all the fetures / channels?

User avatar
quax
Posts: 47
Joined: Mon Mar 14, 2011 12:28 pm
Contact:

Re: MultiWii v1.pre7 released

Post by quax »

I found this line in the .pde and wonder, what it is good for.

Code: Select all

  #define LEDPIN_SWITCH              PINB |= 1<<5;     //switch LEDPIN state (digital PIN 13)


As far as I know, the PINB register is read only and cannot be written.


Kevinlei324
Posts: 1
Joined: Wed Mar 16, 2011 3:51 pm

Re: MultiWii v1.pre7 released

Post by Kevinlei324 »

Hey guys.
I just tired running the 1.7 with both the NP and nunchuck. I'm still waiting for my tx and rx...
In the Configurator, when I tilt the quad, the roll indicator stays in place. The Pitch indicator however, will move to the angle that the quad is at, the drift backwards, PAST level, and settle at the same angle, but past level. (Say, I tilt the quad 45 degrees back, and the pitch will point upwards, at a 45 degree angle. The will drift towards level, and settle, with the pitch arrow pointing DOWNWARD, at a 45 degree angle). Is this normal? Also, my Roll Pitch indicator (The Black circle with the white arrow inside) does not respond. It stays pointing straight up...
Please help! this is my first time using MWC. Thanks!

quadslo
Posts: 16
Joined: Sat Feb 26, 2011 12:39 pm

Re: MultiWii v1.pre7 released

Post by quadslo »

I will upgrade my quad from 1.5 to 1.pre7.

If I leave all the PID config in 1.7 as in 1.5, will quad fly the same in acro mode?

User avatar
captaingeek
Posts: 228
Joined: Fri Jan 28, 2011 6:42 pm

Re: MultiWii v1.pre7 released

Post by captaingeek »

any idea when 1.7 will go gold?

PatrikE
Posts: 1955
Joined: Tue Apr 12, 2011 6:35 pm
Location: Sweden
Contact:

Re: MultiWii v1.pre7 released

Post by PatrikE »

captaingeek wrote:any idea when 1.7 will go gold?

If you mean released it's a long time ago.
All releases can be found here.
http://code.google.com/p/multiwii/source/browse/#svn%2Ftags
And if you look in the trunk there is the latest Development releases to be tested.

User avatar
captaingeek
Posts: 228
Joined: Fri Jan 28, 2011 6:42 pm

Re: MultiWii v1.pre7 released

Post by captaingeek »

OK I was looking for a release announcement / thread for it here. I suppose we're just discussing it in this thread.

User avatar
captaingeek
Posts: 228
Joined: Fri Jan 28, 2011 6:42 pm

Re: MultiWii v1.pre7 released

Post by captaingeek »

2 questions:

MAIN SOFT: software trim for stable mode
It is now possible to adjust the trim of the level mode to match the same TX trim used for the acro mode.
1) disarm the motors
2) full throttle (must be >1900)
3) full PITCH forward/backward and full ROLL left/right (2 axis possibilities) will trim the level mode according to the neutral angle you want to change. The status LED will blink to confirm each ticks.


1) How many ticks are there? 100? I had to about 10 left roll and 5 pitch back ticks to get it level. How many are possible?

2) In the conf, what does the numbers with commas mean? How do I adjust each number? In the past I would click drag to go from a negative to a positive number.

http://wbb.multiwii.com/download/file.php?id=36&mode=view

Post Reply