Page 22 of 29

Re: MultiWii EZ-GUI

PostPosted: Thu Sep 18, 2014 7:04 am
by EOSBandi
rubadub wrote:
ezio wrote:
rubadub wrote:might be a stupid question, but can the CLI feature in EZ-GUI be used to send raw MSP_SET* messages? Or, does it only support the baseflight CLI features?

Technically it is possible. Everything you put there is send to the flight control board. But it will be very difficult to do it as you have to write entire message using ASCII.


how difficult would it be to add such a feature? BTW, I'm a paying customer, in case it makes a difference... ;)


I think what could make sense is to create a translation layer in the gui which converts set and get commands to the appropriate MSP_ commands.. and formats the answers to a readable form. Sending pure MSP_ commands from CLI otherwise does not makes sense, since it is not a human readable protocol..

Re: MultiWii EZ-GUI

PostPosted: Thu Sep 18, 2014 7:53 am
by rubadub
ok, but would it be able to handle custom MSP commands?
I'm playing with creating a custom MSP_SET for setting the ROLLRATE and PITCHRATE variables for flying wings. I had to add two new variables to the conf_t struct and then create a new MSP_SET command & logic for setting these values with the MW protocol. Obviously, without modifying the MW GUI tools, I can't really use my custom command, but, if there was a way to do it via the CLI or an EZ-GUI tool, it would be a piece of cake to simply manually enter the command ID, the number and types of params to send, and then click a button to send.

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 19, 2014 6:58 am
by ezio
rubadub wrote:ok, but would it be able to handle custom MSP commands?
I'm playing with creating a custom MSP_SET for setting the ROLLRATE and PITCHRATE variables for flying wings. I had to add two new variables to the conf_t struct and then create a new MSP_SET command & logic for setting these values with the MW protocol. Obviously, without modifying the MW GUI tools, I can't really use my custom command, but, if there was a way to do it via the CLI or an EZ-GUI tool, it would be a piece of cake to simply manually enter the command ID, the number and types of params to send, and then click a button to send.

Give me more details about command you want to implement and I will see what can I do for you.

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 19, 2014 7:02 am
by ezio
Hypermobile wrote:@ Ezio

Two idea's for you EZGui.

1) Intergrated info from http://www.n3kl.org/sun/noaa.html (Geomagnetic situation)....to check if Flying on GPS is a good idea or not.
(top Left). Today it says Geomagnetic Storm....and if i look to my GPS it's floating around...so not that good.

2) A screen to Popup user specified Pre-Flight Checks (and post flight checks).
i've made a list on paper...but PAPER ;-) is old skool.

Sometimes i forget my switch off my Video power....of forget to Record the GoPro.
Nice to have a screen full of reminders.

i'm getting old

I have done the number 1 from your list.
But I don't have a time to test it and compile correctly. I will push the update probably next week.
uploadfromtaptalk1411106550959.jpg

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 19, 2014 9:50 am
by brewski
This is a great idea & will help prevent crazy flyaway situations for those who do not check their actual quad position on map in EZ-GUI before arming.
I now do this religiously before activating any GPS function & had zero flyaways since. I have noticed a couple of times that quad was moving randomly within approx. 5 metres despite having lock of >7 satellites. I'm pretty sure this was due to sun activity & when I see this I use GPS very cautiously if at all. This data is another excellent tool to help us make the right decision without guessing..well done Guys!

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 19, 2014 10:26 am
by Hypermobile
ezio wrote:
Hypermobile wrote:@ Ezio

Two idea's for you EZGui.

1) Intergrated info from http://www.n3kl.org/sun/noaa.html (Geomagnetic situation)....to check if Flying on GPS is a good idea or not.
(top Left). Today it says Geomagnetic Storm....and if i look to my GPS it's floating around...so not that good.

2) A screen to Popup user specified Pre-Flight Checks (and post flight checks).
i've made a list on paper...but PAPER ;-) is old skool.

Sometimes i forget my switch off my Video power....of forget to Record the GoPro.
Nice to have a screen full of reminders.

i'm getting old

I have done the number 1 from your list.
But I don't have a time to test it and compile correctly. I will push the update probably next week.
Screenshot_2014-09-19-08-00-38.png



Great! stuff Ezio. thx

;) push on for the PreFlight checks

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 19, 2014 5:05 pm
by ezio
Hypermobile wrote:
ezio wrote:
Hypermobile wrote:@ Ezio

Two idea's for you EZGui.

1) Intergrated info from http://www.n3kl.org/sun/noaa.html (Geomagnetic situation)....to check if Flying on GPS is a good idea or not.
(top Left). Today it says Geomagnetic Storm....and if i look to my GPS it's floating around...so not that good.

2) A screen to Popup user specified Pre-Flight Checks (and post flight checks).
i've made a list on paper...but PAPER ;-) is old skool.

Sometimes i forget my switch off my Video power....of forget to Record the GoPro.
Nice to have a screen full of reminders.

i'm getting old

I have done the number 1 from your list.
But I don't have a time to test it and compile correctly. I will push the update probably next week.
Screenshot_2014-09-19-08-00-38.png



Great! stuff Ezio. thx

;) push on for the PreFlight checks

First I have to sort out the units and make a possibility to choose metric and imperial. cm/s irritates me :)

After that AUX support for Cleanflight - i have no idea why the developer of cleanflight has changed the protocol

So for now PLEASE DO NOT USE AUX SETTINGS WITH CLEANFLIGHT

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 19, 2014 5:06 pm
by ezio
Hypermobile wrote:
ezio wrote:
Hypermobile wrote:@ Ezio

Two idea's for you EZGui.

1) Intergrated info from http://www.n3kl.org/sun/noaa.html (Geomagnetic situation)....to check if Flying on GPS is a good idea or not.
(top Left). Today it says Geomagnetic Storm....and if i look to my GPS it's floating around...so not that good.

2) A screen to Popup user specified Pre-Flight Checks (and post flight checks).
i've made a list on paper...but PAPER ;-) is old skool.

Sometimes i forget my switch off my Video power....of forget to Record the GoPro.
Nice to have a screen full of reminders.

i'm getting old

I have done the number 1 from your list.
But I don't have a time to test it and compile correctly. I will push the update probably next week.
Screenshot_2014-09-19-08-00-38.png



Great! stuff Ezio. thx

;) push on for the PreFlight checks

First I have to sort out the units and make a possibility to choose metric and imperial. cm/s irritates me :)

After that AUX support for Cleanflight - i have no idea why the developer of cleanflight has changed the protocol

So for now PLEASE DO NOT USE AUX SETTINGS WITH CLEANFLIGHT

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 19, 2014 9:05 pm
by rubadub
ezio wrote:
rubadub wrote:ok, but would it be able to handle custom MSP commands?
I'm playing with creating a custom MSP_SET for setting the ROLLRATE and PITCHRATE variables for flying wings. I had to add two new variables to the conf_t struct and then create a new MSP_SET command & logic for setting these values with the MW protocol. Obviously, without modifying the MW GUI tools, I can't really use my custom command, but, if there was a way to do it via the CLI or an EZ-GUI tool, it would be a piece of cake to simply manually enter the command ID, the number and types of params to send, and then click a button to send.

Give me more details about command you want to implement and I will see what can I do for you.

thanks, I really appreciate the offer :)
However, I think it might be a waste of time to develop a specific solution *just* for the command that I'm experimenting with, which I'm not even sure will be a permament solution. It would probably be easier and a lot more useful to develop a simple debug tool that lets you specify the following:
- MSP command type: read or write

- command ID: the MSP command #, which can either be entered manually or selected from a dropdown list of the existing commands or user-defined commands

- input param count: for write commands, the number of input params
-- for each input param, type and value

- output params, count & type: same as above, but for formatting the output

- anything else?

hit a button, send the command, and have the output displayed in a small console-type window. I think something like this could be very cool and useful to developers for testing out new serial protocol commands. any thoughts?

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 21, 2014 3:01 am
by carl1864
Huge fan of the app, just purchased the unlocker. Having an issue trying to get Nav mode to work, I've been searching for hours with no luck.

Everything was working fine on multiwii 2.3, including RTH. I tried upgrading to the Nav version though, starting with the latest nav version B7, then stepping back to nav version B5 baro fix. I set EZ Gui to Nav protocol, but when I try to connect via bluetooth, I just get constant "No data recieved" errors, and cannot do anything at all, not even adjust PID's. I've cleared eeprom, and recompiled both nav versions multiple times, double checking all settings in config.h. I simply cannot get this nav version to function at all in EZ Gui.

Specs: crius aiop board, ublox gps, typical bluetooth module, phone galaxy S.

Any idea what's wrong?

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 21, 2014 3:56 am
by RC_Adik
I am also having problems with EZ-GUI using bluetooth on my MWI 2.3 FC's.
Problems I don't have have using EZ-GUI & bluetooth with any of my Naze 32 FC's.
Trying to set/change PID's on the MWI with 2.3 firmware I get the rotating circle indicating ongoing communication with the FC that never ends.
I can end this endless cycle by exiting the PID screen or using the read eeprom arrow. If I do either to quickly, the PID values are not saved.
I have gone back to EZ-GUI 3.102.159 and find that everything works as expected with the Multiwii 2.3 FC's.
This problem happens with both my Samsung devices, TAB 3 10.1 wifi and S3 phone.
Both 2.3 FC's have baro & mag with no GPS or other bells and whistles.

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 21, 2014 12:15 pm
by Hypermobile
@above posters

I just Upgraded again to 2.3 NAV B7 (witespy 2560).
App works just great as ever. (bluetooth).
Flew my first SUCCELFUL mission :mrgreen:

Maybe Try to restart your Phone.
My Bluetooth sometimes goes nuts....and cann't connect anymore to anything.

@Ezio,
Today:
For Some reason my *.EL1 file stopped for some reason.

like this

Code: Select all
GRAW,12:17:38.538,-35,61,530,-4,0,11
GMAG,12:17:38.539,26,73,138,-4,2.47
GMOT,12:17:38.674,1522,1526,1494,1338,0,0,0,0
GPAR,12:17:38.778,2984,0,146,327
GATT,12:17


Resulting in a Bad *.KML file Bad *.GPX file (KML errors in Earth; GPX doesn;'t show a thing)

What i'm gonna do: Fix the file by shorten it. put it on the Phone and run it again
Should be fixable in the app :-)

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 21, 2014 8:47 pm
by NNagib
@ezio, I have a suggestion and a question :)
1. I think it would be nice to add the "default home position" in the app. My copter is placed in central Africa whenever the app doesn't have gps data. In some cases, even after establishing the gps fix, the map is not refreshed, and I have to reload the map manually. I would like to have possibility for entering coordinates of my default home position, where the copter will be shown in cases of absence of gps.
2. Can you check the app behavior when the screen is switched off. In my case (Note 3), when I press the button to power off the screen, the app stops working/logging. I think this is wrong.

Cheers

Re: MultiWii EZ-GUI

PostPosted: Mon Sep 22, 2014 6:15 pm
by fiestito
Hi folks,

I finally got to set up the 3DR radio telemetry for my Multiwii FC. Using Multiwii EZ GUI androind app + Garmin Virb edit software I got some nice data overlay on the video from the GPS data.
This video its just a boring flight test on a bit small location but I was able to get top speed around 76 km/h and top altitude around 62 meters!!

Ezio the export to .gpx feature works great!


Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 6:29 am
by ezio
Hypermobile wrote:@above posters

I just Upgraded again to 2.3 NAV B7 (witespy 2560).
App works just great as ever. (bluetooth).
Flew my first SUCCELFUL mission :mrgreen:

Maybe Try to restart your Phone.
My Bluetooth sometimes goes nuts....and cann't connect anymore to anything.

@Ezio,
Today:
For Some reason my *.EL1 file stopped for some reason.

like this

Code: Select all
GRAW,12:17:38.538,-35,61,530,-4,0,11
GMAG,12:17:38.539,26,73,138,-4,2.47
GMOT,12:17:38.674,1522,1526,1494,1338,0,0,0,0
GPAR,12:17:38.778,2984,0,146,327
GATT,12:17


Resulting in a Bad *.KML file Bad *.GPX file (KML errors in Earth; GPX doesn;'t show a thing)

What i'm gonna do: Fix the file by shorten it. put it on the Phone and run it again
Should be fixable in the app :-)

I have no idea why it stops logging at the moment. It can be something with file access. More investigation is needed. During my flights it has never happened.

Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 6:42 am
by Hypermobile
ezio wrote:
Hypermobile wrote:@above posters

I just Upgraded again to 2.3 NAV B7 (witespy 2560).
App works just great as ever. (bluetooth).
Flew my first SUCCELFUL mission :mrgreen:

Maybe Try to restart your Phone.
My Bluetooth sometimes goes nuts....and cann't connect anymore to anything.

@Ezio,
Today:
For Some reason my *.EL1 file stopped for some reason.

like this

Code: Select all
GRAW,12:17:38.538,-35,61,530,-4,0,11
GMAG,12:17:38.539,26,73,138,-4,2.47
GMOT,12:17:38.674,1522,1526,1494,1338,0,0,0,0
GPAR,12:17:38.778,2984,0,146,327
GATT,12:17


Resulting in a Bad *.KML file Bad *.GPX file (KML errors in Earth; GPX doesn;'t show a thing)

What i'm gonna do: Fix the file by shorten it. put it on the Phone and run it again
Should be fixable in the app :-)

I have no idea why it stops logging at the moment. It can be something with file access. More investigation is needed. During my flights it has never happened.



File access won't change suddenly ...does it?

I think it happened when the app crashed.
(more a bad phone; rather than a bad App).

maybe it's easy possible to erase incomplete lines in the converter app
(manually it works) :D

Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 11:19 am
by rubadub
quick & easy feature request:
in MISC menu, please add options for changing Power Sensor variables, conf.psensornull and conf.pint2ma.

Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 2:50 pm
by ezio
NNagib wrote:@ezio, I have a suggestion and a question :)
1. I think it would be nice to add the "default home position" in the app. My copter is placed in central Africa whenever the app doesn't have gps data. In some cases, even after establishing the gps fix, the map is not refreshed, and I have to reload the map manually. I would like to have possibility for entering coordinates of my default home position, where the copter will be shown in cases of absence of gps.
2. Can you check the app behavior when the screen is switched off. In my case (Note 3), when I press the button to power off the screen, the app stops working/logging. I think this is wrong.

Cheers

In this state the app won't work when the screen is off. It requires redesigning almost entire app to make it possible.
I don't have a time right now to do it.

Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 2:51 pm
by ezio
rubadub wrote:quick & easy feature request:
in MISC menu, please add options for changing Power Sensor variables, conf.psensornull and conf.pint2ma.

The MSP protocol supports it?

Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 2:54 pm
by ezio
carl1864 wrote:Huge fan of the app, just purchased the unlocker. Having an issue trying to get Nav mode to work, I've been searching for hours with no luck.

Everything was working fine on multiwii 2.3, including RTH. I tried upgrading to the Nav version though, starting with the latest nav version B7, then stepping back to nav version B5 baro fix. I set EZ Gui to Nav protocol, but when I try to connect via bluetooth, I just get constant "No data recieved" errors, and cannot do anything at all, not even adjust PID's. I've cleared eeprom, and recompiled both nav versions multiple times, double checking all settings in config.h. I simply cannot get this nav version to function at all in EZ Gui.

Specs: crius aiop board, ublox gps, typical bluetooth module, phone galaxy S.

Any idea what's wrong?

Do you have serial port speed set correctly in config.h?

Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 2:55 pm
by ezio
rubadub wrote:
ezio wrote:
rubadub wrote:ok, but would it be able to handle custom MSP commands?
I'm playing with creating a custom MSP_SET for setting the ROLLRATE and PITCHRATE variables for flying wings. I had to add two new variables to the conf_t struct and then create a new MSP_SET command & logic for setting these values with the MW protocol. Obviously, without modifying the MW GUI tools, I can't really use my custom command, but, if there was a way to do it via the CLI or an EZ-GUI tool, it would be a piece of cake to simply manually enter the command ID, the number and types of params to send, and then click a button to send.

Give me more details about command you want to implement and I will see what can I do for you.

thanks, I really appreciate the offer :)
However, I think it might be a waste of time to develop a specific solution *just* for the command that I'm experimenting with, which I'm not even sure will be a permament solution. It would probably be easier and a lot more useful to develop a simple debug tool that lets you specify the following:
- MSP command type: read or write

- command ID: the MSP command #, which can either be entered manually or selected from a dropdown list of the existing commands or user-defined commands

- input param count: for write commands, the number of input params
-- for each input param, type and value

- output params, count & type: same as above, but for formatting the output

- anything else?

hit a button, send the command, and have the output displayed in a small console-type window. I think something like this could be very cool and useful to developers for testing out new serial protocol commands. any thoughts?

If there is enough demand I will add it. For now easier for me is add custom command.

Re: MultiWii EZ-GUI

PostPosted: Tue Sep 23, 2014 7:06 pm
by Hypermobile
ezio wrote:
Hypermobile wrote:@above posters

I just Upgraded again to 2.3 NAV B7 (witespy 2560).
App works just great as ever. (bluetooth).
Flew my first SUCCELFUL mission :mrgreen:

Maybe Try to restart your Phone.
My Bluetooth sometimes goes nuts....and cann't connect anymore to anything.

@Ezio,
Today:
For Some reason my *.EL1 file stopped for some reason.

like this

Code: Select all
GRAW,12:17:38.538,-35,61,530,-4,0,11
GMAG,12:17:38.539,26,73,138,-4,2.47
GMOT,12:17:38.674,1522,1526,1494,1338,0,0,0,0
GPAR,12:17:38.778,2984,0,146,327
GATT,12:17


Resulting in a Bad *.KML file Bad *.GPX file (KML errors in Earth; GPX doesn;'t show a thing)

What i'm gonna do: Fix the file by shorten it. put it on the Phone and run it again
Should be fixable in the app :-)

I have no idea why it stops logging at the moment. It can be something with file access. More investigation is needed. During my flights it has never happened.


2 Broken files again like these,
App was not responding (Report / Wait / Close).


Was using Map & 2nd crash Dash 3.
Maybe it has something to do with a lost Bluetooth connection or bad reception?

anyway; when the app crashes, you can get a incomplete line resulting is a wrong KML / GPX / (didn't check Wingui).


Code: Select all
GMAG,17:36:24.755,-57,26,141,66,2.62
GNAV,17:36:24.776,1,11,222,5
GPAR,17:36:24.810,2940,0,151,462
GATT,17:36:24.834,0.0


Code: Select all
GRAW,17:40:13.033,22,25,516,2,-1,0
GMAG,17:40:13.033,-42,40,136,47,3.69
GNAV,17:40:13.089,1,11,128,3
GPAR,17:40:13.173,2904,0,145,756
GATT,17:40:13.233,


Each time for now....on GATT.

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 1:54 am
by ezio
RC_Adik wrote:I am also having problems with EZ-GUI using bluetooth on my MWI 2.3 FC's.
Problems I don't have have using EZ-GUI & bluetooth with any of my Naze 32 FC's.
Trying to set/change PID's on the MWI with 2.3 firmware I get the rotating circle indicating ongoing communication with the FC that never ends.
I can end this endless cycle by exiting the PID screen or using the read eeprom arrow. If I do either to quickly, the PID values are not saved.
I have gone back to EZ-GUI 3.102.159 and find that everything works as expected with the Multiwii 2.3 FC's.
This problem happens with both my Samsung devices, TAB 3 10.1 wifi and S3 phone.
Both 2.3 FC's have baro & mag with no GPS or other bells and whistles.


I've checked it on Nexus 5 and galaxy s2 and it works as expected. cannot reproduce bug

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 2:16 am
by rubadub
ezio wrote:
rubadub wrote:quick & easy feature request:
in MISC menu, please add options for changing Power Sensor variables, conf.psensornull and conf.pint2ma.

The MSP protocol supports it?


oops, i just checked, and it doesn't.
I can add it to Protocol.cpp with your approval/guidance/blessing.
Could we please work something out? It sucks to have to re-compile in order to adjust the power/amperage meter

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 2:21 am
by rubadub
ezio wrote:If there is enough demand I will add it. For now easier for me is add custom command.


ok, I'll try to come up with a final prototype for adding the ROLLRATE and PITCHRATE to the protocol for FLYING_WING. I'll post back as soon as it's ready for your inspection/approval...

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 5:48 am
by RC_Adik
ezio wrote:
RC_Adik wrote:I am also having problems with EZ-GUI using bluetooth on my MWI 2.3 FC's.
Problems I don't have have using EZ-GUI & bluetooth with any of my Naze 32 FC's.
Trying to set/change PID's on the MWI with 2.3 firmware I get the rotating circle indicating ongoing communication with the FC that never ends.
I can end this endless cycle by exiting the PID screen or using the read eeprom arrow. If I do either to quickly, the PID values are not saved.
I have gone back to EZ-GUI 3.102.159 and find that everything works as expected with the Multiwii 2.3 FC's.
This problem happens with both my Samsung devices, TAB 3 10.1 wifi and S3 phone.
Both 2.3 FC's have baro & mag with no GPS or other bells and whistles.


I've checked it on Nexus 5 and galaxy s2 and it works as expected. cannot reproduce bug


To start, I personally am amazed by the app and it's ever expanding features. To say I'm fond of it would be an understatement!

I guess my expectations may differ. Maybe a little more information on my part.
Tab 3 = KitKat 4.4.2
S3 = ICS 4.3

When sending changes, (PID..) to MultiWii FC 2.3 neither device indicates eeprom saved or read. Only indication that anything has been done is the spinning circle indicating the process has not completed.
In reality the process has or does complete. I verified this by changing the offset of the tail servo on a Tri-copter, but as I mentioned before the only way to stop the spinning circle was to exit the PID screen or touch the read eeprom.

This feature, (spinning circle) doe NOT happen when communicating with my Naze 32 boards. When the setting is sent to the eeprom a message is displayed on the screen stating, (settings saved - S3) and (settings read - Tab 3) and the spinning circle stops immediately.

I know nothing about writing code or programming and this problem is far from a serious bug, but....
We all understand that as a program matures and features are added, un-known features can evolve also.

Thanks for looking into it!

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 7:18 pm
by Leo
I've just purchased the File Converter and looked at some test flights with Google Earth. Nice :)

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 7:26 pm
by Leo
I'm going to post this here as I'm seeing the problem by using EZ-GUI just because I don't know if it's a MultiWii code or EZ-GUI problem.

I am using "MultiWii_dev_2014_01_14__r1648" on the QC.

When I start up the QC and run EZ-GUI all is fine. I feel excited. The sexy sounding lady spits out the correct altitude. However when flying around at some random point all of a sudden my altitude is -50xxx meters! Before I check the MultiWii code or ask in another thread I thought I'd start here, not that EZ-GUI the culprit.

Anyone have this happen to them?

Leo

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 8:20 pm
by Hypermobile
I once had -1500 or something.

I guess it could be that the GPS altitude is mentioned.
In GPS tab in EZGui; you can check (since today) the X-flare and earth magnetic field.

could be that GPS is way off.

Today it was "Unsettled" > advice is to do no GPS guided flight

Re: MultiWii EZ-GUI

PostPosted: Wed Sep 24, 2014 8:25 pm
by Leo
Thanks. I didn't think of GPS altitude :roll:

Next time I'll pay attention to the GPS conditions in EZ GUI.

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 26, 2014 8:05 am
by trogalko
Hi Ezio,

Do You have plan to put EZ-GUI on other android market (which accept paypal) like SlideME?
I'm the one who hate the idea to expose my cc number to google, as I already did that with paypal.
Thanks

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 26, 2014 8:13 am
by AlouetteIII
@Ezio - can you please implement BLE connectivity for naze32 - or have you done it already http://www.multiwiicopter.com/products/bluetooth-ble-for-paris - we are getting much better range with BLE than regular BT

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 26, 2014 9:21 am
by fpv_downunder
What range are you getting typically?

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 26, 2014 11:51 pm
by ezio
trogalko wrote:Hi Ezio,

Do You have plan to put EZ-GUI on other android market (which accept paypal) like SlideME?
I'm the one who hate the idea to expose my cc number to google, as I already did that with paypal.
Thanks

Here in France I can pay via PayPal in playstore.
Contact me directly to eziosoft@gmail.com

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 26, 2014 11:51 pm
by ezio
trogalko wrote:Hi Ezio,

Do You have plan to put EZ-GUI on other android market (which accept paypal) like SlideME?
I'm the one who hate the idea to expose my cc number to google, as I already did that with paypal.
Thanks

Here in France I can pay via PayPal in playstore.
Contact me directly to eziosoft@gmail.com

Re: MultiWii EZ-GUI

PostPosted: Fri Sep 26, 2014 11:53 pm
by ezio
Leo wrote:Thanks. I didn't think of GPS altitude :roll:

Next time I'll pay attention to the GPS conditions in EZ GUI.

Actually MW doesn't use the GPS altitude at all.

Re: MultiWii EZ-GUI

PostPosted: Sat Sep 27, 2014 6:50 am
by Leo
ezio wrote:
Leo wrote:Thanks. I didn't think of GPS altitude :roll:

Next time I'll pay attention to the GPS conditions in EZ GUI.

Actually MW doesn't use the GPS altitude at all.

If that is the case then there might be an error either in EZ GUI (which I doubt) or an error in the MS5611 Baro code!

Re: MultiWii EZ-GUI

PostPosted: Sat Sep 27, 2014 5:38 pm
by Leo
I threw out the MS5611 code and used my own.

This afternoon I flew for 40 min and didn't have an issue anymore :)

Re: MultiWii EZ-GUI

PostPosted: Sat Sep 27, 2014 6:01 pm
by ezio
Leo wrote:
ezio wrote:
Leo wrote:Thanks. I didn't think of GPS altitude :roll:

Next time I'll pay attention to the GPS conditions in EZ GUI.

Actually MW doesn't use the GPS altitude at all.

If that is the case then there might be an error either in EZ GUI (which I doubt) or an error in the MS5611 Baro code!

I had the same situation today. I was flying at 5m but MW though that it was 45m.

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 28, 2014 5:26 am
by rubadub
ezio wrote:
Leo wrote:Thanks. I didn't think of GPS altitude :roll:

Next time I'll pay attention to the GPS conditions in EZ GUI.

Actually MW doesn't use the GPS altitude at all.


don't know if it matters in this context, but PatrikE's fixed-wing NAV code uses GPS altitude instead of baro altitude. Just an FYI...

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 28, 2014 10:33 am
by carlonb
MultiWii dev version r1648 has the baro altitude issue, this is solved with r1649, please see here http://www.multiwii.com/forum/viewtopic.php?f=8&t=4534

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 28, 2014 10:40 am
by Leo
carlonb wrote:MultiWii dev version r1648 has the baro altitude issue, this is solved with r1649, please see here http://www.multiwii.com/forum/viewtopic.php?f=8&t=4534


Thanks. It confirms my findings.

This begs the question why r1648 is still avaliable for download https://code.google.com/p/multiwii/downloads/list ?

Re: MultiWii EZ-GUI

PostPosted: Sun Sep 28, 2014 10:47 am
by carlonb
Leo wrote:
carlonb wrote:MultiWii dev version r1648 has the baro altitude issue, this is solved with r1649, please see here http://www.multiwii.com/forum/viewtopic.php?f=8&t=4534


Thanks. It confirms my findings.

This begs the question why r1648 is still avaliable for download https://code.google.com/p/multiwii/downloads/list ?

Very good question... may be the developers are waiting for the final next release :)

Re: MultiWii EZ-GUI

PostPosted: Fri Oct 03, 2014 5:11 pm
by Leo
I think I've found an error in the Logging section. If I deactivate Autologging it will still log files and save them.

Also spelling mistake. Should read "Motors" :)

Re: MultiWii EZ-GUI

PostPosted: Thu Oct 16, 2014 6:07 pm
by josepo
Hello

Read the forum translating it with google because they are not English

But that have asked me to translate:

I started in the drone world with the ArduPilot board connecting to an airplane model, it was very basic and waypoints were introduced by text in the program itself, so when a change the mission was desired, the board need to be reprogramed, so that although I had fun any change was tedious, impossible to be done on field, it was needed to go with the work done from home.

I recently find the EZ-GUI and I assembled it, but as I did with the ArduPilot before mounting on the drone I tried it doing tours and seeing the servos respond as expected to do so, but I have not actually achieved it, the system works well in principle, the gps gives the correct position, missions are charged with EZ GUI or with WIN-GUI and with the screen mission turned on I can see that every time the drone enters the defined radius of the waypoint, the target waypoint becomes the next, but the servos only respond to changes due to the change of role or roll pit, no movement due to the mission is observed, although the waypoint this clearly in a very different direction, I've done all kinds of tests, but since I can not think any more idea.

Also GPS emulator is missed to avoid the need to do the trials physically. I´m able to make gpsemulator communicate with ArduPilot, but I have not managed to communicate gpsemulator with multiwiipro and cannot find any alternative, any idea?

hardware:
Multiwiipro (HK) processor 2560
GPS ublos NEO6 38400 Bd
Connect Bt (libor)
sof: 2.3 multiwi B7 eosbandi navi, win-gui, ez-gui
Radio: Futaba
phone samsung s4

best regards Josepo

Re: MultiWii EZ-GUI

PostPosted: Fri Oct 17, 2014 5:19 am
by Arakon
Do you have a compass (HMC5883 or similar) installed? Without a compass, it won't know which direction it is facing.

Re: MultiWii EZ-GUI

PostPosted: Fri Oct 17, 2014 6:34 am
by ezio
josepo wrote:Hello

Read the forum translating it with google because they are not English

But that have asked me to translate:

I started in the drone world with the ArduPilot board connecting to an airplane model, it was very basic and waypoints were introduced by text in the program itself, so when a change the mission was desired, the board need to be reprogramed, so that although I had fun any change was tedious, impossible to be done on field, it was needed to go with the work done from home.

I recently find the EZ-GUI and I assembled it, but as I did with the ArduPilot before mounting on the drone I tried it doing tours and seeing the servos respond as expected to do so, but I have not actually achieved it, the system works well in principle, the gps gives the correct position, missions are charged with EZ GUI or with WIN-GUI and with the screen mission turned on I can see that every time the drone enters the defined radius of the waypoint, the target waypoint becomes the next, but the servos only respond to changes due to the change of role or roll pit, no movement due to the mission is observed, although the waypoint this clearly in a very different direction, I've done all kinds of tests, but since I can not think any more idea.

Also GPS emulator is missed to avoid the need to do the trials physically. I´m able to make gpsemulator communicate with ArduPilot, but I have not managed to communicate gpsemulator with multiwiipro and cannot find any alternative, any idea?

hardware:
Multiwiipro (HK) processor 2560
GPS ublos NEO6 38400 Bd
Connect Bt (libor)
sof: 2.3 multiwi B7 eosbandi navi, win-gui, ez-gui
Radio: Futaba
phone samsung s4

best regards Josepo

Stupid question
Did you set and enable correctly mission mode via AUX switches?

Re: MultiWii EZ-GUI

PostPosted: Fri Oct 17, 2014 11:58 am
by josepo
The compass is integrated into the motherboard multiwiipro , there are also integrated 3 accelerometer , 3 gyroscopes and one barometer.

Regarding the activate the mission issue, I see through the EZ-GUI that at least five satellites must be established and the motherboard must be armed to activate the mission with the switch, once activated, the wp with its radius (in my case 5m) and the circle where everything is included (3 km maximum) are seen and each time the circle of influence of a wp is reached, the destination changes to the following WP, but no servo action is appreciated, that has been tested as Cuard and as plane.


greetings

josepo

Re: MultiWii EZ-GUI

PostPosted: Fri Oct 24, 2014 8:35 pm
by henfri
Hello,

I am using/starting to use a Flyduino Mega and a Frsky Taranis with the X8D, which supports Telemetry via SBUS.
Now, browsing through EZ-Gui, I noticed the FrSky Telemetry-Option. Searching about what's behind this, I found this thread and read most of it. The general process is understood: Connect Serial of the Flight-Controller to the X8D and connect a Bluetooth-Module<-> Serial Module to the FrSky.
On the Taranis-Side:
The Serial Port of the Taranis is described here.
In short:
Set Serial-Output to 'Telemetry' (or S-Port mirror??), and set the Baud-Rate to 9600 (or 57600?).
The Bluetooth-Module must support this
Taranis serial port uses RS-232 polarity for RX and TX signals, but it won't output full RS-232 voltage levels (from -15V to +15V) on TX line. The RX input is RS-232 tolerant. Still it will work with most standard serial adapters (even USB serial adapters).

This could by the JY-MCU, but here, it seems like a level-shifter is needed -but I find no specs. But that Guy uses apparently thisBluetooth<->Serial Module.
Any hints on working hardware on the Taranis-Side? Are there no BT-Serial Modules that directly support the right Levels?

Now, coming to the Flightcontroller-Side:
Here we want two things:
a) direct BT-Connection (or rather WiFi?) to EZ-GUI in order to be able to change PID-Settings etc. of the flight controller, when the Copter is in close proximity
here, I think the JY-MCU is confirmed to work, isn't it?

b) Connection to the SBus-Input of the FrSky RX (X8D), for Telemetry via Taranis/2.4Ghz when Copter is flying/further away.
I found some Information on Multiwii-Telemetry via FrSky/Sbus here. I was delighted to see, that one very active Author in that Thread was ezio :-)
Unfortunately, the Frsky-Telemetry code seems to have been working in MultiWii, but not in MultiWii 2.3 anymore. Is that right?
Also, FrSky uses RS232 Voltages here again and not TTL --> another Adapter/Inverter?
This?
Or This?
Are these two last modules maybe also usefull on the Taranis-Side?

Last Questions:
-Can the BT-Serial-Module on the Flight-Controller-Side and the X8D be connected to the same Serial-Port (the X8D is only listening).
-Do I have any benefits using also the SBus instead of PWM to send the normal RX-TX commands (for pitch, yaw, etc) to the Flightcontroller (i.e. higher Resolution etc)?

Greetings,
Hendrik

Re: MultiWii EZ-GUI

PostPosted: Sat Oct 25, 2014 7:31 pm
by henfri
Hmmm, I fear my post was too long?