MultiWii v1.pre7 new BUG not really !!!

This forum is dedicated to software development related to MultiWii.
It is not the right place to submit a setup problem.
Software download

MultiWii v1.pre7 new BUG not really !!!

Postby johnnyquad » Sun Feb 27, 2011 4:42 pm

Using MultiWii v1.pre7 with WMP and NC on a mega (both original) standard Futaba FP-TV6A 35MHz 6ch Tx, Corona RP8D1 Rx.

Normal cycle time for me is about ~6120 I had to increase INTERLEAVING_DELAY to 3050 to stop some glitches in the ACC which is about normal for WM+ and NC.

Image

***PROBLEM***
If you throttle up full or at least about 1780, even with the motors not armed, then PITCH full right (above 1700) or full left (below 1150) the cycle time reduces to 2020 and the GUI goes into very slow update(~2 every second). The same thing happens if you do this with ROLL

I think the bug is in the flight control software as I added a
Code: Select all
   case 'P':
      Serial.println(cycleTime);
      break;

at the bottom of the serial routines which printed out the cycle times in the serial port console
during the error conditions (THROTTLE above 1750 / PITCH >1700 <1150 etc) gives values
60544/60544/61196/60608/60644
and I think the GUI only displays the last 4 digits of that value ie. 1196 etc.

and when sticks are at rest gives
6102/6126/6101 etc which is normal

It does not do this in any of the other versions 1.pre6/1.prebis6/1.6 I have tried

I have also posted this in the MultiWii Board index ‹ Software ‹ Current developments and bugs in the hope Alex may get a look at this.

I have flown this version and it flies very well I just think there is a bug here as I would never be using such extreme stick input at least not yet.

Can anyone else try this and see if they get the same results. I think this needs addressed as could cause some serious crashes.

Image

Image

Image

Image
Last edited by johnnyquad on Sun Feb 27, 2011 5:01 pm, edited 1 time in total.
johnnyquad
 
Posts: 6
Joined: Sun Feb 27, 2011 2:58 pm

Re: MultiWii v1.pre7 new BUG

Postby Alexinparis » Sun Feb 27, 2011 4:51 pm

Hi,

It's not a bug, it's a new feature ;)

If the motors are disarmed, this stick combination correspond to the soft ACC trim (see the last change.txt),
and a write to the EEPROM is done each time + led blink.
Those operations are very long in comparison of a normal cycle.

But don't worry, it can't happen once the motors are armed.
Alexinparis
 
Posts: 1630
Joined: Wed Jan 19, 2011 9:07 pm

Re: MultiWii v1.pre7 new BUG

Postby johnnyquad » Sun Feb 27, 2011 5:00 pm

Your right Alex sorry for the alarm!
johnnyquad
 
Posts: 6
Joined: Sun Feb 27, 2011 2:58 pm


Return to Software development

Who is online

Users browsing this forum: No registered users and 14 guests

cron