GUI horizon spins 90degrees randomly

GUI horizon spins 90degrees randomly

Postby jonrev » Wed Jan 18, 2017 2:15 am

I have a MWC SE V2.5 with Ublox GPS unit which is now set up in a 450 quad and is pretty much all working OK and ready for flight testing....EXCEPT....

Over the past few days while setting up the quad it's been sitting on my bench next to the PC and hooked up variously to WinGUI or MultiwiiConf for several hours. On two occasions I looked at the screen and found the artificial horizon was about 90 degrees off horizontal. The quad had not been moved and was sitting on a pretty flat worktop. Moving the quad showed the AH following the movements but remaining 90 degrees out.
The third time this happened I was actually watching the screen and suddenly the AH rapidly turned to it's near vertical position and stayed there. I was not doing anything to the quad or moving it in any way and neither was I making any software changes so I can't think of anything that could have prompted the movement.

Over the last two days I haven't noticed it happen again and I can't seem to force it to happen.

I'm a bit reluctant to think about flying with this behaviour in case it should happen in flight and bring the quad down. Is this something anyone has had experience of or can anyone suggest what might be happening?

Thank you
jonrev
 
Posts: 2
Joined: Fri Aug 12, 2016 3:34 pm

Return to Shields, boards and sensors

Who is online

Users browsing this forum: No registered users and 1 guest

cron