Page 1 of 1

Heads Up On Board Quirks

Posted: Mon Nov 16, 2015 4:04 pm
by Kbev5709
Just in case anyone else out there bought/buys a RTF Quads Mega Multiwii Pro 3 "Blacked Mag" edition FC, there are some quirks and inconsistencies in the instructions provided on re-flashing the board.
For anyone who doesn't know and who may be interested, the "Blacked Mag" edition is a MW Pro much like the HK Pro but the mag has been removed. The board has no mag at all. Why? It is designed to work with a remote mag on a GPS unit. As far as I know this is the only Mega board out there that can run a remote mag. On this board, the GPS plugs into serial 2 just like a HK board, but the mag plugs into the I2C.
On the RTF Quads sales page for this board they state that this board, if to be re-flashed, should use the following board definition: FFIMUv43
Trouble with that is there is no FFIMUv43 in the boards list. The RTF Quads MW Pro 2 uses FFREEIMUv043. Trying that on the Pro 3 it does nothing like it should. Using that definition, the Gyro stops functioning, and there is no sign of a mag anywhere.
After I dropped Paul over there at RTF Quads an e-mail asking WTF, I got busy trying to resolve things on my own. Turns out that my solution was to recomment ALL board definitions. Then using the independent sensors section, I uncommented my sensors. Wow, hey, it worked!! Trouble was, everything was still messed up (without my knowledge yet) and when I tried to fly the quad did a beautiful flip landing squarely on the prop shafts.
More investigation using the GUI revealed that the sensors were not responding correctly. I used the section right below the independent sensors to enforce my individual sensor orientation. After working with the quad and GUI I got everything responding properly. Test flight later today.
I'm having trouble grasping at how they can give that BS definition on that board. I reviewed the board on his site but he has not yet published my review.

Posted: Fri Nov 27, 2015 4:31 am
by SkySpaghetti
I've been playing around with a RTFQ Mega Pro 2 board myself and I've found the documentation on their site is a bit jumbled and the preset files provided didn't work very well.

After doing my own searching I've been able to piece together the Config.h settings to get the system working fairly well. Google Witespy Multiwii on the RCgroups forum and you'll find much better write ups for all 3 boards then whats available on the RTFQ website.

I myself am struggling to get the GPS working properly with my board on the Serial 2 port. I've also run into trouble with the PPM system but was able to get it working after a bit of fiddling and reflashing the code.

If you have any luck with the GPS, let me know what you find out.

Re: Heads Up On Board Quirks

Posted: Fri Nov 27, 2015 2:56 pm
by Kbev5709
My GPS works awesomely allowing me to do waypoint missions. I use a different GPS than you do though, mine being a LEAH6H UBLOX. I have experience with a successful MTK set up though before I got the UBLOX. See my answer to your GPS problem in your other post. Do you think you could post a link to the RC groups thread? I couldn't find the Whitespy one. Thanks in advance.