MWC 2.5 LED fast blinking (NO sensors)

MWC 2.5 LED fast blinking (NO sensors)

Postby Amefuri » Tue May 05, 2015 4:41 am

Hi, tonight I connected my tricopter to battery with mwc without receiver and I got everything working fine but then I connected the receiver to the mwc and the battery again. The multiwii board wasnt getting enough energy or something because the led was barelly visible so I disconnected everything and connected mwc with ftdi to my pc and my board started blinking normal but then really fast without stopping. I tried to get something from GUI but no signal.
What does it mean. Did it burn or something ? I didn't exceed any voltage or something. Never happen before. Also everytime I upload a sketch, the loading bar dissapears but it stays uploading... in arduino. Someone can help ?

Okey, as I suspected, the multiwii is not damaged, after countless times connecting /disconnecting FTDI from pc and from multiwii I got green led from FTDI blinking (RX) receiving data from sensors. I went to GUI and there it was. I could move it in realtime and get realtime data. Got happy for a moment but then reconnected FTDI and there again, no RX but only TX (red led), mwc is not blinking fast anymore and jump blinks every 1 and 2 seconds ignoring sensors.
I suspect the sensor's led blink will only happen when the rx is well connected to pc through FTDI right? and right COM is selected. So then do I have faulty FTDI ? I am going to test my multiwii with bluetooth to check if I receive continuos data to my android device. I'll update asap.

Lol. Now suddently it works everytime I connect it to the computer.
Very strange. Anyways, tested with bluetooth and it was glitching ( 1 time working, 1 time not working ) and tried many apps.
Right now I am trying to get my motors working with receiver connected to the mwc. It recognizes my motor but no signal from transmiiter gets into the mwc.
Every connection is right and I guess something maybe wrong in the config.h or in transmitter configuration.
If you have ideas what could have happen , please comment below. I am still clueless why it stopped working and why it started working again by just retrying.
Last edited by Amefuri on Wed May 06, 2015 2:52 am, edited 3 times in total.
Posts: 17
Joined: Fri Apr 17, 2015 4:40 pm

Re: MWC 2.5 LED fast blinking

Postby FengShuiDrone » Tue May 05, 2015 2:31 pm

Check to make sure you have the correct board and port names in the tools section of your Arduino then make sure that you have the correct board selected in the boards and sensor definitions section of your config.h sketch.
Posts: 234
Joined: Wed Dec 24, 2014 1:20 am
Location: ......

Re: MWC 2.5 LED fast blinking

Postby Amefuri » Tue May 05, 2015 3:43 pm

I did. Normally it would work.
Are there any blue led flashing guide to know what problem it is.
Because normally when I move the multiwii while in ftdi , the blue led flashes for every movement I do. Normal sensor reacting.
But now it just flashes every 2 seconds. And sometimes it goes really fast.
Tried multiple GUI but no connection. No signal. Says, cant connect to COM3.
I reinstalled drivers. Still no connection. The FTDI's tx is blinking red but mwc wont answer.
I really cant see any damage on chips or circuits. And it doesn't smell burned.
Posts: 17
Joined: Fri Apr 17, 2015 4:40 pm

Re: MWC 2.5 LED fast blinking (NO sensors)

Postby saponga » Mon Aug 31, 2015 6:18 pm

Hi there,

I'm facing the same situation. If you figure something out, please report back. Thanks.
Posts: 5
Joined: Mon Aug 31, 2015 5:23 pm

Re: MWC 2.5 LED fast blinking (NO sensors)

Postby Dennis D » Mon Aug 31, 2015 10:51 pm


I have (or had) Crius MW SE 2.5 from BG. It was running MW 2.4. NP.
The I2C communications to the on board sensors completely and abruptly failed! Somehow, this also destroyed the FTDI (strange!). The I2C errors cause the fast blinking LED (no sensors!).
The FC still has some functionality. BT works, motors spin up, buzzer works, inputs work...but Gyro, acc, mag, and baro don't. Quad is un-flyable w/o gyro.
I can only connect to FC with BT. Then, it indicates continuous I2C errors and cycle times of 6000 to 7000 usecs (more than 2x normal).

I don't really know what caused this failure...but I was flying rough just before failure.
My TL250A quad was flying great so I ordered exact replacement FC and FTDI from BG. Hope these work.
I wonder if this is problem with Crius MW FC?

Just wanted to let others know in case this turns into an issue that is related to the CRIUS FC or BG or both....

Dennis D
Posts: 16
Joined: Wed Jun 24, 2015 1:48 am

Re: MWC 2.5 LED fast blinking (NO sensors)

Postby saponga » Wed Sep 02, 2015 2:29 am

Ok... After a lot of reading and learning I found out that the default bootloader of the Arduino Pro or Pro Mini (5V, 16 MHz) w/ ATmega328 chip has the brown-out detector DISABLED. It means that a low voltage can lead to bootloader corruption. In my case, the problem get started when I was trying to test a gimbal connecting 2 servos at the a0 and a1 pins while powering up the board only from an USB port. So I start to think now that the servos got the voltage for atmega below it's threshold and the bootloader got corrupted. Next step is soldering some pins to ISP header of the crius and burn a fresh bootloader using an arduino uno as programmer. Does it make any sense ? Let's see it.

EDIT: Yeahhh !!! It's alive !!! That's it guys... Like i suspected, the bootloader was corrupted by a suddenly drop in tension. I just re-burned the proper bootloader using an arduino UNO V3 as a programer and my board is normal again !!! If anyone is feeling brave, the link below shows the connections from the UNO to ISP of the target board. Just be aware that the Crius' ISP header seems to be "upside down" (the little square is the pin 1). The procedure is quite straightforward:
a) Upload the sketch "ArduinoISP" (from file/examples) to arduino UNO and disconnect the UNO from PC;
b) Solder the 6 ISP pins on the Crius and make the connections as shown in the picture linked below;
c) Double check the connections, especially VCC and GND.
d) connect the UNO to PC via USB cable.
e) From "tools" select the proper port, board (Arduino Pro or Pro Mini (5V, 16 MHz) w/ ATmega328) and programmer (Arduino as a programmer)
d) Them in the same menu tab (tools) select "Burn Bootloader" and wait a few seconds. You're done !!!

DISCLAIMER: I'm a total newbie soooo the risk is all yours !!! If you need help just ask for and i'll do my best. ... 8b456a.jpg
Posts: 5
Joined: Mon Aug 31, 2015 5:23 pm

Return to Shields, boards and sensors

Who is online

Users browsing this forum: No registered users and 1 guest