Drifting pitch

Post Reply
walkmanz
Posts: 10
Joined: Fri Jul 13, 2012 6:07 pm

Drifting pitch

Post by walkmanz »

http://youtu.be/Of-U2oyVFG0

Could you please look at my video from Multiwii GUI, I use QADX with WMP and Nunchunk clones.. Is that correct that nunchunk is green but ACC is red?
And I have some problems with autolevel because my pitch is drifting, as you can see in video, when I put quad nose up or down and hold, pitch level is leveling horizontal or going on opposite direction, I tested in real life it by holding in one hand my quad and on other my transmiter, and putting on some throttle it starts to level and it reaches it when nose is about 45 degrees down..

Roll is working fine as you can see..
And I have calibrated accelerometer..

Anybody has an idea what could be the problem?

walkmanz
Posts: 10
Joined: Fri Jul 13, 2012 6:07 pm

Re: Drifting pitch

Post by walkmanz »

Nobody has any idea?

User avatar
Hamburger
Posts: 2559
Joined: Tue Mar 01, 2011 2:14 pm
Location: air
Contact:

Re: Drifting pitch

Post by Hamburger »

did you check sensor orientation as described in faq and wiki?

walkmanz
Posts: 10
Joined: Fri Jul 13, 2012 6:07 pm

Re: Drifting pitch

Post by walkmanz »

yes orientation is as in faq and wiki.. the problem is not that pitch goes opposite direction but that it changes its value even I don't move my quad..

refractions
Posts: 92
Joined: Thu Dec 01, 2011 8:55 pm
Location: Scotter, Lincolnshire, UK

Re: Drifting pitch

Post by refractions »

I had this exact same problem and its your sensor orientation. The orientation changed between V1.9 and V2.0. I use a BMA180 instead of a nunchuck and I just had to rotate this 90 degrees.

Iain

walkmanz
Posts: 10
Joined: Fri Jul 13, 2012 6:07 pm

Re: Drifting pitch

Post by walkmanz »

ok I will try to change orientation of nunchunk but roll is working fine so I thought that it is correct.. thanks for answer.. I will check it out after some hours and then post the results..

walkmanz
Posts: 10
Joined: Fri Jul 13, 2012 6:07 pm

Re: Drifting pitch

Post by walkmanz »

Image

This is my sensor setup and as I can see in GUI all values ar responding as described in http://www.multiwii.com/faq .. but I has a lot GUI crash and it makes a lot of log error files.. sometimes it shows I2C errors too..

what I noticed was that ACC_Pitch reading value is not changing when I do not move my quad but on right where is displayed pich arrow, this arrow is floating.. you can see that in my previous video too..

Alexinparis
Posts: 1630
Joined: Wed Jan 19, 2011 9:07 pm

Re: Drifting pitch

Post by Alexinparis »

walkmanz wrote:This is my sensor setup and as I can see in GUI all values ar responding as described in http://www.multiwii.com/faq .. but I has a lot GUI crash and it makes a lot of log error files.. sometimes it shows I2C errors too..

I think the I2C errors are the first thing to solve. It could explain easily why the ACC data are corrupted.

signal15
Posts: 37
Joined: Sat Jun 23, 2012 8:44 pm

Re: Drifting pitch

Post by signal15 »

Make sure you follow the procedure for trimming the ACC mode also.

walkmanz
Posts: 10
Joined: Fri Jul 13, 2012 6:07 pm

Re: Drifting pitch

Post by walkmanz »

Alexinparis how can I do that? I looked in error log files but didn't understand what is the meaning of anything..

signal15 - I didn't understand what are you suggesting.. I calibrated my quad when it was standing on my table and I didn't try flying because of the wrong readings and GUI crashes.. If you are thinking about ACC triming on field, then I had no need for that..

chris ables
Posts: 317
Joined: Wed Feb 08, 2012 8:42 pm
Location: United states

Re: Drifting pitch

Post by chris ables »

My acc acts simular to that if i dont calibrate acc with tx sticks ! Do this with motors disarmed ! http://multiwii.googlecode.com/svn/bran ... 721566.pdf this link shows you how ! I have also heard to do this right after flashing firmware and before you use the button in gui to calibrate acc ! So you might want to reflash firmware and try this !

walkmanz
Posts: 10
Joined: Fri Jul 13, 2012 6:07 pm

Re: Drifting pitch

Post by walkmanz »

I tried.. Updated multiwii to 2.1 and acc calibration with Tx and nothing has changed.. I'm thinking that it is some kind off ACC error because it is some cheap chinese clone.. Ordered IMU, will see when it cames..

Post Reply