Naze32 - Are all boards prone to weird failures?!

Post Reply
Posts: 4
Joined: Tue Oct 07, 2014 1:36 pm

Naze32 - Are all boards prone to weird failures?!

Post by hndaluvr »

So I have 2 new AcroNaze32s... each of them have unexplainable

My setup is as follows: Blackout Mini H / Acro Naze32 / FrSky

Taranis Plus / FrSky X4R-SB / Cobra 2204 / AfroESC 12A

Board 1 - Unable to get Naze32 to work in PPM mode. I'm using the FrSky SBus->PPm converter, and have tried to configure PPM using both the latest firmware release (with the check-boxes) and the
previous version by way of CLI (Feature PPM) input.
I've even tried using the FrSky D4R-II PPM Rx directly... still no luck.
Board works perfectly with Spektrum Sat and traditional Rx connection, so don't know what the deal is with this.

Board 2 - PPM mode WORKS!... both with Direct PPM and SBus->PPM.
However, its issue(s) are VBAT readout is severely off (5.00V input voltage reads 3.8V). The telemetry output (Feature telemry) for FrSky does not output any data.
Additionally, the BIG issue just happened last night. After flying this board for nearly 15 flights, the board
inexplicably stops accepting ANY Rx data input!!!

During my flight, I landed momentarily and lowered the throttle to where the motors stopped spinning (but did NOT de-initalize
the motors). I went to take off again and the motors would not spin... and the RED LED was lit along with the blue. Unplugged
everything and re-plugged... Naze initialized but red and blue LEDs remained... no motor spinup.
So I connected to BaseFlight to take a look at my configuration and I see in the Receiver tab that there is NO Rx being seen by the unit. Re-bound the Tx and RX and checked with a spare servo that the TX/Rx side of things was working properly, and it was. I performed a reset on the Naze (which cleared all settings and config).
Reinitialized board and re-input all settings that i require... still NO Rx recongnized when receiver is attached to board (with either PPM, SBUs, or conventional Rx connection)!
Both boards initialize properly... accept firmware updates smoothly... CLI inputs are all excepted and confirmed in CLI window... and all gyro/accel seem to work properly.

Whats going on with these boards?!!

Need help timecop!

Posts: 1880
Joined: Fri Sep 02, 2011 4:48 pm

Re: Naze32 - Are all boards prone to weird failures?!

Post by timecop »

Um dude, something is definitely broken and it's probably not the naze. Not sure what to tell you tho, I have D4R-II and lots of people use those, I haven't dicked with taranis receivers, sbut stuff should work out of the box but you need one of ... cable.html to work.

Anyway, all weird shit, can't happen, most likely user error but I can't tell you what the error is - flash w/configurator using "erase full chip", make sure it's actually running oct1 or whatever is current firmware, post 'version' output from cli, but i'm guessing after the first few steps it will be working agian.

Posts: 4
Joined: Tue Oct 07, 2014 1:36 pm

Re: Naze32 - Are all boards prone to weird failures?!

Post by hndaluvr »

Thanks for the insight on the "erase full chip"... that fixed board #1 and i suspect board#2 as well, but have more verification to do.
As for the issue of the "No Rx signal received"... I now believe it to be the FrSky Sbus-to-PPM converter.

Thanks for your quick response... keep up the good work!

Posts: 76
Joined: Wed May 28, 2014 10:17 am

Post by kilby »

I did have a phase of my Naze dumping some settings a couple of months ago (just after a firmware update)

The erase full chip before a reflash made the difference, so I keep an eye on that sort of problem after any update these days.

Post Reply