Can not program MultiWii_32U4_SE from Arduino IDE

This forum is dedicated to all issues and questions related to your individual setups and configurations
Post Reply
Posts: 1
Joined: Thu Mar 31, 2022 10:15 am

Can not program MultiWii_32U4_SE from Arduino IDE

Post by mitakata »

Hi everybody,

I've searched for a solution , unfortunately didn't found anything here and in Arduino forums either.
The conditions:
I am working on MAC and the board connects correct (But try it on WIN computer with absolutely the same result). The issue that I have is:

avrdude: butterfly_recv(): programmer is not responding

The problem is described here: ... responding

and they (arduino) recommend pressing and holding the RESET button on Leonardo board till it starts uploading the FW. As I do not have a RST button, I am not able to follow this solution.
I've tried different cables, programmers and not success till now.
It is interesting to say, that the very first time I've pressed the "Upload" button it did uploaded the FW successfully.

Appreciate any Idea how I can proceed ...
Thanks in advance !!!
Screenshot 2022-03-31 at 11.37.06.jpg
Screenshot 2022-03-31 at 11.34.45.png

User avatar
Posts: 2571
Joined: Tue Mar 01, 2011 2:14 pm
Location: air

Re: Can not program MultiWii_32U4_SE from Arduino IDE

Post by Hamburger »

insert the usb connector as late as possible in the build/upload process.

Once you have a receiver attached (and the config menu in MultiWii enabled) it gets easier: enter the config menu via stick commands. While in there, uploading always works for me

Post Reply