Transmitter Trouble

This forum is dedicated to all issues and questions related to your individual setups and configurations
Post Reply
awoods177
Posts: 14
Joined: Mon Apr 30, 2012 10:08 pm

Transmitter Trouble

Post by awoods177 »

Hi Guys,

I am slowly learning about Multiwii and what not but when I mess with the throttle and other sticks on my transmitter in the config program I am only seeing ranges from 1071-1977 (similar on all sticks).

I've read about modifying values but I can't find anywhere in the code that deals with this sort of thing.

I can't seem to arm my quad because of this.

I'm using a basic 4 channel Tactic TTX404 transmitter/receiver combo.

Any ideas?

Thanks,
Alex
Last edited by awoods177 on Thu May 17, 2012 1:25 am, edited 1 time in total.

PatrikE
Posts: 1964
Joined: Tue Apr 12, 2011 6:35 pm
Location: Sweden
Contact:

Re: Transmitter Trouble

Post by PatrikE »

Look in the MultiWii Tab.

Code: Select all

// ******************
// rc functions
// ******************
#define MINCHECK 1100
#define MAXCHECK 1900

Adjust the values to match your radio.

/Patrik

awoods177
Posts: 14
Joined: Mon Apr 30, 2012 10:08 pm

Re: Transmitter Trouble

Post by awoods177 »

So change it to:

MINCHECK 1071
MAXCHECK 1977

Is this correct?
Last edited by awoods177 on Thu May 17, 2012 1:25 am, edited 1 time in total.

tovrin
Posts: 705
Joined: Tue Sep 20, 2011 4:08 pm

Re: Transmitter Trouble

Post by tovrin »

yes, that is correct. mine is set similarly.

awoods177
Posts: 14
Joined: Mon Apr 30, 2012 10:08 pm

Re: Transmitter Trouble

Post by awoods177 »

Should I use my absolute max/min values for all 4 channels (throttle, pitch, roll, yaw) or just the minimum from the throttle channel?

tovrin
Posts: 705
Joined: Tue Sep 20, 2011 4:08 pm

Re: Transmitter Trouble

Post by tovrin »

I'm not sure what your asking, but i set min and max on mine to match the gui readings of my TX min/max. i was unable to set trim before i did that.

PatrikE
Posts: 1964
Joined: Tue Apr 12, 2011 6:35 pm
Location: Sweden
Contact:

Re: Transmitter Trouble

Post by PatrikE »

If possible setup your radio to reach 1000 - 2000 µs on all cannels.
Then all functions and stickCombinations for Trimming the model will work.

awoods177
Posts: 14
Joined: Mon Apr 30, 2012 10:08 pm

Re: Transmitter Trouble

Post by awoods177 »

Well, I'm really new to the whole RC scene so I'm not sure how to setup the radio, or even if I CAN...its a pretty inexpensive Tactic TTX404 4-Channel transmitter. How would I go about adjusting the range? I can adjust the trim for the channel but that only moves the midpoint, giving me a lower low end, but also a lower high end...not increasing the overall range.

I set the MINCHECK and MAXCHECK to match the values on the GUI but it didn't help at all...motors are still not arming...

awoods177
Posts: 14
Joined: Mon Apr 30, 2012 10:08 pm

Re: Transmitter Trouble

Post by awoods177 »

Well I figured it out, in the GUI the three little boxes next to "ARM" were turned on, I turned them off and it worked. I also put MINCHECK = 1300 and MAXCHECK=1700 but I'm not sure if that helped or not.

hexjump
Posts: 39
Joined: Fri May 18, 2012 1:47 pm

Re: Transmitter Trouble

Post by hexjump »

awoods177 wrote:Well I figured it out, in the GUI the three little boxes next to "ARM" were turned on, I turned them off and it worked. I also put MINCHECK = 1300 and MAXCHECK=1700 but I'm not sure if that helped or not.

Yes it helps. You need a value under MINCHECK to arm your quad, but be careful if you have min value=1071 on your tx Yaw or Roll channels and you put MINCHECK=1300, there are 1300-1071=229 difference. You will turn off the motors easily during the flight.

Post Reply