MultiWii program seem to freeze

Post Reply
babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

MultiWii program seem to freeze

Post by babelo »

Hello,

I ran into a strange issue with multiwii program,sometimes it freeze very quickly and sometimes it freeze when flying. Program version is v1.7 .

Why i say it is frozen ? Because motors kept their PWM input, and as it is a tricopter, servo has kept its last position

Who is connected ? WMP + NunChunk, and it occurs also with only WMP

Also when i'm connected to GUI, if the problem occur, the serial dialog stop also.

What can happen ? If it is a low voltage issue, i think atmel will reboot completly , so PWM reset, it is not the case.

My last try for this evening is to try without receiver AR6100.

Did i miss something in settings ?

Thanks for reading

Alexinparis
Posts: 1630
Joined: Wed Jan 19, 2011 9:07 pm

Re: MultiWii program seem to freeze

Post by Alexinparis »

There is a function to reboot the WMP when an I2C freeze happens.
However, it does not work for every WMP clone and the freeze state can stay.
It is a clone ?

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

Hello,

Thanks for your answer.

It is not a clone it is a genuine version from Wii.

I set an interleave delay to 3300 and also tried a bigger value at 5000.

I see this function in action already, when motors are not armed, if i move tricopter, i can see the green led blinking for short time when servo does not respond.

It looks very strange as it happen often, my wire are short 5 centimeters max

Fabrice,

User avatar
captaingeek
Posts: 228
Joined: Fri Jan 28, 2011 6:42 pm

Re: MultiWii program seem to freeze

Post by captaingeek »

Check all grounds and wiring. Which schematic did you use? How are you providing power to the mw?

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

Alerady checked ground, i use FCWii schematic which is equivalent to arduino dualminove something like that, 16mhz quartz.

Power is provided through ESC.

User avatar
captaingeek
Posts: 228
Joined: Fri Jan 28, 2011 6:42 pm

Re: MultiWii program seem to freeze

Post by captaingeek »

OK can you send a link to that schematic because I dont know what that is. Are you powering from one ESC or all ESC's?

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

I use all three ESC, for schematic, i m looking for. PCB is this one http://fcwiiki.fpv4ever.com/index.php/M ... e_la_carte

thanks for your help

User avatar
captaingeek
Posts: 228
Joined: Fri Jan 28, 2011 6:42 pm

Re: MultiWii program seem to freeze

Post by captaingeek »

OK check out these schematics. Generally its recommened that you only use one of the ESC's BEC's.

http://www.rcgroups.com/forums/showthread.php?t=1340771

http://radio-commande.com/wp-content/up ... g-v1.3.jpg

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

Ok i think i found the problem.

Doing lot of test with a different board, with a different atmega328p...

With only one ESC without receiver but with servo.

With all ESC, without receiver, without servo, and all is good ...

So look like i have an issue with servo DS 928 BB.

I have many of them, tried 4 different, but still same issue.

What do you think ? servo drive to much power ? i can try a capacitor ?

For your information, board settings for compilation is PROMINI

ziss_dm
Posts: 529
Joined: Tue Mar 08, 2011 5:26 am

Re: MultiWii program seem to freeze

Post by ziss_dm »

Hi,
You can try to power up servo from another ESC ;)

regards,
ziss_dm

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

Yes it still look strange.

Just moving quickly radio rudder can hang the atmega.

If it is a power issue, why atmega does not reset and restart normally ?

I will try to power servo with one of the three ESC only

User avatar
Hamburger
Posts: 2559
Joined: Tue Mar 01, 2011 2:14 pm
Location: air
Contact:

Re: MultiWii program seem to freeze

Post by Hamburger »

ziss_dm wrote:Hi,
You can try to power up servo from another ESC


Yes, I strongly second that. It seems servos can draw high currents or introduce high freq noise.
Driving servo via separate bec solved some mysterious glitches for me

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

Ok i will try this evening, maybe adding a capacitor close to servo power pin too

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

Ok the capacitor was a really bad idea :)

But like ziss_dm says and as Hamburger confirm. I took the power from one of the three ESC and connected it directly to servo power.

Now all looks good :)

Tomorrow i ll do more test outside.

Thanks again

Fabrice,

babelo
Posts: 28
Joined: Wed Jul 06, 2011 12:56 pm

Re: MultiWii program seem to freeze

Post by babelo »

It fly very well, as i have made a minitri by using jakub frame, tri is very fast. but i need to
tweak settings a little more i think, it is far from my trex family copter tail heading hold in curve.

Anyway it is a very good project programming, i like the code, it is easy to understand.

Do you have settings for minitri ?

Mine are 1.3 0.030 16 for PID loop
and 4.3 for YAW i think this one is bad.

Also, what are your settings on your minitri for level mode ?

Thanks again

Fabrice

Post Reply