Multiwii Pro board & Mission planner GUI

Multiwii Pro board & Mission planner GUI

Postby snorkrc » Wed Mar 06, 2013 8:42 pm

Does the mission planner (http://code.google.com/p/arducopter/wiki/AC2_Mission) work with the hobbyking multiwii pro board?

If so, anyone have any tutorials? I've donwloaded the software and run it, but when I try to connect to my board it times out.

Thx
snorkrc
 
Posts: 14
Joined: Thu Feb 21, 2013 5:43 am

Re: Multiwii Pro board & Mission planner GUI

Postby subaru4wd » Wed Mar 06, 2013 9:29 pm

Mission Planner only works with Arducopter or the MegaPirateNG port.

MPNG will work on the MultiWii pro board, i suggest you check this thread here: http://www.rcgroups.com/forums/showthread.php?t=1752719
subaru4wd
 
Posts: 310
Joined: Sat Dec 08, 2012 2:16 am

Re: Multiwii Pro board & Mission planner GUI

Postby snorkrc » Wed Mar 06, 2013 11:07 pm

Thanks for the answer! However, I have tried going thru that tutorial a few times, but there's a couple things that baffle me. Maybe someone can help. He says:

"You need to copy from the zip file the code sub directory to the place Arduino keeps sketches which on Windows 7 is - Documents - My Documents - Arduino

You also need to copy from the zip file the LIBRARIES to the libraries folder of Arduino, in Windows 7 that is C:\Arduino-1.0.1\Libraries

That information is very standard Arduino stuff covered in Arduino tutorials.but it may not be obvious that you need to do that first."
Arduino isn't a program that's installed on you computer regardless of version of windows...you just run the executable. So where would you copy the libraries etc too?
I'm sure this is the wall I'm hitting. When I try to compile, it errors out because it can't find the libraries.

Should I just copy all the files in the MP library into the librarie folder in the arduino root folder?
snorkrc
 
Posts: 14
Joined: Thu Feb 21, 2013 5:43 am

Re: Multiwii Pro board & Mission planner GUI

Postby tovrin » Wed Mar 06, 2013 11:12 pm

no, arduino will look in these folders for the files it wants, create these folders in the locations stated and put the files needed there.

this IS very standard arduino stuff
tovrin
 
Posts: 705
Joined: Tue Sep 20, 2011 4:08 pm

Re: Multiwii Pro board & Mission planner GUI

Postby subaru4wd » Sat Mar 16, 2013 4:30 pm

snorkrc wrote:Thanks for the answer! However, I have tried going thru that tutorial a few times, but there's a couple things that baffle me. Maybe someone can help. He says:

"You need to copy from the zip file the code sub directory to the place Arduino keeps sketches which on Windows 7 is - Documents - My Documents - Arduino

You also need to copy from the zip file the LIBRARIES to the libraries folder of Arduino, in Windows 7 that is C:\Arduino-1.0.1\Libraries

That information is very standard Arduino stuff covered in Arduino tutorials.but it may not be obvious that you need to do that first."
Arduino isn't a program that's installed on you computer regardless of version of windows...you just run the executable. So where would you copy the libraries etc too?
I'm sure this is the wall I'm hitting. When I try to compile, it errors out because it can't find the libraries.

Should I just copy all the files in the MP library into the librarie folder in the arduino root folder?


It took me a while to figure this step out.

Look inside the Arduino program folder and you will see a folder inside there called LIBRARIES.

Now look inside the MPNG .zip you downloaded, and you should see a LIBRARIES folder. You need to replace the Arduino LIBRARIES folder with the one from MPNG. Then you can compile & upload the MPNG code.

Do not forget to edit config.h to suit your board before you upload.

If you want to switch back to MultiWii, you need to restore the stock arduino libraries folder.
subaru4wd
 
Posts: 310
Joined: Sat Dec 08, 2012 2:16 am

Re: Multiwii Pro board & Mission planner GUI

Postby snorkrc » Tue Mar 19, 2013 5:54 am

subaru4wd Thanks for you reply! Someone replied that it's standard Audrino stuff, but even after reading their instructions it wasn't clear! I finally found a post in french that I translated and it said to goto file, preferences and then change your sketchbook location to directory of the libarary file of the sketch you're trying to load. That worked for me! However, it seems to be very buggy. At work, I started from scratch on a different computer, but this method didn't work.

At some point I decided to rid my self of Megapirate and go try the latest version of multiwii. Couldn't get my quad to fly stable with the PID settings and was going through flying Withdrawals so I decided to load Megapirate back on and it wouldn't compile!!! Even though it compiled before on this compute with no settings changed. I messed around with the path to the libraries, tried it several times and finally it would rebuild! This program is very buggy for some reason....I don't understand why it doesn't seem to be a problem with others???? It's hit and miss for me. Sometimes it works and sometimes it doesn't.
snorkrc
 
Posts: 14
Joined: Thu Feb 21, 2013 5:43 am


Return to General discussions

Who is online

Users browsing this forum: No registered users and 1 guest

cron