Page 1 of 1

My X Copter always falling backwards

Posted: Tue Feb 22, 2011 3:29 pm
by Kayle
Hello,

I built my copter ready. When I tested him, he always tipped me to the back. When I connect the copter to the GUI I see when I give gas, the front right Motor turns higher and the rear left motor turns slower. I have calibrated it. The copter alwas stays at bottom. The motors are CF2822 1000 kV and Turborix 20A ESC. The problem is with and without Props. What can i do now ?

greetings
Kayle

Re: My X Copter always falling backwards

Posted: Tue Feb 22, 2011 7:23 pm
by kiliam
Hi
I am using an original wm+ and tried last weekend to put 2 diodes after d12 and because of that it became crazy, after arming motors and giving little throttle it made the rear left motor spin much more than the others. So much that it could turn it upside down if i let it.
I measured after that i was powering wm+ with only 3.14v.
Dont know if you have any diode at all.

Re: My X Copter always falling backwards

Posted: Tue Feb 22, 2011 10:57 pm
by Alexinparis

Re: My X Copter always falling backwards

Posted: Wed Feb 23, 2011 1:15 am
by Kayle
Hi Alex,

thanks for the link. What for a I-Term must i zero ?

Regards
Kayle

Re: My X Copter always falling backwards

Posted: Wed Feb 23, 2011 7:51 pm
by Kayle
Or is it zeroed by itself when it fly┬┤s ?

regards
Kayle

Re: My X Copter always falling backwards

Posted: Wed Feb 23, 2011 10:11 pm
by Alexinparis
yes, it's automatic when the control loop is active

Re: My X Copter always falling backwards

Posted: Thu Feb 24, 2011 12:04 am
by Kayle
ok alex. Thanks for reply.

Re: My X Copter always falling backwards

Posted: Wed Sep 07, 2011 10:23 pm
by dhirajjadhao
have you solved the problem because i am getting the same thing even after calibration of the gyro and acc.
my front right motor runs faster than the other and the left rear motor runs slower as compared to other taking the quad to back and left on roll axis.
i am using the setup of WiiMotion+ with Nunchuk from nintendo.
Pls Help me out what should i do to get my quad stable.

regards
Dhiraj

Re: My X Copter always falling backwards

Posted: Thu Sep 08, 2011 3:19 am
by cardboard
have u trimmed the radio??
that or you can look at these 2 threads for inspirations.
http://www.multiwii.com/forum/viewtopic.php?f=8&t=671
http://www.multiwii.com/forum/viewtopic.php?f=8&t=677

Re: My X Copter always falling backwards

Posted: Fri Sep 09, 2011 6:45 pm
by dhirajjadhao
i tried to do that but it does not help out.
today i connected the board with GUI and gave the throttle but it seems in the GUI itself that the throttle given to the front right motor is higher than the other and the throttle to the rear left motor is lower than the other and remaining two motor runs with the same throttle.
i have balanced the props and motor.
I have even changed and try the same board with other setup but the pictures on the GUI is Same.
i think there should be some alteration with the code or what should i do.

Experts pls help me out with the condition.

Dhiraj

Re: My X Copter always falling backwards

Posted: Fri Sep 09, 2011 9:17 pm
by PatrikE
I had some problems like that to.
I had set MINTHROTTLE to low!

When i pitched back the rear engine went to low.

Try to inrease MINTHROTTLE.

Re: My X Copter always falling backwards

Posted: Wed Sep 14, 2011 9:49 pm
by dhirajjadhao
ok thanks patrike i will do it now and will let you know the updates

Re: My X Copter always falling backwards

Posted: Thu Sep 15, 2011 12:15 am
by captaingeek
alex's link to the faq post was indicating that this is normal behaviour and should be ignored:

The motor output on the GUI is not equal on both sides with a neutral RC input

This is the normal PID loop behaviour, the I-term is actually cumulating the error over time & tries to compensate for that but the copter is hand-held or fixed on the table.
When the I-term is zeroed, the this will not happen.
A flying multicopter will actually use the I-term in the PID to correct itself again to the same level as before the disturbance.

Re: My X Copter always falling backwards

Posted: Sun Sep 18, 2011 7:31 pm
by dhirajjadhao
i didn't get this PID tuning theory.
According to it i have Increased P term untill the quad start to oscillate and ruduced a bit.
But what about the I and D terms how to set them for stability?
i want to tune the quad for stable mode.
With the current PID setting my quadrotor takes off and then start a Backward drift for that i trimmed the quad in ACC mode
but even trimming it upto it's end point it still have backward drift.
So guys can you pls guide me with how to tune with I and D terms and how to stop backward drift.
my current PID valus are
P I D
Roll 6.9 0.010 12
Pitch 6.9 0.010 12
Yaw Default

Help