Search found 75 matches

by hwurzburg
Tue Mar 17, 2015 12:04 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

yes or via any + - on output rows to far left....like from an esc bec output
by hwurzburg
Mon Mar 16, 2015 11:30 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

That will work...it doesn't power the board however...power for the board can be supplied (5V) on the motor output side or via the pin next to "1" on the input side (dot)....those pins you show just monitor bat voltage for telemetry and low bat beeper function...IF, feature VBAT is enabled...
by hwurzburg
Tue Jan 27, 2015 11:25 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

if you want PosHold, Althold and Waypoints and Autonomous...get an APM2.6 with external GPS/Compass....it works well...and is almost at the completely phone/pad control stage now....(I use an RC as a 'just in case') but fly my APM ZMR250 from my Android phone without touching the RC TX (I have 900MH...
by hwurzburg
Sun Jan 25, 2015 7:51 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

I'll try to help....as I understand things...the Specktrum SAT RX is 115.2Kbaud....must be attached to a hardware uart (although they are working on getting softserial ports running over 19.2K...not there yet)....so USB (ie MSP/CLI) on port 0, SAT RX output on port2 (RC input pin 4), and GPS on one ...
by hwurzburg
Mon Dec 15, 2014 10:48 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Sounds like it...the board's 3.3V regulators are powered thru two diodes...one to the USB 5V and the other to the ESC BEC 5V input....sounds like the ESC BEC input diode is blown
by hwurzburg
Sun Dec 07, 2014 4:18 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Not on Softserial with Baseflight...you can do it with Cleanflight...by setting one softserial port to output MSP protocol....unfortunately, max baudrate for softserial ports, at least at the present, is 19200 baud...so setting that for MSP also means that will be the rate for USB connections also (...
by hwurzburg
Tue Dec 02, 2014 1:52 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

What you call manual is generally referred to as "Acro"....and uses the basic PID controller in the firmware...so, yes, its PIDS are important...they are the yaw,pitch, and roll pids in the gui... in leveling modes, such as angle or horizon, an additional loop is run around the rate (aka a...
by hwurzburg
Mon Dec 01, 2014 9:13 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

@hwurzburg - How do you change the GSV message so that BF shows sat strength? Thanks. yeah, changing gps TIMEPULSE config only affects the gps modules led flashing...your module apparently has two leds...mine only one... as to GSV message: just double click that message in messages view(it was grey...
by hwurzburg
Sun Nov 30, 2014 12:25 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

I've got a problem with the GPS functionality I'm hoping someone can help with... I'm running a full Naze32 and Neo-6M GPS. In baseflight I can see 9 satellites but no flashing red light on the naze32, or at least I can't detect that it's flashing. its hard to tell its flashing....it a very quick &...
by hwurzburg
Sat Nov 29, 2014 1:01 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Hi, Is the naze32 serial port, the one I'm connecting to KV-OSD , 5 V compatible? ............. Thank you UART port1 (the one used by USB FTDI chip, and RX for sat in, TX pad which is also inverted for TELEM pin) is 5v tolerant....UART2, ie RC3/4 is not, but most 5V GPS are 3V signal level outputs ...
by hwurzburg
Fri Nov 28, 2014 1:19 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Naze32 has just one serial port. It is shared. Incorrect...it has 4: Port1 is a hardware UART.When USB is connected,it uses that port...it can be used for BT,OSD, orTelem, when not connected to USB. Port2 is also hardware and is used for gps on pins 3/4 when cppm is used, which also allows use of t...
by hwurzburg
Sun Nov 16, 2014 2:48 pm
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255333

Not able to reconnect

Running latest BF on a NAZE32 r5 board....After power up, I can connect via BT to this app on my phone without issue and all works well....but if I disconnect and then reconnect...the BT connects, but I get a constant stream of "No data received errors"....I have tried just repowering the ...
by hwurzburg
Wed Nov 12, 2014 9:17 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

Dominic, I updated the serial.md docs file with the information you provided above... changes in green ...thanks Henry cant attach the file so here is the changes: ### Con s traints * There must always be a port available to use for MSP * There must always be a port available to use for CLI * To use...
by hwurzburg
Tue Nov 11, 2014 1:45 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Uncommanded Yaw

As I started pushing this little Armattan mini quad, I started getting some uncommanded yaw right issues...first showed up in fast coordinated turns...then just in fast climbs...and then after stationary rolls....never noticed just tree dodging, but only after passing 60% throttle or so...no yawing ...
by hwurzburg
Sun Nov 09, 2014 3:27 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

Latest binaries are now available Softserial fixed. CC3D supports 4 channel parallel PWM mode. Rate profiles. Adjustment Range support added for in-flight tuning and rate profile switching. Various cleanups and improvements. Dom,thanks for fixing softserial! and all the work! with 41souths' serial ...
by hwurzburg
Thu Nov 06, 2014 4:42 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

Latest binaries are now available Softserial fixed. CC3D supports 4 channel parallel PWM mode. Rate profiles. Adjustment Range support added for in-flight tuning and rate profile switching. Various cleanups and improvements. Dom,thanks for fixing softserial! and all the work! with 41souths' serial ...
by hwurzburg
Thu Nov 06, 2014 3:01 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Not sure BF has GPS_SBAS_MODE clisetting....joblessflight does, however protip, if you're not sure of something, not posting would be a better solution. protip....not being listed in CLI dump (ver I am using is a few months old) and, more importantly, not being listed in documentation : m means tha...
by hwurzburg
Wed Nov 05, 2014 4:30 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Not sure BF has GPS_SBAS_MODE clisetting....Cleanflight does, however
by hwurzburg
Wed Nov 05, 2014 1:49 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

thanks hwurzburg I've got it working now. It appears that something in my office is making the UBLOX receiver a bit deaf. It works OK with the U-center app but seems to take a lifetime to acquire any sats when connected to the Naze. I left it on for an hour and it has a lock now. I think I might in...
by hwurzburg
Tue Nov 04, 2014 11:44 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Be aware that Baseflight reconfigures Ublox upon detection but does not save it in the GPS..so the config you see in Ucenter is not exactly what is being used..some things you set in Ucenter..like the sat rssi message are not impacted ...just noticed this once reading the code
by hwurzburg
Tue Nov 04, 2014 1:39 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

UBLOX gps is powered by 5V but signals compatible with either 3.3V or 5V systems...
by hwurzburg
Sun Nov 02, 2014 1:34 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

If that is really how you have things hooked up, you have problems.... 1. the Video side of the MINIMOSD needs either 12V, or you solder some tiny solder pads bridging input side to output side (5V and gnd) on the board and do not connect ANY power to the video side of the board. 2. the data side of...
by hwurzburg
Sun Nov 02, 2014 1:10 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

I have the Naze on a tri with flexible landing gear. When the board is armed the yaw servo will start bouncing causing the frame to move inducing more bounce. The yaw PID settings are not excessive and the tri flies great. Is there a setting that will "turn off" the yaw gyro at low thrott...
by hwurzburg
Wed Oct 29, 2014 1:05 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

Need help please - my quad is too fast I just finished a build and it seems the quad is too light for the thrust available. As a result I barely get 1/4 throttle and the quad is hovering - half throttle and the quad is outta there. The issue I have is that it is VERY hard to get down now Pretty muc...
by hwurzburg
Sat Oct 25, 2014 5:27 pm
Forum: Software
Topic: Baseflight aka multiwii port to stm32
Replies: 1036
Views: 2309568

GPS fix not being reported correctly in Config

Just put a UBLOX NEO-6M gps on my NAZE32 with cleanflight... In the Config GPS tab, its showing 7 sats indoors,and the correct LAT/LON...but the FIX is flashing alternatively on and off....the fix led on the GPS is blinking, indicating 3DFIX....and if I put the GPS on U-Center, it also shows 7 sats ...
by hwurzburg
Sat Oct 25, 2014 5:27 pm
Forum: Software
Topic: Baseflight aka multiwii port to stm32
Replies: 1036
Views: 2309568

GPS fix not being reported correctly in Config

Just put a UBLOX NEO-6M gps on my NAZE32 with cleanflight... In the Config GPS tab, its showing 7 sats indoors,and the correct LAT/LON...but the FIX is flashing alternatively on and off....the fix led on the GPS is blinking, indicating 3DFIX....and if I put the GPS on U-Center, it also shows 7 sats ...
by hwurzburg
Fri Oct 24, 2014 3:43 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

But here is a question for you hwurzburg. If Tx subtrims/endpoints are used to make the throttle range say 1000 - 2000 and the MINTROTTLE MAXTHROTTLE is set to say 1100 - 1900, does this mean there is a 100 deadband on the top and bottom side, or does the FC scale the 1000 -2000 input to match 1100...
by hwurzburg
Thu Oct 23, 2014 11:15 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Re: Naze32 hardware discussion thread

FC scales throttle between MINTHROTTLE and MAXTHROTTLE(if armed and actual throttle is above MINTHROTTLE)...scales again for MIDTHROTTLE and EXPO...then sends throttle and PID error terms to mixers and on to motors... and the diagram is a little off....active stablization (acc and/or gyro) only beco...
by hwurzburg
Tue Oct 21, 2014 1:38 am
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

NAZE32 rev 5 Buzzer output driver

I notice in the code that Rev5 changed the buzzer output from a PNP (which would be limited to ~7.3v max being driven from a 5V tolerant uP output) to an NPN driver....which,depending on transistor specs, allows a higher voltage (>5V) buzzer to be attached...however, the manual still states 5V max.....
by hwurzburg
Tue Oct 14, 2014 10:17 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

Hi Dominic, i have your latest hex flashed to my NAze32 Rev3 and want to enable Telemtry, but it´s not working. I have a FRSKY D8R-II RX and enabled RX_PPM/GPS/SOFTSERIAL/TELEMETRY Set´s are frsky_inversion = 1 telemetry_provider = 0 When these Parameters are enabled my GPS lost Signal. I have sold...
by hwurzburg
Mon Oct 13, 2014 1:30 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

SONAR Questions: 1. Someone posted a video on the NAZE32 thread showing SONAR operating from the motor pins with PPM feature enabled....the docs imply that PPM requires it to be connected to the RC7/8 pins. 2. That video showed that SONAR could be used WITHOUT BARO and that it would switch to norma...
by hwurzburg
Mon Oct 13, 2014 1:28 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

Except for the AUX setup,until the app catches up or backward compatibility is restored, MultiWii EZGUI will let you do about anything the config will except flash firmware...
it runs on any Android OS....even has the CLI function
by hwurzburg
Mon Oct 13, 2014 1:02 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

SONAR Questions: 1. Someone posted a video on the NAZE32 thread showing SONAR operating from the motor pins with PPM feature enabled....the docs imply that PPM requires it to be connected to the RC7/8 pins. 2. That video showed that SONAR could be used WITHOUT BARO and that it would switch to normal...
by hwurzburg
Mon Oct 13, 2014 12:57 pm
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

Here's a video showing the channel mode ranges in action! WXsZWLdUwwY m Looks great Dominic! A suggestion: Perhaps it would be good to make this AUX behavior an expanded feature, ie FEATURE EXPANDAUX, keeping the old three way operation as is, in addition to this new feature... that would allow bac...
by hwurzburg
Thu Oct 09, 2014 8:03 am
Forum: Software
Topic: Cleanflight aka Multiwii port to STM32 F10x and F30x
Replies: 761
Views: 1355108

Re: Cleanflight aka Multiwii port to STM32 F10x and F30x

Can the SONAR sensor be used when SOFTSERIAL and RX_PPM are enabled? I imagine you have to be sure to set UART4 to the UNUSED scenario to connect the RC7/8 pins to the sonar sensor if SOFTSERIAL is active,correct? fyi, I am also using FRSKY telemetry on UART3....it seems that its baud rate is contro...
by hwurzburg
Sun Aug 03, 2014 10:09 pm
Forum: Boards
Topic: Naze32 hardware discussion thread
Replies: 3249
Views: 675993

Throttle midpoint and TPA

After a lot of searching I found that setting the Throttle midpoint in the config does nothing unless you also have Throttle expo.... very disappointing, but easily overcome with TX curves if you are lucky enough to have such...I prefer linear throttle "curves" on my minis but my problem i...
by hwurzburg
Thu Dec 20, 2012 12:35 am
Forum: Software development
Topic: Conf only works once after flashing firmware
Replies: 7
Views: 587

Conf only works once after flashing firmware

Using Multwii 2.1 in X-quad...flashes fine and works well...however, config tool only works ONCE after flashing the firmware....if I power down and re-attach and restart Conf 2.1, I get com attached, but straight lines on gryos,etc. after starting....if I reflash, then restart Conf program, it works...
by hwurzburg
Fri Jul 06, 2012 11:38 pm
Forum: Software development
Topic: Airplane mode
Replies: 512
Views: 88085

Re: Airplane mode

thanks PartikE....loving WinMerga...just what I needed....
by hwurzburg
Fri Jul 06, 2012 10:48 pm
Forum: Software development
Topic: Airplane mode
Replies: 512
Views: 88085

Re: Airplane mode

Well, I'm back playing with the MultiWii in a plane...a flying wing this time.... making code modifications.... 1. Arm on powerup _ DONE 2. Changing the throttle attenuation curve to start at 1/4 throttle instead of 1/2 throttle....my wing cruises at 1/4 throttle and will oscillate at 1/2 throttle w...
by hwurzburg
Sun May 06, 2012 5:58 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

yep, like I said... all my boxes are checked in AUX1...wanted three active flight modes in that AUX...wont arm, unless you make my code change...then it arms without having to toggle to an UNarm box first...and wont disarm by stick command accidentally in the air... my setup was...AUX1: low= passthr...
by hwurzburg
Fri May 04, 2012 10:49 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

Surely this has been noted on the multis also somewhere? running autolevel..doing FF, make a smooth turn with bank and yaw and it does level? however, on a multi you would need to keep feeding yaw for coordination after releasing the stick...not likely....immediately you would start slipping in the ...
by hwurzburg
Fri May 04, 2012 10:46 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

I think I needed to use if (axis==0)....duh...told you its been years..
by hwurzburg
Fri May 04, 2012 10:30 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

duh! I'm a full scale pilot ! I should have guessed that from my unusual attitude training! if my inner ear cant tell when I'm in a mild coordinated turn, then this board sure cant either......then how in the world do the other stabilizers manage it? my RVOSD in fly by wire mode will level the wings...
by hwurzburg
Fri May 04, 2012 5:59 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

today result is I still have roll micro wobbles, but no sustained oscillations in gyro mode with roll 3-0-25....tried more D,up to 40...just oscillations at high speed.. -next outing I will lower Roll P some more....but I dont want to lose the gyro smoothing in turbulent wind (this week is 12mph gus...
by hwurzburg
Fri May 04, 2012 2:36 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

I am sure that my issues are not vibration related...but thanks anyway... studying the code I have determined a couple of things: 1. Level D term value is not a derivative gain term...its a max value cap on the Level error input to the inner gyro loop...it has no derivative effect on angle errors......
by hwurzburg
Thu May 03, 2012 11:26 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

Thanks...I have tried all those combos including desktop runup...except higher averaging values...but why would it try to actually hold the new bank angle in level???
by hwurzburg
Thu May 03, 2012 10:25 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

okay, I've tweaked to the best of my ability on the Funjet....working OK....but not as good as I want or as good as ET guardian or RVOSD stabilization... the Funjet is setup as a "lite" version with a smaller motor for endurance (I get 20+mins at 1/2 throttle cruising at 45mph) Vibration i...
by hwurzburg
Wed May 02, 2012 4:04 am
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

Been flying it several times....I started with default PIDs for gyro and I got tiny, sporadic, low magnitude, very fast roll oscillations...at first I thought it was vibration, but it increased with increased airspeed, even with throttle idle(ie dives)...so its PID loop gain...reduced I and D to 0, ...
by hwurzburg
Sun Apr 29, 2012 3:12 pm
Forum: Software development
Topic: Flying Wing - development done?
Replies: 107
Views: 22398

Re: Flying Wing - development done?

Sorry but you are incorrect....try it...I have many times...