Search found 171 matches

by spagoziak
Thu Nov 05, 2015 11:52 pm
Forum: Getting Started - MultiWii config and setup
Topic: How to mount Multiwii Board along inside of plane
Replies: 0
Views: 426

How to mount Multiwii Board along inside of plane

Hello everyone, I'd like to stuff an extra crius se .2 board I have into a small plane. The board will not fit flat on the bottom like you would normally set in a multirotor. However the body is tall enough to mount the board sideways along the inside wall of the body. This obviously fusses with the...
by spagoziak
Thu Nov 05, 2015 4:44 am
Forum: Getting Started - MultiWii config and setup
Topic: Want complete guide to FC board mounting orientation values
Replies: 6
Views: 882

Re: Want complete guide to FC board mounting orientation val

Hamburger,

Does that mean that mounting my crius se board on its side along the inside of a plane is impossible? There's no way to adjust sensor orientation by 90 degree increments in the code?

spag
by spagoziak
Thu Nov 05, 2015 12:14 am
Forum: Getting Started - MultiWii config and setup
Topic: Yaw creep in airplane acro/horizon mode
Replies: 2
Views: 504

Re: Yaw creep in airplane acro/horizon mode

Oh great! I'll do that tonight and report back.

Thanks Patrik!
by spagoziak
Wed Nov 04, 2015 6:07 am
Forum: Getting Started - MultiWii config and setup
Topic: Yaw creep in airplane acro/horizon mode
Replies: 2
Views: 504

Yaw creep in airplane acro/horizon mode

Hello folks, I just installed MW 2.4 into a plane I had laying around; no GPS, just the board (a crius SE v0.2). Things look great on the bench except one thing: While in acro or horizon mode, the rudder will shift all the way to one side (the lower numbered value). This can be corrected by nudging ...
by spagoziak
Sun Aug 18, 2013 10:17 pm
Forum: MultiWii tweaking - flying experience
Topic: Multiwii 2.2 - GPS hold
Replies: 93
Views: 102385

Re: Multiwii 2.2 - GPS hold

I have the same experience--if the quad is blown too far away from its GPS hold point, it will suddenly and violently pitch toward the hold point, most certainly bound to crash if I don't intervene. Why doesn't the response scale smoothly from gentle to severe as the error increases? It was graduall...
by spagoziak
Mon Apr 29, 2013 2:07 am
Forum: Shields, boards and sensors
Topic: Holybro HK 328P Uploading Errors
Replies: 2
Views: 1034

Re: Holybro HK 328P Uploading Errors

I had the same issue, but with the Crius Lite board. Your solution plus a bit extra solved it for me, too. In addition to removing the AUX2 connection to the receiver, I had to disconnect power to the receiver and my attached UART bluetooth module altogether. Once it was just the board all on its ow...
by spagoziak
Tue Apr 09, 2013 9:24 pm
Forum: Frames
Topic: [solved] Accelerometer Drift--caused by Vibration?
Replies: 1
Views: 2691

Re: Accelerometer Drift--caused by Vibration?

I figured it out!

There was *too much* padding on that board. I removed the layers of black foam pictured above and tightened the board down on the arms. Problem solved.
by spagoziak
Sun Apr 07, 2013 5:57 am
Forum: Frames
Topic: [solved] Accelerometer Drift--caused by Vibration?
Replies: 1
Views: 2691

[solved] Accelerometer Drift--caused by Vibration?

Hello folks, After doing a complete overhaul on my mini quad, I rebuilt the core of my frame--new foam tape, new craft foam on top. The trouble is this: now the quad drifts pretty seriously in random directions when hovering in level or horizon mode. Acro mode is 100% perfect. No listing, no shudder...
by spagoziak
Tue Jan 01, 2013 10:33 pm
Forum: Shields, boards and sensors
Topic: Serial Bluetooth RF Transceiver Module RS232
Replies: 154
Views: 79789

Re: Serial Bluetooth RF Transceiver Module RS232

I struggled with this for several days, but got it working in end. Here's what I did: Make sure the bluetooth module is unpaired--so unpair your phone/laptop from it so it's not bound to any bluetooth radios. The BT module won't interact with you on the serial port whatsoever if it's paired with som...
by spagoziak
Tue Dec 11, 2012 5:47 am
Forum: Shields, boards and sensors
Topic: I2C OLED thread
Replies: 62
Views: 31671

Re: I2C OLED thread

Hi folks, I didn't do enough research before I got the Crius CO-16 v1.0, so when I enabled the defines below, as you might have guessed, NOTHING happened on that screen. No light, no dots, nothing. It's plugged into the usual Crius SE. Is this likely the 100ohm resistor + reset issue described above...
by spagoziak
Thu Nov 22, 2012 6:25 pm
Forum: MultiWii tweaking - flying experience
Topic: MWC Config Survey Updated
Replies: 0
Views: 495

MWC Config Survey Updated

Hi folks! It's been a long time since I've been to this thread--took a break to work on a Skywalker & Arduplane. I just built a tiny quad and realized that the survey I built last year has grown out of date. Not any more! If you haven't thrown in your best config yet, head over and add it. The p...
by spagoziak
Sat Dec 31, 2011 3:17 pm
Forum: Software development
Topic: Unusually Slow Frame Rate on GUI?
Replies: 3
Views: 510

Re: Unusually Slow Frame Rate on GUI?

Ahh interesting, I'll check it out! Thanks Alex :)
by spagoziak
Fri Dec 30, 2011 3:48 pm
Forum: Software development
Topic: Unusually Slow Frame Rate on GUI?
Replies: 3
Views: 510

Unusually Slow Frame Rate on GUI?

Hey folks, I just ran the gui on a new laptop and discovered the frame rate is dramatically slower than on my desktop or my older laptop. It's probably 5-8 fps, where my other machines would run it at 30-50. Direct x is up to date, at 11. Running Win 7 on the new laptop (also on desktop), vista on o...
by spagoziak
Wed Dec 07, 2011 7:06 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

A magnetometer is required for head free mode, right?
by spagoziak
Wed Nov 30, 2011 10:41 pm
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

Great to have so many folks verify this! That really narrows it down to my BMA. I actually have another one on a friend's controller... I'll push my 1.9 config there and see if I get a different result.
by spagoziak
Thu Nov 24, 2011 5:21 pm
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

After a just-in-case hand test, I lifted it off in the living room, only 8x8 feet of room. Solid as a stone That is excellent. While I was bench testing the code, I noticed something interesting: tilting the mwc past 90 degrees stopped the gyro from working. The graph wouldn't update changes and th...
by spagoziak
Wed Nov 23, 2011 8:23 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

How many times have 1.9 been fixed and reuploaded without any obvious changes to the naked eye? I have 1.9 on all my Arduinos (5 in total) but I have no clue at all WHICH version of 1.9 they are running... I suggest start naming them accordingly 1.9 (release) 1.9.1 (bug fixes) 1.9.2 (bugfixes) 2.0 ...
by spagoziak
Wed Nov 23, 2011 4:42 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

Here's what's different: [*]I downloaded 1.9 fresh from the repository. [*]I replaced the included sensors.pde with the one Alex posted here [*]I //commented out and disconnected my BMP025... If you "updated" the latest V1.9 code with that particular patch from Alex then you will NOT see ...
by spagoziak
Tue Nov 22, 2011 6:57 pm
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

While I was searching the thread for some clue about what you mean by ST1 and 2, I found Alex's code (below) and figured I'd give it a shot... Went' from 50,000 errors in 30 seconds to 0 in 10 minutes, according to debug2 on the GUI @ version 1.9! If you fixed this without any hardware changes then...
by spagoziak
Tue Nov 22, 2011 5:23 am
Forum: Software development
Topic: I2C R/W Test. Debug code posted here.
Replies: 31
Views: 6566

Re: I2C R/W Test. Debug code posted here.

[quote="Alexinparis"]Hi Thomas, I think I found something very interesting tonight. [snip] But if we don't wait for the STOP command acknowledgement , it works very well. All my bad clones are now usable without any risk to freeze ! And the best: it works also very well with every other I2...
by spagoziak
Tue Nov 22, 2011 5:22 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

I use genuine Wmp and bma020 without problems but I also use baro and mag. Additional homework items for Stalk, Spagoziak, and jevermeister: 1. On the BMA020 schematic is a pair of I/O wire connection areas labeled ST1 and ST2. Please post the details to where you have connected each of their five ...
by spagoziak
Wed Nov 16, 2011 6:15 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

I'll get workin on that homework but I won't be able to post results till tomorrow! Thank you for your help, Thomas!
by spagoziak
Tue Nov 15, 2011 2:22 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

ok another try: TWCR = (1<<TWINT) | (1<<TWSTA) | (1<<TWEN) ; // send REPEAT START condition -> TWCR = (1<<TWINT) | (1<<TWSTA) | (1<<TWEN) | (1 << TWSTO) ; // send REPEAT START condition I've finally had a chance to try this too... the issue still persists for me. I'm using the 1.9 version from this...
by spagoziak
Sun Nov 13, 2011 4:39 pm
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

Stalk wrote:Hi all,
In version 1.9 I have no response from WMP (original) in the GUI. BMA020 shows movement. With ITG3200 BMA020 the response from both.
In previous versions, everything was OK.
Thank you for your help.


I have the exact same issue! Not sure what to do about it except return to 1.8p2 :(
by spagoziak
Sun Nov 13, 2011 6:30 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

Do I have to uncomment the WMP now, in 1.9? Same as before, the WMP will be automatically chosen if you have not defined the other two gyros choices (ITG3200 or L3G4200D) in config.h. Things to do/check (all things you probably already know, but it is good to check them all again). 1. Visit config....
by spagoziak
Sun Nov 13, 2011 1:55 am
Forum: Software development
Topic: MultiWii 1.9
Replies: 211
Views: 36435

Re: MultiWii 1.9

I upgraded from 1.8p2 to 1.9 and found that my gyro lines in the GUI all remained at 0 no matter what was done to the copter. The acc lines/values showed proper operation. The LED on the ard was lit solid green--nothing would alter its behavior, so arming wasn't possible. However, the GUI would allo...
by spagoziak
Mon Oct 24, 2011 4:07 am
Forum: Shields, boards and sensors
Topic: BlackVortex Board from CSG_EU _ update 20120528dev
Replies: 6
Views: 2143

Re: BlackVortex Board from CSG_EU

Thanks for the info, Cob!
by spagoziak
Tue Sep 27, 2011 5:04 pm
Forum: Shields, boards and sensors
Topic: BlackVortex Board from CSG_EU _ update 20120528dev
Replies: 6
Views: 2143

Re: BlackVortex Board from CSG_EU

Have you had a good experience with the developer of this one? The board looks great, almost too great lol
by spagoziak
Mon Sep 19, 2011 7:00 am
Forum: Software development
Topic: Dev 9-3-2011
Replies: 11
Views: 1462

Re: Dev 9-3-2011

Oops typo! So I flew both codes tonight and video'd them. However, I'm not seeing much of a difference between the two now, so I need to make sure I didn't make a mistake and upload the same code twice, or something equally as silly. For what it's worth, there's a chance that my observations happene...
by spagoziak
Sun Sep 18, 2011 3:45 pm
Forum: Software development
Topic: Dev 9-3-2011
Replies: 11
Views: 1462

Re: Dev 9-3-2011

I'm using an original wmp and a bma020 on 1.8 dev 9-13 with 1.7 stab enabled. It flies perfectly :)
by spagoziak
Sun Sep 18, 2011 6:02 am
Forum: Software development
Topic: Dev 9-3-2011
Replies: 11
Views: 1462

Re: Dev 9-3-2011

Alex, while I agree that leaving the 1.7 chunk in would be lovely, I fully understand your motivation to figure out how the 1.8 stab code can be improved. Tomorrow night I hope to do comparison hovering (and a tiny bit of forward flight) in a store after it's been closed for the night. There will be...
by spagoziak
Sat Sep 17, 2011 3:06 pm
Forum: Software development
Topic: Dev 9-3-2011
Replies: 11
Views: 1462

Re: Dev 9-3-2011

I was pretty tired when I posted this last night, I probably didn't make much sense The quality of the PID changes in 1.8 (vs 1.7) is amazing; definitely the best yet. I found the change in 1.8p2 to be ineffective, surprisingly. I didn't do much forward flight, though, I only had a few minutes to fl...
by spagoziak
Sat Sep 17, 2011 6:35 am
Forum: Software development
Topic: Dev 9-3-2011
Replies: 11
Views: 1462

Dev 9-3-2011

Alex, I tried this dev version today, with the 1.7 stab code enabled. It's the best that MWC has flown to date--the stab code of 1.7 is predictable and understandible. It doesn't drift, and doesn't seem to have tuning characteristics different from the YawPitchRoll PID set. More P makes it wobble to...
by spagoziak
Sat Sep 10, 2011 6:45 am
Forum: Frames
Topic: Is an Octo H Frame type supported by the MWC?
Replies: 8
Views: 2995

Re: Is an Octo H Frame type supported by the MWC?

Ohhhh wow that's brilliant! Alex is really incredible...

What about the 2nd code chunk you posted, regarding mixing? What does that line mean?
by spagoziak
Fri Sep 09, 2011 9:56 pm
Forum: Frames
Topic: Is an Octo H Frame type supported by the MWC?
Replies: 8
Views: 2995

Re: Is an Octo H Frame type supported by the MWC?

That is cool! Can you explain more about this code snip? Are there recommendations for how to mix an H8 so pitch = pitch and roll=roll?
by spagoziak
Fri Sep 09, 2011 7:25 pm
Forum: Frames
Topic: Is an Octo H Frame type supported by the MWC?
Replies: 8
Views: 2995

Re: Is an Octo H Frame type supported by the MWC?

Thanks Patrick! Is it really this simple? What are those adjustments.. some sort of PID bias?

Do you know of anywhere I can find better pictures of this sort of frame, or perhaps even a build log?

thanks!
spag
by spagoziak
Fri Sep 09, 2011 5:52 am
Forum: Frames
Topic: Is an Octo H Frame type supported by the MWC?
Replies: 8
Views: 2995

Is an Octo H Frame type supported by the MWC?

Hey folks,

I'm interested in building an octo for some AP this winter, and while the grid frame (think of an #) is nice, I'm really intreigued by the 8H format. This is what I'm thinking of:
Image

Does the MWC support it?

spag
by spagoziak
Tue Sep 06, 2011 5:28 am
Forum: Ideas
Topic: Gimbal control
Replies: 6
Views: 4511

Re: Gimbal control

With a mega, I can have a pitch and a roll channel assigned to a gimbal, where the MWC will stabilize those channels, even if they're receiving rate adjustments from a gimbal pitch & gimbal roll input on the board? yes, it's exactly like this description. That is marvelous! I was hoping so.. it...
by spagoziak
Mon Sep 05, 2011 3:41 am
Forum: Ideas
Topic: Gimbal control
Replies: 6
Views: 4511

Re: Gimbal control

spag, two receiivers attached to one MultiWii? You want the inputs to control movement instead of position? Is that it? first order instead of zero order? If desired, how would the operator force a return to level position? Sorta, but not quite! One operator would pilot the MWC as normal, via FPV. ...
by spagoziak
Fri Sep 02, 2011 8:43 am
Forum: Ideas
Topic: Gimbal control
Replies: 6
Views: 4511

Gimbal control

Alex, is it possible to add manual RC control to the gimbal servos? Here's what I would like to do: Separate from the flight receiver, I will have a 2nd receiver operated by a 2nd person. They'll be seeing through a camera mounted on a gimbal. I would like to use MWC stabilization to mitigate jerks ...
by spagoziak
Mon Aug 29, 2011 5:09 pm
Forum: Shields, boards and sensors
Topic: Sudden troubles with BMA180?
Replies: 10
Views: 1431

Re: Sudden troubles with BMA180?

mgros wrote:Silly question. ¿have you calibrated the ACC after the installation?.


Definitely :) Good question though!

Trouble is, the acc usually freezes the GUI and the Ard entirely when it's on the bus. So calibration doesn't get to happen very often.

This thing used to be perfect! Just last week, even...
by spagoziak
Mon Aug 29, 2011 3:17 pm
Forum: Shields, boards and sensors
Topic: Sudden troubles with BMA180?
Replies: 10
Views: 1431

Re: Sudden troubles with BMA180?

Well Poop. I have a spare BMA020 laying around... I guess that's what I'll have to do... $40 for a new one is out of reach for now. Poop!
by spagoziak
Mon Aug 29, 2011 6:27 am
Forum: Shields, boards and sensors
Topic: Sudden troubles with BMA180?
Replies: 10
Views: 1431

Re: Sudden troubles with BMA180?

Sadly, I don't have such a contraption... never even seen one! Isn't there a way to make one using a sound card out of a computer, some how? Or was that some other gadget I'm thinking of?
by spagoziak
Sun Aug 28, 2011 7:21 pm
Forum: Shields, boards and sensors
Topic: Sudden troubles with BMA180?
Replies: 10
Views: 1431

Re: Sudden troubles with BMA180?

Is the behavior I describe symptomatic of a damaged acc?

And... does anyone have a bma180 they'd like to sell? For less than sparkfun's $30 + shipping ? :roll:

spag
by spagoziak
Sun Aug 28, 2011 5:38 pm
Forum: Shields, boards and sensors
Topic: Sudden troubles with BMA180?
Replies: 10
Views: 1431

Re: Sudden troubles with BMA180?

I've filled out this post with the images so now it's easier to read. What do you folks think this accelerometer is doing?
by spagoziak
Sun Aug 28, 2011 5:58 am
Forum: Shields, boards and sensors
Topic: Sudden troubles with BMA180?
Replies: 10
Views: 1431

Sudden troubles with BMA180?

So I've flown this BMA180 on countless flights before, but after re-wiring it to a breadboard for re-installation onto the MWC, I'm having no success. ⋅ I'm using 1.7 for this since 1.8 hasn't been very reliable for me. ⋅ When the BMA180 is plugged into the I2C line, my cycle tim...
by spagoziak
Tue Aug 23, 2011 4:18 pm
Forum: Shields, boards and sensors
Topic: Slow Graphic Movement in 1.8?
Replies: 3
Views: 668

Re: Slow Graphic Movement in 1.8?

Brilliant! I'd never tried acc only... just happened to be how I grabbed the thing, I guess. Neat trivia :)
by spagoziak
Tue Aug 23, 2011 5:58 am
Forum: Shields, boards and sensors
Topic: Slow Graphic Movement in 1.8?
Replies: 3
Views: 668

Slow Graphic Movement in 1.8?

I haven't tried flying this yet--gotta wait for sunlight first. However, on the bench tonight, I re-installed my BMA180 after having enough frustration with the 020. While tilting the accelerometer to determine if I had my orientation reversals correct, I noticed that the attitude symbols in the GUI...
by spagoziak
Mon Aug 22, 2011 5:06 pm
Forum: Software development
Topic: Accelerometer Drift
Replies: 13
Views: 2272

Re: Accelerometer Drift

I could believe that... but it'd be pretty incredible... I got 2 from Kinderkram at the same time... one has been riding around on a tricopter for weeks with perfect behavior. Just popped it onto my quad and things haven't gone well! I'm going to desolder BMA180 from my bread board and remount it on...
by spagoziak
Fri Aug 19, 2011 3:22 pm
Forum: Software development
Topic: Accelerometer Drift
Replies: 13
Views: 2272

Re: Accelerometer Drift

I'm pretty interested in how this'll be solved.. my BMA020 behaves exactly the same way. Seems a few folk are having this happen where it never happened before. Pretty interesting!