Search found 67 matches

by LutzB
Mon Feb 11, 2019 7:06 pm
Forum: ESCs, propellers , servos and radios
Topic: Propeller speed problem
Replies: 2
Views: 2021

Re: Propeller speed problem

And your inputs for roll and yaw are not properly centered.
by LutzB
Mon Sep 03, 2018 9:57 am
Forum: Software development
Topic: MWii development beyond v2.4
Replies: 73
Views: 21949

Re: MWii development beyond v2.4

This is a 32 bit processor and was the reason for ports like cleanflight, betaflight, iNav etc.
by LutzB
Tue Aug 22, 2017 6:41 am
Forum: Software development
Topic: BgoBeyond - modded multiwii sources
Replies: 7
Views: 2636

Re: BgoBeyond - modded multiwii sources

That is the reason, why i said "ugly hack". He modified the config of the Hex. It is not possible to simply merge the code. You have to create a new config for this Quad Car and adopt the changes into this.
by LutzB
Sun Aug 20, 2017 10:06 pm
Forum: Software development
Topic: BgoBeyond - modded multiwii sources
Replies: 7
Views: 2636

Re: BgoBeyond - modded multiwii sources

Maybe you can take a look here: https://youtu.be/abhKyjMqiaw
While not armed, motor 5 and 6 control speed and steering. If armed, you have a simple quad drone.
by LutzB
Fri Aug 18, 2017 6:28 am
Forum: Software development
Topic: BgoBeyond - modded multiwii sources
Replies: 7
Views: 2636

Re: BgoBeyond - modded multiwii sources

As far as I remember, this was an ugly hack of the Hex+ configuration. Two motor outputs are removed (front and rear) are not used if armed but unarmed. They control the driving speed and the servo for the steering if unarmed.
by LutzB
Wed May 03, 2017 8:23 am
Forum: Getting Started - MultiWii config and setup
Topic: Motors power goes down and flip on take off
Replies: 2
Views: 959

Re: Motors power goes down and flip on take off

Also check the input channels of pitch, roll and yaw. they should be as close to 1500 as possible with centered sticks.
by LutzB
Mon Mar 20, 2017 7:34 am
Forum: Getting Started - MultiWii config and setup
Topic: How to set flight modes?
Replies: 11
Views: 7147

Re: How to set flight modes?

This should be possible, but I think it is easier to limit the channels in your tx. Maybe setup a flightmode with limited rates there?
by LutzB
Mon Mar 20, 2017 7:31 am
Forum: General discussions
Topic: newest/stablest version
Replies: 3
Views: 888

Re: newest/stablest version

I would prefer the Mega, not the ProMini. Only one serial port is a real pain. Also you have dedicated outputs for the gimbal.
by LutzB
Mon Feb 27, 2017 7:26 am
Forum: General discussions
Topic: Fresh Quad Scratch Build - USB PID Tuning
Replies: 1
Views: 811

Re: Fresh Quad Scratch Build - USB PID Tuning

If the serial port on the NanoWii is not used, you can connect a Bluetooth adapter to this. Googling for NanoWii and Bluetooth will give you some results.
I would then recommend the EZ-GUI App on your Android phone to configure the FC.
by LutzB
Tue Jan 31, 2017 7:26 am
Forum: ESCs, propellers , servos and radios
Topic: back motors spinning faster; drone flips over
Replies: 3
Views: 1059

Re: back motors spinning faster; drone flips over

From a short look at the video I notices that your TX is not properly centered.
Roll, pitch and yaw should be as close to 1500 as you can get.
by LutzB
Thu Aug 11, 2016 6:21 am
Forum: Connecting elements
Topic: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signal
Replies: 13
Views: 1711

Re: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signa

You are right. I could not read the labels on the first picture. Sorry for this.
by LutzB
Wed Aug 10, 2016 6:32 pm
Forum: Connecting elements
Topic: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signal
Replies: 13
Views: 1711

Re: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signa

Things are not quite right. OK, you have the GPS power hooked up to the I2C port on the FC but you are using the serial 2 port in your config.h and have your signal RX and TX hooked up to the serial port on your FC. Also it looks like your GPS module is hooked up at the I2C port and not the serial ...
by LutzB
Thu Aug 04, 2016 6:21 am
Forum: Getting Started - MultiWii config and setup
Topic: MultiWiiConf: connect to serial port rfcomm0 as normal user?
Replies: 5
Views: 966

Re: MultiWiiConf: connect to serial port rfcomm0 as normal u

Oh.. sorry missed that one.
Can you post what commands or config you use for rfcomm? Please include any error messages too.
by LutzB
Fri Jul 22, 2016 6:01 am
Forum: ESCs, propellers , servos and radios
Topic: Afro ESC problem
Replies: 6
Views: 1325

Re: Afro ESC problem

Sorry but I have no other idea what might be wrong with your setup.
by LutzB
Thu Jul 21, 2016 6:35 am
Forum: ESCs, propellers , servos and radios
Topic: Afro ESC problem
Replies: 6
Views: 1325

Re: Afro ESC problem

Hi Nudop, if your ESCs are really calibrated try increasing MINTHROTTLE in the gui until all motors spin. This might be somewhere around 1100. In your screenshot the motor outputs are around 1200. Do they spin with this values or not? If not the calibration of the ESCs might have failed as this is a...
by LutzB
Sat Apr 09, 2016 8:02 am
Forum: Ideas
Topic: Direct Frsky telemtry data from MW FC
Replies: 359
Views: 1029873

Re: Direct Frsky telemtry data from MW FC

The 2.4 release does not include any telemetry functionality. You will have to merge the code yourself or get the latest code from the GIT.
https://github.com/multiwii/multiwii-firmware
by LutzB
Fri Apr 08, 2016 1:06 pm
Forum: Shields, boards and sensors
Topic: Yaw calibration problem
Replies: 7
Views: 3456

Re: Yaw calibration problem

This is the way ACC and GYRO are supposed to work. The gyro recognizes rotation. So while pitching your copter forward, you see a spike. If you stop turning, gyro goes back to zero. If your copter is not moving in any way ACC measures the g force. If the copter is leveled, you get a max on the z axi...
by LutzB
Sun Apr 03, 2016 9:32 am
Forum: General discussions
Topic: Flying car help
Replies: 26
Views: 9016

Re: Flying car help

This is not the first one:
http://www.rcgroups.com/forums/showthread.php?t=2221060

This car even uses MultiWii!
by LutzB
Sat Mar 12, 2016 10:21 am
Forum: Software development
Topic: FRSKY telemetry integration into Multiwii 2.4 has started
Replies: 71
Views: 13250

Re: FRSKY telemetry integration into Multiwii 2.4 has starte

Please find the latest MultiWii 2.4 with S.Port Telemetry in my Git repo in the S.Port-Telemetry branch: m You will need an Inverter as described in the topic you referenced to. The TTL level converter will not invert the signal and cannot be used. The SBus cable is only for one way communication an...
by LutzB
Wed Mar 09, 2016 7:52 pm
Forum: ESCs, propellers , servos and radios
Topic: Multiwii v2.5 board - motor doesn't spin as the throttle up
Replies: 5
Views: 3758

Re: Multiwii v2.5 board - motor doesn't spin as the throttle

Thanks for the reply. I connect the muliwii board and using the multiwii config, i read the tx value. The throttle value varies from 990 to 1990. i attach the screenshot of the GUI. when i rise the throttle the rpm of the motor is still gives the same problem. there is no lift. Is it compulsory to ...
by LutzB
Tue Mar 08, 2016 1:11 pm
Forum: ESCs, propellers , servos and radios
Topic: Multiwii v2.5 board - motor doesn't spin as the throttle up
Replies: 5
Views: 3758

Re: Multiwii v2.5 board - motor doesn't spin as the throttle

Use MultiWiiConf or WinGui or whatever you have to look at the running flight controller. You have to adjust the endpoint and center of each stick to give you a range from 1000 to 2000 with 1500 at center position. This must be done on the tx side. I have no idea what this is called in the menu of y...
by LutzB
Mon Mar 07, 2016 5:28 pm
Forum: ESCs, propellers , servos and radios
Topic: Multiwii v2.5 board - motor doesn't spin as the throttle up
Replies: 5
Views: 3758

Re: Multiwii v2.5 board - motor doesn't spin as the throttle

There are many things that can cause this behavior. As we cannot guess which video you are referring to, helping you is quite complicated. Some things to check: - ESCs calibrated? - TX calibrated? - ACC calibrated? - MAG calibrated? Sounds like your copter tries to yaw because of a not calibrated st...
by LutzB
Sun Feb 21, 2016 1:03 pm
Forum: Getting Started - MultiWii config and setup
Topic: Motors Aren't Arming
Replies: 4
Views: 1065

Re: Motors Aren't Arming

I would bet your sticks are not calibrated to 1000-1500-2000. I think throttle will be around 1150 too in low position. Then MW will not arm. Trim your enpoints to match 1000 in low, 1500 in mid and 2000 in high position as close as possible.
by LutzB
Fri Jan 29, 2016 8:07 am
Forum: Getting Started - MultiWii config and setup
Topic: brushless motor rotation is not the same
Replies: 1
Views: 581

Re: brushless motor rotation is not the same

Just swap two wires between ESC and the motor. This will make the motor rotate in the opposite direction.
But remember that your quad needs two motors rotating clock wise and two counter clock wise! Details with pictures can be found on the multiwii website.
by LutzB
Tue Jan 19, 2016 7:50 am
Forum: General discussions
Topic: New pilot making sure I got it all correct
Replies: 19
Views: 2505

Re: New pilot making sure I got it all correct

Welcome to the forum! I would suggest to connect the flight controller to your pc and run multiwiiconf first. Then you can see which version is running and if there are any special things configured. At first there is no need to directly flash the latest multiwii version. Get your TX channel ranges ...
by LutzB
Tue Jan 12, 2016 7:16 am
Forum: Connecting elements
Topic: FrSky Taranis and MW AIOP
Replies: 2
Views: 760

Re: FrSky Taranis and MW AIOP

The X8R only supports Sbus. But you will need an inverter to connect it to a free serial port.
by LutzB
Mon Jan 11, 2016 7:35 am
Forum: Getting Started - MultiWii config and setup
Topic: Odd readings from ESC outputs (or are they?...)
Replies: 2
Views: 618

Re: Odd readings from ESC outputs (or are they?...)

As Kbev5709 already said: adjust your channel ranges in your transmitter!
The different values for the motors make sense as the copter wants to yaw right (1522).
by LutzB
Tue Dec 29, 2015 7:09 pm
Forum: Getting Started - MultiWii config and setup
Topic: MULTIWII QUADCOPTER without Hobbyking Transmitter & Receiver
Replies: 2
Views: 519

Re: MULTIWII QUADCOPTER without Hobbyking Transmitter & Rece

If you just want to test the motors you can use the dynbalance definition in the config. Compile and upload the sketch. When you now connect with MultiWiiConf you will get another tab where you can play with motor values. But with this sketch you are not able to fly! You will have to upload again wi...
by LutzB
Tue Dec 29, 2015 7:05 pm
Forum: Shields, boards and sensors
Topic: I want to make my own FC with multiwii
Replies: 3
Views: 2314

Re: I want to make my own FC with multiwii

If you really want to play with all things possible you will need a Mega processor. Something like the Crius AIO Pro.
by LutzB
Thu Oct 29, 2015 11:19 am
Forum: Getting Started - MultiWii config and setup
Topic: how can i connect uplox gps neo-6m to arduino uno
Replies: 2
Views: 372

Re: how can i connect uplox gps neo-6m to arduino uno

You will need a free serial port (UART) for this. Then connect TX to RX and vice versa. You will also need to set the GPS and MultiWii to the same baud rate. I googled for the Uno and learned that is has the 328P processor. So you have no free serial port for this. The only way to go is I2C with a s...
by LutzB
Mon Aug 31, 2015 10:15 pm
Forum: Software development
Topic: FRSKY telemetry integration into Multiwii 2.4 has started
Replies: 71
Views: 13250

Re: FRSKY telemetry integration into Multiwii 2.4 has starte

You are absolutely right. I have a Crius AIO Pro v2.0 with the Mega processor.
So you need a free serial port for this.
by LutzB
Wed Aug 26, 2015 9:11 am
Forum: Software development
Topic: Goggle Code is Shutting down.
Replies: 16
Views: 3084

Re: Goggle Code is Shutting down.

I know this repo, but the last commit is from Mar 14!
I thought there was an updated source somewhere.
by LutzB
Tue Aug 25, 2015 3:39 pm
Forum: Software development
Topic: Goggle Code is Shutting down.
Replies: 16
Views: 3084

Re: Goggle Code is Shutting down.

Any news on this?
Google code is readonly now. I saw some commits pointing to multiwii.com, but there are still only links to google code.
by LutzB
Fri Aug 21, 2015 6:19 am
Forum: Shields, boards and sensors
Topic: PPM sum activation ?
Replies: 3
Views: 573

Re: PPM sum activation ?

Yes, PPM Sum can only be activated during compiling. So you will have to modify config.h in the source code and flash the modified firmware.
by LutzB
Tue Aug 18, 2015 9:07 am
Forum: Connecting elements
Topic: vbat cells
Replies: 12
Views: 1692

Re: vbat cells

We do have a static offset vbatcells_offset[VBAT_CELLS_NUM] - why? This has nothing to do with the individual cell voltage! It is useful if you have a zener diode in your measuring circuit. You can get a much better resolution of the interesting part of the voltage. So this should not be removed IM...
by LutzB
Tue Aug 18, 2015 5:48 am
Forum: Boards
Topic: Help with sbus
Replies: 4
Views: 1125

Re: Help with sbus

I do not know the board. Can you post the S.Bus part of your config.h?
by LutzB
Mon Aug 17, 2015 8:34 pm
Forum: Software development
Topic: FRSKY telemetry integration into Multiwii 2.4 has started
Replies: 71
Views: 13250

Re: FRSKY telemetry integration into Multiwii 2.4 has starte

Thanks QuadBow! Maybe I should tell you that I still moved the run_telemetry() call to the position mentioned earlier. The result is much better then. I think timing is much more important for SPort because the receiver polls the sensors. I have no idea in what timeframe the answer has to be send. Y...
by LutzB
Mon Aug 17, 2015 8:10 pm
Forum: Boards
Topic: Help with sbus
Replies: 4
Views: 1125

Re: Help with sbus

Do you have an inverter for the sbus connection?
by LutzB
Sun Aug 16, 2015 8:38 pm
Forum: Software development
Topic: FRSKY telemetry integration into Multiwii 2.4 has started
Replies: 71
Views: 13250

Re: FRSKY telemetry integration into Multiwii 2.4 has starte

Thanks to this rainy sunday I reworked the SPort telemetry according to the mentioned library. Only the delays for each value are not done, but it is working fine here with my Taranis Plus. As I changed the code to simulate the FrSky hardware sensors, most IDs have changed. If you setup your radio a...
by LutzB
Sun Aug 16, 2015 8:11 pm
Forum: Connecting elements
Topic: vbat cells
Replies: 12
Views: 1692

Re: vbat cells

As it is raining the whole day here I had some time for developing. I have reworked the cell voltage calculation to take the same parameters as vbat. Namely the new definition VBAT_CELLS_PRESCALER was added and calculation changed. I did not change the measured values, so the problem that you measur...
by LutzB
Mon Aug 10, 2015 6:24 pm
Forum: Getting Started - MultiWii config and setup
Topic: PID's and AUX settings deleted after firmware upload
Replies: 5
Views: 419

Re: PID's and AUX settings deleted after firmware upload

Thanks for the confirmation. I've noticed this for a while and I always put the blame on the GUI. I use a screenshot as well but it's a pain having to reenter the PID's and AUX settings every time. I hope this gets fixed. Maybe this can be fixed for the PIDs but I think the structure of the aux set...
by LutzB
Mon Aug 10, 2015 11:49 am
Forum: Getting Started - MultiWii config and setup
Topic: PID's and AUX settings deleted after firmware upload
Replies: 5
Views: 419

Re: PID's and AUX settings deleted after firmware upload

I thought if this option is set #define NO_FLASH_CHECK I would be safe. I also noticed this behaviour, but this only happened to me when I added or removed some features in the code. If this results in more or less checkboxes for AUX the settings are reset. Now I always take a screenshot from the c...
by LutzB
Mon Aug 10, 2015 6:22 am
Forum: Connecting elements
Topic: vbat cells
Replies: 12
Views: 1692

Re: vbat cells

Thank you for the quick reply. Yesterday I modified the code a bit and changed the calculation in multiwii.cpp to the same that is used for vbat and added prescaler definitions to config.h. After a lot of try and error I found some numbers for VBAT_CELLS_DIV that give me good measurements. I will po...
by LutzB
Sat Aug 08, 2015 6:48 pm
Forum: Connecting elements
Topic: vbat cells
Replies: 12
Views: 1692

Re: vbat cells

I tried setting up vbat cells today in order to implement it into the FrSky s.port telemetry. I also got mad with the values in config.h. My setup is similar to adivacaru: ⋅ 3S Lipo ⋅ cell 1 direct on A2 ⋅ cells 1+2 on A1 with 33k/47k resistors ⋅ cells 1+2+3 o...
by LutzB
Sun Jul 26, 2015 11:29 am
Forum: Software development
Topic: FRSKY telemetry integration into Multiwii 2.4 has started
Replies: 71
Views: 13250

Code Refactoring?

While looking for the S.Port telemetry code, I found the handy libraries for S.Port and old FrSky telemetry on rcgroups. I asked myself, why we must invent the wheel again? Is there any chance that something like this will be merged into the multiwii code? I'd really like to do it, but before spendi...
by LutzB
Thu Jul 23, 2015 11:40 am
Forum: ESCs, propellers , servos and radios
Topic: Yaw problem. Cannot lift up. Quad X
Replies: 3
Views: 1061

Re: Yaw problem. Cannot lift up. Quad X

Just ignore "kongling". It is a spambot.
by LutzB
Mon Jul 20, 2015 6:33 am
Forum: ESCs, propellers , servos and radios
Topic: Esc calibration failled
Replies: 4
Views: 1090

Re: Esc calibration failled

Semms that your esc are not compatible with this procedure of calibrating. What type are you using? Do you have a manual?
by LutzB
Sun Jul 19, 2015 7:08 pm
Forum: Getting Started - MultiWii config and setup
Topic: multiwii GUI not seeing RX
Replies: 15
Views: 1264

multiwii GUI not seeing RX

Here is an example of a inverter: http://aeroquad.com/showthread.php?9064 ... r-NOT-Gate

You will also find some pictures and schematics here in the forum when searching.