Search found 23 matches

by pihlerm
Sun Feb 14, 2016 10:33 pm
Forum: Shields, boards and sensors
Topic: Temperature dependency - copter not booting when cold?
Replies: 9
Views: 2832

Re: Temperature dependency - copter not booting when cold?

Hello, I have a AIOpro from HK board, running Multiwii 2.4. I have a custom copter type and mix, using 3 motors and 4 servos. I have a problem in cold weather: two of the three ESC's (motors 1&2) are not booting .. the ESC's dont initialize (like there is no PWM signal) (no beeps when power on)....
by pihlerm
Thu May 28, 2015 1:50 pm
Forum: General discussions
Topic: Antenna orientation....what is best?
Replies: 9
Views: 724

Re: Antenna orientation....what is best?

You can start by reading this http://open-txu.org/home/continuing-education/introduction-to-antennas/ . I always have great problems with antenna position; also had a loss-of-signal related crash once. It is best to have two (diversity) antennas placed at a right angle. The end of receiver antenna (...
by pihlerm
Wed May 27, 2015 5:29 am
Forum: Shields, boards and sensors
Topic: Using an Ultrasonic sensor to constrain pitch/roll/throttle.
Replies: 5
Views: 1069

Re: Using an Ultrasonic sensor to constrain pitch/roll/throt

Hi, the point in multiwii 2.4 is Multiwii.cpp around line 1500, where RD data is used as input to PID controllers. There you could constrain that. But I don' think this will be ok.. Besides RC, there is all other data from gyros and accelerometers and NAV code .. that influences movement. You could ...
by pihlerm
Wed May 27, 2015 4:41 am
Forum: Getting Started - MultiWii config and setup
Topic: GPS Hold, What am i doing wrong??
Replies: 11
Views: 637

Re: GPS Hold, What am i doing wrong??

Hi, you have to manually enable MAG and BARO modes (see multiwii conf) together with GPS_HOLD. 2.4 multiwii can work without MAG. I had great problems with on-board MAG because of power cables that were causing magnetic field. Direction of compass varied with throttle up to 30 degrees. I can see fro...
by pihlerm
Wed May 27, 2015 4:26 am
Forum: General discussions
Topic: MultiWii 328p - proper way to attach remote control
Replies: 5
Views: 597

Re: MultiWii 328p - proper way to attach remote control

One more advice. Buy a cheap 4-axis (not 3-axis!) mini-copter (around 20$) (WLtoys V911 or similar). Fly it until you get good control (landing, height control, hover, turning, flying AWAY and TOWARDS you, ..). Especially important is to learn directions under all circumstances. This will prevent ma...
by pihlerm
Wed May 27, 2015 3:50 am
Forum: General discussions
Topic: Exactly 18 i2c errors crius aio pro
Replies: 4
Views: 578

Re: Exactly 18 i2c errors crius aio pro

Hi, do you also have external MAG or gps on serial only? I'm getting some I2C errors from an external mag chip, probably due to (bad) wiring and EM noise. They come usually in multiples of 6. The counter is in multiwii, so you get the same number no matter what you look with (ezgui/wingui,..). Do yo...
by pihlerm
Mon May 25, 2015 4:18 pm
Forum: Pictures & Videos
Topic: First REAL autonomous flight of FengShuiDrone
Replies: 2
Views: 2823

Re: First REAL autonomous flight of FengShuiDrone

Congrats!

I like your folding landing gear .. could you post a link or did you make it yourself?
by pihlerm
Mon May 25, 2015 4:15 pm
Forum: MultiWii tweaking - flying experience
Topic: Serial0 problems
Replies: 2
Views: 889

Re: Serial0 problems

Well, no. I have moved my wifi bridge to serial2 and it works a little better now. Will see when I go to the field .. But problems with serial 0 persist. I have problems with USB or with wifi on port0. Somehow the protocol goes out of sync and/or serial0 becomes unresponsive. If somebody has a simil...
by pihlerm
Mon May 25, 2015 1:57 am
Forum: Software development
Topic: New Multiwii Serial Protocol
Replies: 409
Views: 108349

Re: New Multiwii Serial Protocol

Hi, I have a problem with Serial0 (needing reset whilw wingui is connecting).
http://www.multiwii.com/forum/viewtopic.php?f=17&t=6443
Thanks for any info.
by pihlerm
Mon May 25, 2015 1:53 am
Forum: MultiWii tweaking - flying experience
Topic: Serial0 problems
Replies: 2
Views: 889

Serial0 problems

Hi, I have Crius AIO v1 (Hobby King clone). Multiwii 2.4 (though this problem occured with other versions). When connecting via USB (WinGUI, ..) most of the time I cannot connect. I must manually reset the FC while WinGUI is attempting to connect to it. It works imediately after uploading new formwa...
by pihlerm
Mon May 25, 2015 1:43 am
Forum: Shields, boards and sensors
Topic: Using an Ultrasonic sensor to constrain pitch/roll/throttle.
Replies: 5
Views: 1069

Re: Using an Ultrasonic sensor to constrain pitch/roll/throt

Hi Spacenaut, I toyed with this idea a while ago. I'm not a multiwii dev but I think you'll ned a PID contoller for this. Main PID's are handled in Multiwii.cpp around line 1500 (from my own understanding), so perhaps that's where the new PID should go as well. The other place would be where GPS nav...
by pihlerm
Fri May 22, 2015 8:19 am
Forum: MultiWii tweaking - flying experience
Topic: Good vibrations
Replies: 3
Views: 935

Re: Good vibrations

The code in previous post does two things. Make sure #define DYNBALANCE #define RMS_SAMPLING 600 are uncommented in config.h. 1. It computes RMS values for accelerometer/gyro and sends them to GUI via DEBUG1 - accelerometer and DEBUG2 - gyro fields. 2. It allows you to use remote control and sticks ...
by pihlerm
Fri May 22, 2015 8:06 am
Forum: MultiWii tweaking - flying experience
Topic: Good vibrations
Replies: 3
Views: 935

Re: Good vibrations

ok, here is the code (for multiwii 2.4, but it will also work in 2.3) Usage instructions below. after - find the code block and add code below it insteadof - find the code block and replace it with code config.h after #define DYNBALANCE // (**) Dynamic balancing controlled from Gui #define RMS_SAMPL...
by pihlerm
Mon Mar 09, 2015 3:04 pm
Forum: MultiWii tweaking - flying experience
Topic: Good vibrations
Replies: 3
Views: 935

Good vibrations

Hello all, spring is coming and it is time for tweaking and flying. Above all, I find getting rid of vibrations or minimizing them as much as possible the most difficult part of tweaking. I balance the props, in both axes, by using a static prop balancer. I use tape for the long axis and epoxy near ...
by pihlerm
Wed Feb 04, 2015 9:22 am
Forum: Shields, boards and sensors
Topic: How-To: Crius AIO Pro V2.x with external MAG
Replies: 3
Views: 3123

Re: How-To: Crius AIO Pro V2.x with external MAG

I am reporting here the procedure I've done on a CRIUS AIO V1 board clone : HK Multiwii AIO V2 http://www.hobbyking.com/hobbyking/store/__31138__Multiwii_and_Megapirate_AIO_Flight_Controller_w_FTDI_ATmega_2560_V2_0.html I removed the HMC5843 chip from the board using razor blade (ruins in red circle...
by pihlerm
Mon Feb 02, 2015 2:24 pm
Forum: Shields, boards and sensors
Topic: How-To: Crius AIO Pro V2.x with external MAG
Replies: 3
Views: 3123

Re: How-To: Crius AIO Pro V2.x with external MAG

Hello, I am looking for some info on AIOP v1 board .. what to cut to disable internal HMC5883L? And since I have GPS+MAG board made for APM 2.5 which uses 3.3v I2C port .. what happens when I connect it to AIOP that uses 5V I2C? Are there some simple tricks, do I need bidirectional TTL voltage adapt...
by pihlerm
Fri Jan 30, 2015 8:52 am
Forum: Shields, boards and sensors
Topic: Multiwii SE v3.0 with UBLOX GPS Module V2.0 Problem
Replies: 2
Views: 567

Re: Multiwii SE v3.0 with UBLOX GPS Module V2.0 Problem

Hi,
I have Crius AIO clone board, and on it the serial connector lacks 5V ..
Just guessing, but perhaps your board has the same problem .. try to take 5V from some other pin.
by pihlerm
Fri Jan 30, 2015 1:09 am
Forum: Connecting elements
Topic: arduino 2560 mega + gy-80 + gy-gps6mv2 multirotor
Replies: 6
Views: 4333

Re: arduino 2560 mega + gy-80 + gy-gps6mv2 multirotor

Hi, my new GPS arrived, it is a board originally made for APM 2.6 (m) I see its I2C port uses 3.3 V .. and probably the serial is 3.3V as well. Does anybody have experience with the chip? Do I have to insert level converters .. and what about SDA line .. it's bidirectional? Any info would be GREATLY...
by pihlerm
Wed Jan 21, 2015 8:26 pm
Forum: Connecting elements
Topic: arduino 2560 mega + gy-80 + gy-gps6mv2 multirotor
Replies: 6
Views: 4333

Re: arduino 2560 mega + gy-80 + gy-gps6mv2 multirotor

Hi QuadBow, thank you for response. Regarding voltage; the problem is not VCC but high signal from FC board's UART to GPS boards RX, which seems to be connected directly to chip's RX pin. I have since abandoned all hope for the chip and I'm waiting for another one (original ublox with MAG, whic I ne...
by pihlerm
Wed Jan 21, 2015 8:13 pm
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 131949

Re: Attemp to integrate sonar (ultrasonic sensor)

Could you post your changes for MWII 2.3 ? I am also trying to implement KV mod (have already working sonar on I2C GPS - but just as indication), but as I am not familliar with MWI deeply I have problem where to put changes as 2.3 differs a lot from KV 2.2. Hi, sorry for the delay, I am using pin 1...
by pihlerm
Fri Jan 02, 2015 6:16 am
Forum: Connecting elements
Topic: arduino 2560 mega + gy-80 + gy-gps6mv2 multirotor
Replies: 6
Views: 4333

Re: arduino 2560 mega + gy-80 + gy-gps6mv2 multirotor

Hi, I have Crius AIO and NEO6 GPS sensor gy-gps6mv2 http://www.banggood.com/GY-NEO6MV2-Flight-Controller-GPS-Module-For-Arduino-EEPROM-MWC-APM-2_5-p-915384.html . I CAN get it working in NMEA mode, 9600 baud. It finds the sats, etc.. I cannot get it to work in UBLOX mode ..Seems like it's not accept...
by pihlerm
Tue Dec 30, 2014 6:43 am
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 131949

Re: Attemp to integrate sonar (ultrasonic sensor)

Just wanted to say that I used code from kataventos's post. I have a cheap HC-SR04. Had to re-arrange the code a bit for MWI 2.3 but it works fine. There is a big improvement in triggering the sonar RARELY. I settled for 10Hz. I get no spikes and other artifacts as I had with a tighter (original) lo...
by pihlerm
Tue Dec 09, 2014 6:51 pm
Forum: Ideas
Topic: Changing PID Values with a Pot
Replies: 73
Views: 27373

Re: Changing PID Values with a Pot

I made it! It works in 2.3 ))) Based on JohhnyQuest's post i've made a slight change, so that I can use all three pots at the same time (Turnigy 9xR). Only tested on my quad so far, so if anyone is willing to risk it, here is the code. -> Works with Multiwii 3.2 -> Add UserCode.cpp, UserCode.h, BHT...