Search found 14 matches

by seikurou
Tue Apr 07, 2015 2:11 am
Forum: Shields, boards and sensors
Topic: Getting an External Mag to Work?
Replies: 2
Views: 1072

Getting an External Mag to Work?

Using a HobbyKing All in One Flight Controller. http://www.hobbyking.com/hobbyking/store/__31138__Multiwii_and_Megapirate_AIO_Flight_Controller_w_FTDI_ATmega_2560_V2_0.html Piled with this GPS+MAG combo from Banggood. http://www.banggood.com/CRIUS-NEO-GPS-MAG-V2-NEO-7M-Module-With-Compass-p-951898.h...
by seikurou
Sat Mar 21, 2015 6:54 am
Forum: Connecting elements
Topic: Can't Connect Crius AIO to Arduino
Replies: 1
Views: 653

Can't Connect Crius AIO to Arduino

Hi guys, I purchased a Crius AIO board from HobbyKing. I plugged the board into the computer, and the computer detects it and installs FTDI drivers. Although I can see it in device manager, it does not show up as 'COM' port in Arduino for programming. I have previously purchased a MultiWii 328p, and...
by seikurou
Sat Mar 07, 2015 3:55 am
Forum: Ideas
Topic: Direct Frsky telemtry data from MW FC
Replies: 359
Views: 1042986

Re: Direct Frsky telemtry data from MW FC

What am I doing wrong here?
I've checked the serial speed which should be 9600
Tried swapping the tx/rx wires
using QuadBow's code (thank you for that)
Image
Not even sure if i'm supposed to use that that level converter, or any at all.
Thanks
by seikurou
Mon Mar 02, 2015 9:10 pm
Forum: Connecting elements
Topic: Use MultiWii GPS telemetry for FrSky telemetry
Replies: 14
Views: 2883

Re: Use MultiWii GPS telemetry for FrSky telemetry

For serial 3, I know it's serial 3, but where physically on the board is serial 3?
I would connect the receiver to the mini-b plug through the thing you linked me?
Are the ports the I2C ones?
Not very good at reading schematics... so could the FrSky/TS232 might serve as a substitute?
Thanks
by seikurou
Mon Mar 02, 2015 4:24 am
Forum: Connecting elements
Topic: Use MultiWii GPS telemetry for FrSky telemetry
Replies: 14
Views: 2883

Re: Use MultiWii GPS telemetry for FrSky telemetry

Ended up getting a TTL TS232.
Will your code work with that?
Still am unsure about the connections that have to be made onto the board. (HobbyKing MultiWii 328p, Witespy MW Pro Ez3.0)
by seikurou
Mon Mar 02, 2015 3:27 am
Forum: Connecting elements
Topic: Use MultiWii GPS telemetry for FrSky telemetry
Replies: 14
Views: 2883

Re: Use MultiWii GPS telemetry for FrSky telemetry

Would I be able to use a Bluetooth module at the same time for both of these boards?
Currently know nothing of the more complex aspects of MultiWii.
When you say transistor I'm sure which to get. Even then, I don't know what to do with it to get it to work.
How do I know what serial is what?
by seikurou
Mon Mar 02, 2015 12:38 am
Forum: Connecting elements
Topic: Use MultiWii GPS telemetry for FrSky telemetry
Replies: 14
Views: 2883

Re: Use MultiWii GPS telemetry for FrSky telemetry

Thank you so much!
Would this work on the HK 328p and HK MultiWii pro? Where would I plug stuff in?
Can you link a power inverter that would work?

Your reply is most appreciated.
by seikurou
Sat Feb 28, 2015 7:58 pm
Forum: Connecting elements
Topic: Use MultiWii GPS telemetry for FrSky telemetry
Replies: 14
Views: 2883

Re: Use MultiWii GPS telemetry for FrSky telemetry

Pretty confusing thread...
So what would I need to buy to get it to work?
Some thing like this: http://www.ebay.com/itm/Mini-RS232-MAX3 ... 5b05e33590
is that it?
Is that code compatible with mw 2.3?
by seikurou
Sat Feb 28, 2015 5:29 am
Forum: Connecting elements
Topic: Use MultiWii GPS telemetry for FrSky telemetry
Replies: 14
Views: 2883

Use MultiWii GPS telemetry for FrSky telemetry

Have a HK MultiWii pro with mtk gps. Have an fld display on my tgy9x. Fld connected to telemetry module. Any way to hook up telemetry port in mw board to frsky d8r-ii Rx for GPS coordinates?
by seikurou
Thu Feb 12, 2015 3:52 am
Forum: Shields, boards and sensors
Topic: Multiwii aux channel problem
Replies: 3
Views: 533

Re: Multiwii aux channel problem

Looks like 328p can't handle more than 2 aux channels
by seikurou
Wed Feb 11, 2015 6:14 am
Forum: Shields, boards and sensors
Topic: Multiwii aux channel problem
Replies: 3
Views: 533

Multiwii aux channel problem

My Multiwii 328p from hk worked fine. Then one day I wanted to add some more things. I was already using aux 1 just fine. I tried to install other components into the other aux plugs, but the GUI doesn't detect anything when I move the switch on my Tx around. When I move what's plugged into aux1 to ...
by seikurou
Fri Jan 02, 2015 6:19 am
Forum: Getting Started - MultiWii config and setup
Topic: Can't Arm after Activating Failsafe
Replies: 9
Views: 1011

Re: Can't Arm after Activating Failsafe

Forgot to mention that this was all done in the gui... Yes, everything works normal when reloading the code. I do have to reset PID and aux assignments After uncommenting and turning on failsafe gui flips out and doesn't respond My main problem is getting it to actually arm with failsafe active. May...
by seikurou
Fri Jan 02, 2015 4:36 am
Forum: Getting Started - MultiWii config and setup
Topic: Can't Arm after Activating Failsafe
Replies: 9
Views: 1011

Can't Arm after Activating Failsafe

Have a HK 328p on stock TGY 9x. <-- Does failsafe even work with that? After uncommenting the failsafe option in config.h, motors will not arm. Usually a solid blue LED lights up when armed, but this time it flashes on and off once. the threshold setting doesn't appear to be a problem as nothing eve...
by seikurou
Tue Dec 09, 2014 3:23 am
Forum: Getting Started - MultiWii config and setup
Topic: HK 328p - starting motors?
Replies: 2
Views: 328

HK 328p - starting motors?

I am using the HK 328p. set the minthrottle to 1064, max to 1864, and mincommand at 1000. Using afros. When I move the yaw to the right, a blue LED comes on. Does this mean it's armed? motors don't spin. They do when plugged directly to throttle channel and not through FC. I calibrated the ESCs by p...