Search found 372 matches

by Leo
Sat Jul 07, 2018 6:48 am
Forum: Software development
Topic: MWii development beyond v2.4
Replies: 73
Views: 22111

Re: MWii development beyond v2.4

My recommendation is to switch to INAV (https://github.com/iNavFlight/inav/wiki). It does everything MutliWii can do and more.
You will need a new FC but the switch is worth it. I've since moved on to INAV and Betaflight.
For sentimental reasons I will keep one MW quad copter as it is still a lot of fun to fly.
by Leo
Thu May 03, 2018 11:22 am
Forum: Getting Started - MultiWii config and setup
Topic: How to change servo output to pwm/fet motor control
Replies: 4
Views: 2452

Re: How to change servo output to pwm/fet motor control

OK, I'll answer then.... since I've looked at your thread :)

Sorry, but I haven't clue on how to solve your problem :|
by Leo
Mon Jan 29, 2018 7:05 am
Forum: Shields, boards and sensors
Topic: MultiWii 2.4 and uBlox NEO M8N
Replies: 4
Views: 2132

Re: MultiWii 2.4 and uBlox NEO M8N

It worked out of the box. I only had to make sure that the baud rate in MW is set to the GPS module.
by Leo
Sat Jan 06, 2018 6:34 pm
Forum: Shields, boards and sensors
Topic: MultiWii 2.4 and uBlox NEO M8N
Replies: 4
Views: 2132

MultiWii 2.4 and uBlox NEO M8N

I'm posting this for those who are still flying MultiWii (anyone???) and have wondered if the latest uBlox GPS receivers work. Answer: They do I'm using this model: https://www.banggood.com/Ublox-NEO-M8N-Flight-Controller-GPS-with-Protective-Shell-for-PIX-PX4-Pixhawk-p-1005394.html I hooked it up to...
by Leo
Wed Jun 21, 2017 5:04 pm
Forum: Getting Started - MultiWii config and setup
Topic: Really weird issue with multiwii on Crius AIO Pro
Replies: 11
Views: 1294

Re: Really weird issue with multiwii on Crius AIO Pro

I have the same board as you. I had to use an external MAG and keep it about 120mm away from all wires. Onboard MAG is deactivated.

Here a picture of it in flight taken on 18. June '17:
Image
by Leo
Wed Jun 21, 2017 4:02 pm
Forum: Getting Started - MultiWii config and setup
Topic: Really weird issue with multiwii on Crius AIO Pro
Replies: 11
Views: 1294

Re: Really weird issue with multiwii on Crius AIO Pro

Make sure your MAG is far away from the electronics particularly power cables.
by Leo
Wed Jun 21, 2017 3:47 pm
Forum: Getting Started - MultiWii config and setup
Topic: Really weird issue with multiwii on Crius AIO Pro
Replies: 11
Views: 1294

Re: Really weird issue with multiwii on Crius AIO Pro

So it's a receiver issue and not necessarily due to MultiWii?
by Leo
Fri Jun 16, 2017 8:13 am
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

Nice one Metori.

I already have an external GPS/MAG mounted. But at some time I'll try MahoWii again.
by Leo
Mon Jun 05, 2017 6:20 pm
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

If I do try MahoWii again some time in the future I will report here :-)
by Leo
Mon Jun 05, 2017 6:05 pm
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

I'm using Ublox 6 as well....

Edit: I edited the last sentence in my last post and changed it to something more diplomatic ;-)
by Leo
Mon Jun 05, 2017 5:34 pm
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

Thanks for your answers. It is much appreciated as is your work but nothing you answered is going to help in my case. I've been using MultiWii for many years and I know my way around When I say I reinstalled MultiWii 2.4 and everything works as it is suppose too, then that would mean everything you ...
by Leo
Tue May 30, 2017 11:57 am
Forum: Getting Started - MultiWii config and setup
Topic: Really weird issue with multiwii on Crius AIO Pro
Replies: 11
Views: 1294

Re: Really weird issue with multiwii on Crius AIO Pro

I can't help but I'm hoping you will find a solution :-)
by Leo
Sat May 27, 2017 10:01 am
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

Unfortunately I could not get MahoWii GPS Hold to work properly. So today I reverted back to MutiWii 2.4, set my settings accordingly and tried GPS Hold. Even in the wind we are having it functioned as it is suppose to. Therefore I will be staying with MultiWii 2.4 unless someone can figure out what...
by Leo
Wed May 03, 2017 5:32 am
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

marcdornan wrote:Ok. Well I will give it a shot and see how I get on.


Please do so. Then we could exchange experiences.
by Leo
Tue May 02, 2017 4:35 pm
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

Leo, So I have some Crius AIOP boards that I want to put in a 450 quad for old time's sake. They were my first purchase and MW 2.2 was the first thing I flew. Have you figured out the GPS hold? Can I fly waypoints with EZGUI? I assume this has EOSBANDI's navigation code incorporated? I'm still work...
by Leo
Tue Apr 25, 2017 9:49 am
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

Hi Mahowik, I finally was able to try your version and I have to say I like it. Well done. I'll be doing more testing with the firmware and I'm looking forward to it. Right now the only problem I'm having is getting GPS Hold to work properly. The copter starts to fly bigger and bigger circles. My fi...
by Leo
Thu Mar 02, 2017 8:53 pm
Forum: Shields, boards and sensors
Topic: Multiwii Lite v1 + GY-652
Replies: 2
Views: 1159

Re: Multiwii Lite v1 + GY-652

Steve,

you will have to solder the GY to the MB with wires as follows:

5V -> VIN
OR
3V3 -> 3V3
AND
GND -> GND
AND
SDA -> SDA
AND
SCL -> SCL

Leo
by Leo
Wed Nov 30, 2016 8:32 am
Forum: Software development
Topic: MahoWii rev 2.4 was released ;)
Replies: 22
Views: 14057

Re: MahoWii rev 2.4 was released ;)

Very nice. I will certainly give it a try over the winter.
by Leo
Fri Nov 11, 2016 7:29 am
Forum: Getting Started - MultiWii config and setup
Topic: Trouble with my quadcopter
Replies: 6
Views: 728

Re: Trouble with my quadcopter

In "config.h" look for this and activate it:

//Enables the MSP_WP command set , which is used by WinGUI for displaying an setting up navigation
#define USE_MSP_WP
by Leo
Sat Nov 05, 2016 4:35 pm
Forum: Getting Started - MultiWii config and setup
Topic: Issue with CRIUS AIO Pro Multiwii
Replies: 3
Views: 499

Re: Issue with CRIUS AIO Pro Multiwii

I won't be able to help you much but the first thing I'd do is to remove all the cables and devices from the board.
With only the board itself hook it up to the computer via USB and try uploading the code again.
by Leo
Fri Oct 07, 2016 12:16 pm
Forum: General discussions
Topic: Many people here still flying Multiwii?
Replies: 11
Views: 1751

Re: Many people here still flying Multiwii?

I have two QC's and both fly with MW 2.4. I don't have any experience with other FC systems but for me don't see any reason to switch.
by Leo
Thu Aug 11, 2016 6:56 pm
Forum: Connecting elements
Topic: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signal
Replies: 13
Views: 1726

Re: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signa

That's great news! However, for the record. Your prior setup should have worked just the same. I would guess that you have a defect on your FC board. All positive pins on the Crius 2.x FC boards output 5 volts . I measured mine on the IC2 Port just to make double sure. I only fly these FC boards btw...
by Leo
Thu Aug 11, 2016 6:45 am
Forum: Connecting elements
Topic: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signal
Replies: 13
Views: 1726

Re: Crius AIOP V2 and GPS Ublox Neo-6 Problem with gps signa

I checked the picture and added the port descriptions:

Image

Assuming the white and the yellow wire is the same I'd say the connections are correct.
by Leo
Mon Jun 20, 2016 6:11 pm
Forum: FPV, OSD, Cameras
Topic: Mavlink minim osd mods.
Replies: 1
Views: 997

Re: Mavlink minim osd mods.

This is how I did it on my V2.0 board:

Image
by Leo
Wed May 18, 2016 7:54 am
Forum: Software development
Topic: MWii development beyond v2.4
Replies: 73
Views: 22111

Re: MWii development beyond v2.4

Well, I am very happy about the news! I don't plan on switching to any new hardware. MW and 2560 work fine for me. However tweaks e.g. filtering and cleanup wouldn't hurt any. And I'm sure other platforms e.g. Cleanflight have improved algorithms that could be implemented in MW. I would also hope th...
by Leo
Wed Mar 30, 2016 6:10 am
Forum: MultiWii tweaking - flying experience
Topic: is High accuracy GPS+ALT hold possible?
Replies: 5
Views: 2799

Re: is High accuracy GPS+ALT hold possible?

Here is an example of my position hold with MultiWii 2.4. I'm sure it can be improved further through PID tuning.

by Leo
Sat Mar 05, 2016 8:52 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

With the latest GUI I can't edit my Waypoints without having to connect to the FC first. Is this on purpose or am I doing something wrong? When I enter "1" for auto landing in the Waypoint "RTH" it reverts back to "0". Error in the GUI? There shouldn't be a error in gu...
by Leo
Wed Mar 02, 2016 8:41 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

Yes, MultiWii 2.4
by Leo
Tue Mar 01, 2016 9:54 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

With the latest GUI I can't edit my Waypoints without having to connect to the FC first. Is this on purpose or am I doing something wrong?

When I enter "1" for auto landing in the Waypoint "RTH" it reverts back to "0". Error in the GUI?
by Leo
Sun Feb 21, 2016 10:24 am
Forum: Pictures & Videos
Topic: Multiwii H-Quad build
Replies: 1
Views: 2756

Re: Multiwii H-Quad build

Nicely done :)
by Leo
Tue Feb 16, 2016 7:11 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

... You can change the land speed in centimeters per second in the GPS section with the #define LAND_SPEED 100 by changing the 100 to something less which could result in a smoother landing. My question for you now (for fly4fun, as he was wanting to know) is can you do a RTH and then flip a switch ...
by Leo
Sat Feb 13, 2016 5:05 pm
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

Today I did my quick first tries with the autoland option in MultiWii. The autoland function was activated via switch on the transmitter. I wanted to make sure it works before setting it up on EZ-GUI. The settings are stock and it seems to work good. I will have to check and see how I can tweak the ...
by Leo
Fri Feb 12, 2016 7:19 am
Forum: Getting Started - MultiWii config and setup
Topic: Multiwiiconf settings
Replies: 11
Views: 1978

Re: Multiwiiconf settings

I haven't tried that function either. Since I now have a backup QC from spare parts I had lying around I'm going to try it out too. I'll post a video of the flight as well. In the mission function when you draw the land waypoint and click on it to open it for parameter editing, you can set the alti...
by Leo
Thu Feb 11, 2016 7:48 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

@ezio, there is a bug in the latest version, in mission planner. If you draw a mission path, and select last waypoint as LAND, the distance is not calculated correctly - the length of the last segment is missing. This can be serious problem, because someone might send the copter too far, fooled by ...
by Leo
Tue Feb 09, 2016 6:52 am
Forum: Getting Started - MultiWii config and setup
Topic: Multiwiiconf settings
Replies: 11
Views: 1978

Re: Multiwiiconf settings

I haven't tried that function either. Since I now have a backup QC from spare parts I had lying around I'm going to try it out too. I'll post a video of the flight as well.
by Leo
Sat Jan 23, 2016 8:53 pm
Forum: Software development
Topic: A better MultiWii
Replies: 29
Views: 8707

Re: A better MultiWii

Interesting.....

Do you have a video e.g. on YouTube that gives an overview of the www software in action?
by Leo
Thu Jan 07, 2016 2:40 pm
Forum: Getting Started - MultiWii config and setup
Topic: Motors Spin When Armed
Replies: 2
Views: 466

Re: Motors Spin When Armed

Uncomment the following in config.h /**************************************************************************************/ /*********************** motor, servo and other presets ***********************/ /**************************************************************************************/ /* m...
by Leo
Wed Jan 06, 2016 8:28 am
Forum: Getting Started - MultiWii config and setup
Topic: Crius AIO stk_500 ISSUE related to using 232 Ttl ftdi cable?
Replies: 10
Views: 1089

Re: Crius AIO stk_500 ISSUE related to using 232 Ttl ftdi ca

Under "Tools" -> "Programmer" you should have "AVRISP mkll" set.
by Leo
Tue Jan 05, 2016 4:18 pm
Forum: Getting Started - MultiWii config and setup
Topic: Crius AIO stk_500 ISSUE related to using 232 Ttl ftdi cable?
Replies: 10
Views: 1089

Re: Crius AIO stk_500 ISSUE related to using 232 Ttl ftdi ca

Check out your own eBay link concerning the board and look at the specs....

Then you should realize what you are doing wrong....
by Leo
Tue Jan 05, 2016 7:53 am
Forum: Getting Started - MultiWii config and setup
Topic: Crius AIO stk_500 ISSUE related to using 232 Ttl ftdi cable?
Replies: 10
Views: 1089

Re: Crius AIO stk_500 ISSUE related to using 232 Ttl ftdi ca

You are wondering correctly because you don't need a FTDI cable to program this board!!

Just use a standard micro USB cable and plug that into the USB socket on the board and the other end to your USB port on the computer.
by Leo
Sat Jan 02, 2016 8:47 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

Yes sir, 100% correct :)

I have a Samsung S2.
by Leo
Fri Jan 01, 2016 9:08 pm
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

:oops:

Thanks Bart :)
by Leo
Fri Jan 01, 2016 5:47 pm
Forum: Shields, boards and sensors
Topic: MultiWiiConf is not displaying correctly (white screen)
Replies: 6
Views: 2916

Re: MultiWiiConf is not displaying correctly (white screen)

MultiWiiConf is programmed with http://processing.org/, not Arduino.

You will need to download version 2.2.1. for MultiWiiConf.
by Leo
Fri Jan 01, 2016 1:58 pm
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 255939

Re: MultiWii EZ-GUI

Hi Ezio, I just downloaded Version 3.6.216 and I can't figure out how to use the app. The former config page is no longer available so I can't select which one of my 4 Blue tooth Quads to talk to. John I have the same problem. It doesn't matter if I have my phone upright or tilted. The dotes don't ...
by Leo
Tue Dec 29, 2015 6:55 am
Forum: Software development
Topic: MultiWii OSD - MWOSD
Replies: 872
Views: 138566

Re: MultiWii OSD - MWOSD

Thanks. I just wanted to make sure that I've done everything correctly on my setup.
To compensate I think I will just add 0.3V using "Voltage adjust" (edit 2) or set the alarm lower by 0.3V.

Edit: For reference I'm using v1.5.2.0 - R1.6 pre.
by Leo
Mon Dec 28, 2015 9:01 pm
Forum: Software development
Topic: MultiWii OSD - MWOSD
Replies: 872
Views: 138566

Re: MultiWii OSD - MWOSD

I need some advice concerning the display voltage option. My OSD board has this option. I have it connected directly to the lipo (plus) to read voltage. I set up the display as stated in MWOSD guide "Calibration". Fully charged 3S lipo at 12.6 volts. Adjusted it to 12.6V on the display usi...
by Leo
Sun Dec 27, 2015 2:16 pm
Forum: Software development
Topic: Heading > 180 degrees with magnetic declination
Replies: 1
Views: 1355

Re: Heading > 180 degrees with magnetic declination

Thanks for this. I've updated my code on both my QC's.
by Leo
Mon Dec 21, 2015 7:49 am
Forum: Pictures & Videos
Topic: Latest build
Replies: 3
Views: 2926

Re: Latest build

Nice setup. You're going to enjoy the FPV flights.
by Leo
Wed Nov 18, 2015 5:57 pm
Forum: Software
Topic: Trouble with Multiwii sofwear
Replies: 8
Views: 4880

Re: Trouble with Multiwii sofwear

Guys, when posting the code please use the "Code" tags. Makes it easier on the eyes.

@JFRouh: Please post your complete config.h and post exactly what hardware components you are using.