Search found 34 matches

by polo_fly2
Mon Jul 29, 2013 3:58 pm
Forum: Software
Topic: Baseflight aka multiwii port to stm32
Replies: 1036
Views: 2309848

Re: Baseflight aka multiwii port to stm32

Hi, I have flashed the dev-r363 to my acro-naze, just see what will happen . My tri flies superb with. A big positive change in behavior compared to the release r304 which I had before. Very stable even in turbulent air. If like you can see a short video with unprofessionally taped camera on it duri...
by polo_fly2
Fri Jun 07, 2013 5:47 pm
Forum: Software
Topic: Baseflight aka multiwii port to stm32
Replies: 1036
Views: 2309848

Re: Baseflight aka multiwii port to stm32

R288 is latest stable, 304 was actually mistake build, and shouldn't be used, i think it had some bug in it. Or you can build latest head revision yourself, there are several people flying it without issues. OK. I´ll try the R288. For building head revision myself I have first to learn how to do it...
by polo_fly2
Fri Jun 07, 2013 12:42 pm
Forum: Software
Topic: Baseflight aka multiwii port to stm32
Replies: 1036
Views: 2309848

Re: Baseflight aka multiwii port to stm32

Hello, I receveied one Acro Naze 32 from japan the last days. This will be my first 32 bit happy experience. The board is going to take place in a new tricopter, only for acro flying . To make the board up to date I would like to upload the baseflight release r.304 from May 2. on it. Timecop : can I...
by polo_fly2
Tue Jun 04, 2013 6:31 pm
Forum: Software development
Topic: General servo handler - almost done
Replies: 115
Views: 18544

Re: General servo handler - almost done

hey,

that sounds perfect clever and simple ... thank you a lot :-)

Georg
by polo_fly2
Tue Jun 04, 2013 6:03 pm
Forum: Software development
Topic: General servo handler - almost done
Replies: 115
Views: 18544

Re: General servo handler - almost done

Hi Copterritchie,

.. so do you have a separate 5V powersource for the arduino ?
by polo_fly2
Tue Jun 04, 2013 11:25 am
Forum: Software development
Topic: General servo handler - almost done
Replies: 115
Views: 18544

Re: General servo handler - almost done

I cannot remeber that it was jitterfree before. On all tris I have built , (since mwi 2.0) it was always there.
Btw. The new GUI is great improvement for adjusting the servo travel and midpoint, without recompiling and uploading
the whole software again and again. Thank you :-)

georg
by polo_fly2
Tue Jun 04, 2013 10:55 am
Forum: Software development
Topic: General servo handler - almost done
Replies: 115
Views: 18544

Re: General servo handler - almost done

Hello, I just have installed the shared dev_1457 on a new tri with a 32u4 (nanowii). In combination with the last zipped GUI from PatrikE everything seems to work fine. A short flighttest was just as I like it. But one thing I do not understand: Why does the tailservo jitter during the initialisatio...
by polo_fly2
Fri Oct 26, 2012 1:59 pm
Forum: Software development
Topic: MWC R1232 has a bug in ALT reading
Replies: 38
Views: 4094

Re: MWC R1232 has a bug in ALT reading

pl is a pilotlamp. You should undefine as much as possible or get a bigger FC. Nils you are right. Before it was not my plan to go with all that GPS stuff. But I like the Nanowii, it is the third one I use, of course with GPS, its on extreme limit, but it works. I had the Magneto and Baro since rel...
by polo_fly2
Fri Oct 26, 2012 12:48 pm
Forum: Software development
Topic: MWC R1232 has a bug in ALT reading
Replies: 38
Views: 4094

Re: MWC R1232 has a bug in ALT reading

have you installes a buzzer or a pl? hi jevermeister, have no buzzer, no lcd, no vbat , (what is pl ?) but I got the right size for 32u4, ( I could undefine this one : //#define DEADBAND 6 ) now the sketch is 18,668 bytes ( 4 bytes left ), so I can test now.. anyway thank you for thinking about georg
by polo_fly2
Fri Oct 26, 2012 11:44 am
Forum: Software development
Topic: MWC R1232 has a bug in ALT reading
Replies: 38
Views: 4094

Re: MWC R1232 has a bug in ALT reading

Hello, I´d like to test the new r1232 but its just 10 bytes to big for my config ( i2c-GPS,HMC 5843,BMP 085 32u4 - nanowii board ) " Binary sktch size: 28,682 bytes ( of a 28,672 byte maximum) " I have already undifened evrething of the unneeded usual cofig.h settings. Does anybody know ho...
by polo_fly2
Fri Oct 26, 2012 11:08 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 256060

Re: MultiWii EZ-GUI

Hello polo_fly2, Could answer on these questions: 1. are you using MW version greater or equal than 2.1 ? 2. are you connected to MW ? 3. everything else works fine ? 4. have you changed serial speed ? hello Ezio, sure - I have 1: MW dev r1143 2: yes 3: yes ( when AUX-Table was missing on screen , ...
by polo_fly2
Thu Oct 25, 2012 7:41 am
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 256060

Re: MultiWii EZ-GUI

Hi Watz,

had this problem only once and do not know what the reason was? After a reboot of my samsung, the ez-gui and AUX menue worked again with no issues. I think ezio is working on improvments and this will be solved in the future updates - Ez-GUi is a cool tool. :-)
by polo_fly2
Wed Oct 24, 2012 9:40 pm
Forum: Pictures & Videos
Topic: My very first multicopter - Tricopter, upgraded to Y6
Replies: 15
Views: 3837

Re: My very first multicopter - Tricopter

hi, My actual tricopter weight is 1050 gr, with a 2200mah bat and without cam. I never did not try zero D. Will do it next time. One clip from last Sunday. The RTH was defined so that to fly just without turning the head, it flies backwards here. https://vimeo.com/52105028 Its just miserable quality...
by polo_fly2
Wed Oct 24, 2012 7:01 pm
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 256060

Re: MultiWii EZ-GUI

I see, but do not understand right what should it be. I thaught it means something like GPS refreshrate, and was afraid that there is something wrong with my setup. when I saw the high number in the field :-)
by polo_fly2
Tue Oct 23, 2012 3:42 pm
Forum: Pictures & Videos
Topic: My very first multicopter - Tricopter, upgraded to Y6
Replies: 15
Views: 3837

Re: My very first multicopter - Tricopter

hi vpb, just have seen your nice tricopter build.. Also I built one tri which looks like a brother to yours, but with 55 cm arms, 1000kv motors, and stiff 9x4.7 carbon reinforced props. Added also the GPS stuff and have now one very nice flying Tri with a working RTH function. I had to do a lot PID ...
by polo_fly2
Mon Oct 22, 2012 3:47 pm
Forum: Software development
Topic: MultiWii EZ-GUI
Replies: 1434
Views: 256060

Re: MultiWii EZ-GUI

Hello ezio, since few days I´m using your code 2.8 on my gyalaxy gt-19000. with MWii - shared r1143. Everything works fine for me, but only one time I had no chance to change the AUX switches ( they just were not present on the screen). Nothing helped, but restarting the phone. It was only one time ...
by polo_fly2
Mon Oct 22, 2012 3:28 pm
Forum: Software development
Topic: Crius GPS and I2C_GPS_NAV
Replies: 95
Views: 37824

Re: Crius GPS and I2C_GPS_NAV

its fine now But first I had to re-tune my PIDs for pitch and roll . At the end I went down with I + D by about 40 %. (still comfortable now in acro mode for me, but much better for the GPS features) Now I am using the GPS-PIDs published in pm1 recipe, and the PosHold works just fine . Yesterday tes...
by polo_fly2
Tue Oct 16, 2012 7:36 pm
Forum: Software development
Topic: Crius GPS and I2C_GPS_NAV
Replies: 95
Views: 37824

Re: Crius GPS and I2C_GPS_NAV

Now I have connected the Ublox-I2c Navboard solo (without Magneto) on 3.3V again . The i2c error is constant staying at 136. I repeated it with same result. The Navboard operates at 3.3V and is getting the Satelites too. Maybe I should go on with this I2c error ? What do you think ? thank you Georg...
by polo_fly2
Tue Oct 02, 2012 10:32 pm
Forum: Software development
Topic: Crius GPS and I2C_GPS_NAV
Replies: 95
Views: 37824

Re: Crius GPS and I2C_GPS_NAV

The power supply for the nav board normally is 5v. I don't know, if it does harm, when you pu 5v to the board. How much i2c errors do you have? Are they continously increasing? gps-for-pm1.JPG Hi pm1, just to report an another try. Now the navoard was powered by 5V. The I2C error was the same (stan...
by polo_fly2
Tue Oct 02, 2012 8:59 pm
Forum: Software development
Topic: Crius GPS and I2C_GPS_NAV
Replies: 95
Views: 37824

Re: Crius GPS and I2C_GPS_NAV

Now I have connected the Ublox-I2c Navboard solo (without Magneto) on 3.3V again . The i2c error is constant staying at 136. I repeated it with same result.
The Navboard operates at 3.3V and is getting the Satelites too. Maybe I should go on with this I2c error ? What do you think ?

thank you
Georg
by polo_fly2
Tue Oct 02, 2012 5:11 pm
Forum: Software development
Topic: Crius GPS and I2C_GPS_NAV
Replies: 95
Views: 37824

Re: Crius GPS and I2C_GPS_NAV

Hello 1. The intended way is to configure the board with u-center, save configuration to eeprom and connect to i2c board. Then you are limited to NMEA protocol 2. You can configure i2c-nav to ublox, flash i2c, configure gps to ublox 3. You can flash my code to i2c nav and connect gps without furthe...
by polo_fly2
Mon Oct 01, 2012 10:43 am
Forum: Software development
Topic: Crius GPS and I2C_GPS_NAV
Replies: 95
Views: 37824

Re: Crius GPS and I2C_GPS_NAV

Hello :-)

I have just received one CRIUS-CN 06 - V2.O GPS Board and the I2C navModule from RCtimer.
Can I follow pm1`s receipe for a GPS-I2C setup ( http://www.rcgroups.com/forums/showthread.php?t=1724694),
or is this only suitable for the CN 06 - V1.0 boards and there is another way to go with V2.0 boards ?

Does somebody know ?
Thank you
Georg
by polo_fly2
Wed Jul 11, 2012 12:40 pm
Forum: Software development
Topic: PID settings for EXT_MOTOR_RANGE
Replies: 19
Views: 2207

Re: PID settings for EXT_MOTOR_RANGE

hi and thanks, its clear now.. :-)

Georg
by polo_fly2
Wed Jul 11, 2012 10:52 am
Forum: Software development
Topic: PID settings for EXT_MOTOR_RANGE
Replies: 19
Views: 2207

Re: PID settings for EXT_MOTOR_RANGE

Hi, I´m just a bit confused about using Ext_Motor_Range or not. ?? Its a combo of Flyduino 25A - Simonk firmware ESCs connected to Nanowii (Promicro) Actually Ext_Motor_Range is activated in my config.h , and the copter is running absolutely normal and fine ?? Hamburger wrote that the SimonK ESC do ...
by polo_fly2
Tue Jul 03, 2012 11:02 am
Forum: Software development
Topic: Let's try to release 2.1: first try based on r949
Replies: 74
Views: 6546

Re: Let's try to release 2.1: first try based on r949

Hello, I installed the r949 on my tri yestreday for testing, but did not be able to arm anymore. Tha last ( and a very good running version) before was the dev_20120504. This tri is very simple config with only the orig. WMP , no ACC and the i2c Oled connected to a Flyduino Mini-Pro 328, Adresses an...
by polo_fly2
Wed Jun 27, 2012 9:59 am
Forum: Software development
Topic: Helicopter integration
Replies: 318
Views: 44388

Re: Helicopter integration

Hello Hamburger, hello Patrik,

Thank you for the warnings and tips with the zero and 1 . I have one original wmp an one MPU6050 for trying, I´ll be carefull with testing.
I´ll report how it works, maybe next week or so.

Georg
by polo_fly2
Wed Jun 27, 2012 8:41 am
Forum: Software development
Topic: Helicopter integration
Replies: 318
Views: 44388

Re: Helicopter integration

hello, Jsust a question about gyro-smoothing. Yesterday I played a little with my setup for a Tri and found that gyro smoothing affects the behavior of my yaw servo in a very positive way. It reduces the small nervous over corrections on the yaw servo nearly to zero . I think the Tri -yaw correction...
by polo_fly2
Mon Jun 25, 2012 11:57 am
Forum: Software development
Topic: Teensy Support ?
Replies: 24
Views: 5170

Re: Teensy Support ?

Hi Felix,

OK. I´ll follow you there ... and thanks a lot .

Georg
by polo_fly2
Mon Jun 25, 2012 10:21 am
Forum: Software development
Topic: Teensy Support ?
Replies: 24
Views: 5170

Re: Teensy Support ?

Halo Felix,

thank you for the new code. It works :-)- servo is moving now in the Tri- config.

Just another question. Is there any easy way to get the status LED pin ( D13 on ProMini) also on the NanoWii board somewhwre ?

Thanky you
Georg
by polo_fly2
Sat Jun 23, 2012 11:49 am
Forum: Software development
Topic: Teensy Support ?
Replies: 24
Views: 5170

Re: Teensy Support ?-NanoWii

Hello, I have exact the same issue like KoekieMonster but with a NanoWii and the last dev_20120622. In the Tricopter config the pin (6) is dead - 0V . In the Bi-copter config the servos (5+6) do move. I have looked in the code, but my level of understanding does not allow me to find a solution at th...
by polo_fly2
Sat May 26, 2012 9:13 pm
Forum: Software development
Topic: Tail keeps dropping in acro mode since dev20120504
Replies: 5
Views: 663

Re: Tail keeps dropping in acro mode since dev20120504

I had the same with my tri and the last dev. Adjusted only the pitch " I " from
0.038 to 0.058 and now the tail holds the pitch stick input nearly forever.

Georg
by polo_fly2
Wed Apr 04, 2012 10:51 pm
Forum: Software development
Topic: Multiwii 2.0 - yaw servo travel
Replies: 10
Views: 1203

Re: Multiwii 2.0 - yaw servo travel

Hi Patrik,
also for me your instruction worked perfect.
A bit difficult to know about this method. Maybe it should be documented somwhere ?

Thank you very much :-)

Georg
by polo_fly2
Tue Apr 03, 2012 6:18 pm
Forum: Software development
Topic: Multiwii 2.0 - yaw servo travel
Replies: 10
Views: 1203

Re: Multiwii 2.0 - yaw servo travel

Patrik, thank you for reply. Do you think, can it be a problem for the flightcalculation when the yaw servo endpoints are defined in
the radio and not in the eeprom? I have no lcd, but I think I should buy one.

Georg
by polo_fly2
Tue Apr 03, 2012 5:04 pm
Forum: Software development
Topic: Multiwii 2.0 - yaw servo travel
Replies: 10
Views: 1203

Multiwii 2.0 - yaw servo travel

Hello, I don´t know if this is a bug? I have just finished building a Tri and put the fresh 2.0. on it ( arduino nano328). When I came to the servo adjustment (hitec HS-65MG), I cannot see any effect when changing the start, end or midpoint in config.h. the servo ignores my changes simply. /* you ca...