Search found 16 matches

by Olaf.J
Sun Apr 29, 2012 11:07 pm
Forum: MultiWii tweaking - flying experience
Topic: Trouble adjusting yaw PID values
Replies: 10
Views: 3191

Re: Trouble adjusting yaw PID values

Yes, I did it several times now; however, I am still experiencing the drift around the yaw axis. Hi, I had the same problem with yaw. When I checked the motor-temperatur, the counterclockwise-rotating motors were very hot, the other both not. I solved it the following way: I set all the PID-values ...
by Olaf.J
Sat Apr 21, 2012 10:22 pm
Forum: MultiWii tweaking - flying experience
Topic: Trouble adjusting yaw PID values
Replies: 10
Views: 3191

Re: Trouble adjusting yaw PID values

Yes, I did it several times now; however, I am still experiencing the drift around the yaw axis. Hi, had you any success with your problem? I have the same issue. And if I try to eliminate the yaw drift by trimming the the copter, the drift reappears to one side, if I increase or decrease throttle...
by Olaf.J
Mon Apr 09, 2012 6:52 pm
Forum: Ideas
Topic: Real Subchannels - not only low/mid/high
Replies: 4
Views: 844

Re: Real Subchannels - not only low/mid/high

KaiK wrote:+1

We have to ensure the distance between "Subchannels" is great enough to avoid malefunction (recognice wrong level)...


Right, this could be made configurable - you could select, how many Bits (switches) should be used per Channel. This automatically Sets the bandwith per subchannel.
by Olaf.J
Mon Apr 09, 2012 1:20 pm
Forum: Ideas
Topic: Real Subchannels - not only low/mid/high
Replies: 4
Views: 844

Real Subchannels - not only low/mid/high

Hi, I'm not sure, if already someone has had the following idea (or a similar one) - but if not, perhaps the idea is not too bad I think, most people have to little channels at their TX/RX - I use 8 channels, but that's too less, if you want to activate/deactive all the things, like stable mode, mag...
by Olaf.J
Mon Apr 09, 2012 12:53 pm
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 134999

Re: Attemp to integrate sonar (ultrasonic sensor)

@Olaf, do you want to share your implementation? Thanks Peter Hi, it's not yet ready (it's sonar-mode only without mixing baro at the moment and I use a fix height of 180 cm at the moment, instead of height at activating), but if you want to test it already, here's the modified code for flyduino (a...
by Olaf.J
Mon Apr 09, 2012 12:18 pm
Forum: Software development
Topic: Bug in MAG-routine?
Replies: 14
Views: 1310

Re: Bug in MAG-routine?

Alexinparis wrote:Nothing seems to be wrong. please check all your code mods.


Seems, like nobody else has this problem with the MAG-routine. So perhaps you are right and it's an issue of any other code-modification made by me...
by Olaf.J
Sun Apr 08, 2012 4:34 pm
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 134999

Re: Attemp to integrate sonar (ultrasonic sensor)

Hi zjojos and noobee, thanks for your info about the D-parameter - I successfully implemented it and found suitable parameters for PID. When hoovering, the height is hold pretty good, if I move the copter, it first goes down 50-80 cm and then goes up to the target-height slowly. When stopping, it fi...
by Olaf.J
Sun Apr 08, 2012 12:48 am
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 134999

Re: Attemp to integrate sonar (ultrasonic sensor)

To avoid the Hula Hop you need the derivative term (on altitude speed) to brake the oscillation Hi, "derivative" is the D-Parameter, right? I'll try this - had removed it, because I didn't understood the D-calculation of the baro-control of MWii 2.0, but I implemented it for sonar now - b...
by Olaf.J
Sun Apr 08, 2012 12:35 am
Forum: Ideas
Topic: Position Hold with Optical Flow sensor - done
Replies: 214
Views: 68524

Re: Position Hold with Optical Flow sensor - done

Hi,

has anybode already successfully tried it with an adns 3080? Could be a nice idea to use it with atmega 2560-arduino (flyduino), because the ISP is normally not used, so you need only 1 extra pin, if I understood it right - whatever "NCS" means...
by Olaf.J
Fri Apr 06, 2012 6:01 pm
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 134999

Re: Attemp to integrate sonar (ultrasonic sensor)

noobee wrote:have you tried in increasing d at the same time (to a more negative value) with slightly higher p?


No, not yet. Unfortunately it's raining and windy at the moment - cannot try it any more today. I'll try this as soon as possible.
Thanks for the tip.
by Olaf.J
Fri Apr 06, 2012 2:56 pm
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 134999

Re: Attemp to integrate sonar (ultrasonic sensor)

Hi, Sonar-Results are very good - about 99% of the altitude-values of the sonar are valid But altitude control is not really good. Before mixing sonar and baro, I first want to get a stable alt-control only with sonar. But the copter is oscillating all the time. If I increase P to maximum, the copte...
by Olaf.J
Thu Apr 05, 2012 10:37 pm
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 134999

SRF04 with Flyduino (Atmega2560)

Hi, I think I've got it. It was a little bit difficult because of no experience with arduino, but it seems to work now with the Flyduino (Atmega2560): In the def.h, I defined the following: /* Pin to interrupt map: * PCINT 16-23 = PCIE2 = pcmsk2 = PCINT2_vect * PCINT 0-7 = PCIE0 = pcmsk0 = PCINT0_ve...
by Olaf.J
Wed Apr 04, 2012 10:52 am
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 134999

Use with Atmega 2560

Hi, has anybody successfully implemented this code for the Atmega 2560 (Flyduino)? I think, I will get it to use the Trigger-Pin, but I have really no idea, how to modify the code for using the echo-pin with interrupts. I'm using 8-channel transmitter/receiver, so I think the pins PK0 - PK7 are alre...
by Olaf.J
Sun Apr 01, 2012 1:47 pm
Forum: Software development
Topic: Bug in MAG-routine?
Replies: 14
Views: 1310

Re: Bug in MAG-routine?

rcCommand[YAW] is recomputed at each annexCode() call (from rcData[] which comes directly form RX.pde), ie once per cycle and before MAG compensation. no no error for me here Sounds absolutely logical - but if you add a debug2 = magHold at the end of the Yaw/MAG-routine and increase P-Value for MAG...
by Olaf.J
Sat Mar 31, 2012 11:31 pm
Forum: Software development
Topic: Bug in MAG-routine?
Replies: 14
Views: 1310

Re: Bug in MAG-routine?

Hmmm, but it looks like this routine should have the same issue - rcCommand[YAW] will possibly be set to a value greater than headingband - and then magHold will be modified, although it shouldn't. Or is it possibly an issue with the Arduino 1.0 that the else part will be executed when the condition...
by Olaf.J
Sat Mar 31, 2012 4:05 pm
Forum: Software development
Topic: Bug in MAG-routine?
Replies: 14
Views: 1310

Bug in MAG-routine?

Hi, the mag-routine is not working as expected with my copter. So I had a look at the sourcecode and I hope I found the reason, why big differences betweend maghold and heading result in almost no reaction to the copter. Here's the sourcecode: #if MAG if (abs(rcCommand[YAW]) <70 && magMode) ...