Search found 252 matches

by doughboy
Wed Oct 30, 2013 9:38 pm
Forum: Connecting elements
Topic: Connecting Ublox GPS to Multiwii SE board
Replies: 2
Views: 671

Re: Connecting Ublox GPS to Multiwii SE board

to answer your why question, since you bought all 3 components, why would you not use the ttl->i2c?
it is best to use the converter. you will not be able to view the gps while connected to multiwii conf since the 328 only has one serial port.
the i2c on the gps is only for connecting to the eeprom.
by doughboy
Wed Oct 30, 2013 12:59 am
Forum: Software development
Topic: GPS NAV
Replies: 964
Views: 191438

Re: GPS NAV

I hope I2C GPS is killed with 2.3 so people move on and stop wasting time with trying to "navigate" on "promini". ffs, its 16mhz with like 16k flash and 1k ram. give UP. Lovely TimeCop style ... LOL ProMini is 32kb flash, and 2k ram the common 328 based ProMini ... yes 168 is de...
by doughboy
Thu Sep 26, 2013 8:43 pm
Forum: Shields, boards and sensors
Topic: U-center packet console showing extra unknown messages
Replies: 0
Views: 543

U-center packet console showing extra unknown messages

I uploaded the ublox configuration that comes with i2c_nav, and looking at packet console, I see this 02:06:23 UBX NAV-SOL, Size 60, 'Navigation Solution' 02:06:23 UBX NAV-STATUS, Size 24, 'Navigation Status' 02:06:23 UBX NAV-POSLLH, Size 36, 'Geodetic Position' 02:06:23 UBX NAV-VELNED, Size 44, 'Ve...
by doughboy
Mon Sep 23, 2013 7:35 pm
Forum: Getting Started - MultiWii config and setup
Topic: u-center and neo6m gps question
Replies: 1
Views: 452

u-center and neo6m gps question

I just got a neo6m gps and connected it to u-center and updated the configuration to 115200 baud, ublox binary,etc etc. my question is, I see on u-center, right column data updating, 3D fix, compass, altitude, clock etc updating. But the column for satellite position, satellite level history, satell...
by doughboy
Thu Sep 12, 2013 9:07 pm
Forum: General discussions
Topic: I just got the fastest delivery from China :)
Replies: 1
Views: 420

I just got the fastest delivery from China :)

shipped 9/9, delivered 9/12. This is for a mega2560 board for $11.50 with free shipping.

Image
by doughboy
Wed Sep 11, 2013 6:36 pm
Forum: General discussions
Topic: build with I2C_GPS_SONAR fails on r1563
Replies: 2
Views: 562

Re: build with I2C_GPS_SONAR fails on r1563

thanks for fixing.
I'm still waiting for my gps ($17).
I already got a promini ($3.75) and a sonar ($1.35) and burned the i2c_nav, and added my ppmsum code to it.

everything is so cheap now, there is no reason for anyone not to use gps (and perhaps sonar).
by doughboy
Mon Sep 09, 2013 3:51 am
Forum: Software development
Topic: DEV r1553 - Minthrottle not setting correctly
Replies: 15
Views: 2632

Re: DEV r1553 - Minthrottle not setting correctly

processing 2.0 has disabled 64 bit support for serial library. If you really want 64 bit, you can use processing 1.5. I believe you need to find and install 64 bit rxtx dll for 64 bit to work in processing 1.5.
by doughboy
Sun Sep 08, 2013 8:51 am
Forum: Software development
Topic: Problems with vbat
Replies: 21
Views: 2278

Re: Problems with vbat

I don't get it at all. Why would i use a 2.2 release gui with a shared FW ?? i've been using official release 2.2 with its GUI. I found the shared codes, but didn't download them as i didn't know if i needed them. I'm not using a mix of the 2 (i.e official + shared), have i said otherwise ? When i ...
by doughboy
Sun Sep 08, 2013 1:44 am
Forum: Software development
Topic: Problems with vbat
Replies: 21
Views: 2278

Re: Problems with vbat

Well, i am using the official 2.2, and my multimeter agrees with the GUI. To hit reset solved my vbatscale-related problem. I have also the frsky FBVS01 displaying the voltage on my radio. Gives me another independent check. I have an accuracy of 0.05V on GUI though. Not 0.001 contrary to what the ...
by doughboy
Sat Sep 07, 2013 4:55 pm
Forum: Software development
Topic: Problems with vbat
Replies: 21
Views: 2278

Re: Problems with vbat

the only way I can see the eeprom is not initialized is if this code was not executed #ifndef NO_FLASH_CHECK if(readEEPROM()) { // check current setting integrity if(flashsum != global_conf.flashsum) update_constants(); // update constants if firmware is changed and integrity is OK } #else I remembe...
by doughboy
Sat Sep 07, 2013 4:29 pm
Forum: Software development
Topic: Problems with vbat
Replies: 21
Views: 2278

Re: Problems with vbat

this is the code in the firmware that is supposed to initialize the vbat, minthrottle, etc settings if(readEEPROM()) { // check current setting integrity if(flashsum != global_conf.flashsum) update_constants(); // update constants if firmware is changed and integrity is OK } I think it does not work...
by doughboy
Sat Sep 07, 2013 4:13 pm
Forum: Software development
Topic: Problems with vbat
Replies: 21
Views: 2278

Re: Problems with vbat

now I can see that if somehow, the MultiWii_shared firmware is able to initialize the EEPROM with the proper values, then the 2.2 release may work, since it will not overwrite (I think) the vbat values set during eeprom write command. But for sure, no matter how much you click reset and write on the...
by doughboy
Sat Sep 07, 2013 4:08 pm
Forum: Software development
Topic: Problems with vbat
Replies: 21
Views: 2278

Re: Problems with vbat

Ok, problem solved, reset in GUI in official release was enough to display the right voltage. I also found the shared version of the code. Not sure if i need it though ? now that everything is working. I'm pretty sure the release gui by itself will not fix the problem. there is no code behind that ...
by doughboy
Sat Sep 07, 2013 1:04 am
Forum: Software development
Topic: DEV r1553 - Minthrottle not setting correctly
Replies: 15
Views: 2632

Re: DEV r1553 - Minthrottle not setting correctly

ok, Patrick, you got the correct answer. The MultiWiiConf_shared MUST be used when using MultiWii_shared firmware!! this is what I posted in the vbat thread ok, I ran into this issue, as well as the throttle issue. and as others pointed out, the MW GUI is the problem. If you are using code in shared...
by doughboy
Sat Sep 07, 2013 1:02 am
Forum: Software development
Topic: Problems with vbat
Replies: 21
Views: 2278

Re: Problems with vbat

ok, I ran into this issue, as well as the throttle issue. and as others pointed out, the MW GUI is the problem. If you are using code in shared, you must use the Gui from shared, as that has the page that allows you to set the VBATSCALE, MINTHrOTTLE, etc. Without this, I think they just get a value ...
by doughboy
Fri Sep 06, 2013 10:39 pm
Forum: Software development
Topic: DEV r1553 - Minthrottle not setting correctly
Replies: 15
Views: 2632

Re: DEV r1553 - Minthrottle not setting correctly

hmm, I am using MW conf from 2.2 release (compiled), not the shared one (source only). I did say that 2.2 release FW I did not have any problem, only on shared. if mismatched gui and fw will cause problem, perhaps there should be a check in gui if the fw matches. but if that is the case, I shouldn't...
by doughboy
Fri Sep 06, 2013 5:27 pm
Forum: Software development
Topic: DEV r1553 - Minthrottle not setting correctly
Replies: 15
Views: 2632

Re: DEV r1553 - Minthrottle not setting correctly

I tried to follow the code in the mix tables function, and I cannot see any problem. I did manual calculations etc and everything checks out. so then I noticed on the MWGUI, the voltage is showing some funny value, so I started changing the value of VBAT_SCALE, and tried out a few different values a...
by doughboy
Fri Sep 06, 2013 6:08 am
Forum: General discussions
Topic: build with I2C_GPS_SONAR fails on r1563
Replies: 2
Views: 562

Re: build with I2C_GPS_SONAR fails on r1563

I guess I'll just comment out I2C_GPS_SONAR, since the sonar code is really not used anywhere except for landing lights.
still needs to be fixed though
by doughboy
Fri Sep 06, 2013 5:59 am
Forum: General discussions
Topic: build with I2C_GPS_SONAR fails on r1563
Replies: 2
Views: 562

build with I2C_GPS_SONAR fails on r1563

Building file: ../src/MultiWii/GPS.cpp Invoking: AVR C++ Compiler avr-g++ -I"C:\arduino-eclipse\kepler\Arduino\include" -I"C:\arduino-eclipse\kepler\Arduino\include\variants\standard" -DUSB_PID=null -DUSB_VID=null -DARDUINO=105 -Wall -g2 -Os -fno-exceptions -ffunction-sections -f...
by doughboy
Fri Sep 06, 2013 2:23 am
Forum: Getting Started - MultiWii config and setup
Topic: cannot write PID values / bricked HK pocket quad
Replies: 5
Views: 742

cannot write PID values / bricked HK pocket quad

Did you try loading the blinking LED example sketch? If LED blinks then the hardware is still good
by doughboy
Wed Sep 04, 2013 7:37 pm
Forum: Connecting elements
Topic: 328p gps
Replies: 8
Views: 2088

Re: 328p gps

question on the i2c-nav-card. I currently have a spare mini arduino. I cannot find any schematic diagram for using arduino mini (though it was mentioned in the i2c-nav-card page). Do I just connect the vcc+tx+rx+gnd to the ublox gps then the i2c to the main board i2c? The ublox uart rx tx lines are ...
by doughboy
Tue Sep 03, 2013 9:17 pm
Forum: Software development
Topic: Building MultiWii in Eclipse
Replies: 25
Views: 3883

Re: Building MultiWii in Eclipse

with the current eclipse project setup, how do I checkout files from an earlier revision?

the svn:externals link to src directory is hardcoded to get the head revision on MultiWii_shared. I want to build an earlier revision so I need to check out based on a specific revision number.

thanks
by doughboy
Tue Sep 03, 2013 6:31 pm
Forum: Software development
Topic: DEV r1553 - Minthrottle not setting correctly
Replies: 15
Views: 2632

Re: DEV r1553 - Minthrottle not setting correctly

Hi, 5. Using oscilloscope, when disarmed the waveform is ~20% ON (normal - looks like its at 'MINCOMMAND 1000') not really normal: disarmed means signal = 1000us => at 490Hz, the waveform should be around 50% I would start investigation here I agree with Geebles observation. It does look like the c...
by doughboy
Tue Sep 03, 2013 4:04 pm
Forum: General discussions
Topic: r1561 breaks compilation in Arduino IDE
Replies: 3
Views: 412

r1561 breaks compilation in Arduino IDE

Ok, I thought it was just me unable to compile using arduino IDE. Anyway, I ended up setting up eclipse only to find more problems there. Moving to eclipse may be well and good, but that will not eliminate problems like people checking in without testing. Eclipse can certainly help in program qualit...
by doughboy
Mon Sep 02, 2013 9:27 pm
Forum: Software development
Topic: DEV r1553 - Minthrottle not setting correctly
Replies: 15
Views: 2632

Re: DEV r1553 - Minthrottle not setting correctly

Clear Eeprom with the Arduino example sketch. I thought that clearing eeprom issue was resolved by adding the checksum. anyway, I cleared it and it did not make any difference. I tried the 2.2 release and everything works fine. so something got messed up between 2.2 release and the current head rev...
by doughboy
Mon Sep 02, 2013 9:13 pm
Forum: Software development
Topic: standard 3 i2c erros with r1557 and i2c-gps
Replies: 5
Views: 633

Re: standard 3 i2c erros with r1557 and i2c-gps

I don't have gps enabled and I see 3 i2c error.
by doughboy
Mon Sep 02, 2013 12:19 am
Forum: Software development
Topic: DEV r1553 - Minthrottle not setting correctly
Replies: 15
Views: 2632

DEV r1553 - Minthrottle not setting correctly

Not sure if I'm running into the same problem. I've had my quad on pre 2.2 software and everything works fine. I just upgraded to latest and now the motors don't turn on at all (it arms) with my throttle curve settings I used on 2.1 motors don't come on at all even at 100% throttle. If I reset to de...
by doughboy
Tue Aug 20, 2013 7:00 pm
Forum: Connecting elements
Topic: LED Flasher on Multiwii 328P
Replies: 1
Views: 807

Re: LED Flasher on Multiwii 328P

according to this
//#define LED_FLASHER_PORT PORTB
//#define LED_FLASHER_BIT PORTB4
it is digital pin 12 on atmega328/uno board, or digital pin 10 on the atmega2560/mega board.
by doughboy
Sat Jul 20, 2013 9:22 pm
Forum: Getting Started - MultiWii config and setup
Topic: FlightMode with 4 Channel TX
Replies: 4
Views: 540

FlightMode with 4 Channel TX

If you are handy with modifying the program, you can use stick combinations to switch flight modes, but has to be switched while not armed.

Use the acc trims stick combinations to reduce or eliminate drift.
by doughboy
Tue Jan 15, 2013 6:46 pm
Forum: Software development
Topic: Why 64bit multiwii_conf not included anymore
Replies: 30
Views: 2550

Re: Why 64bit multiwii_conf not included anymore

I checked my copy of mw conf I downloaded a while back, and used dependencywalker to check if dll is 32 or 64 bit. interesting enough, mw conf 64 does come with 64 bit rxtx dll (obviously not the official rxtx dll), and mw conf 32 comes with 32 bit rxtx dll. however, I see MultiWiiConf exe that come...
by doughboy
Tue Jan 15, 2013 5:40 pm
Forum: Software development
Topic: Why 64bit multiwii_conf not included anymore
Replies: 30
Views: 2550

Re: Why 64bit multiwii_conf not included anymore

Your setup might have the working 64 bit dll in windows/system32 that gets picked up by multiwii_conf to explain why you got it to work. I do not have any rxtx dll's in windows dir, still older downloads works OK. Test that. Only dev builds are "32-bit-only" and requires another copy of J...
by doughboy
Tue Jan 15, 2013 1:23 am
Forum: Software development
Topic: Why 64bit multiwii_conf not included anymore
Replies: 30
Views: 2550

Why 64bit multiwii_conf not included anymore

Ok, the "official" multiwii_conf build comes with 32bit dll.

Your setup might have the working 64 bit dll in windows/system32 that gets picked up by multiwii_conf to explain why you got it to work.

Without the proper 64 bit dll, it is physically impossible to work.
by doughboy
Tue Jan 15, 2013 1:20 am
Forum: Software development
Topic: Why 64bit multiwii_conf not included anymore
Replies: 30
Views: 2550

Why 64bit multiwii_conf not included anymore

If Arduino IDE works on 64 bits, then they may be using the proper 64 bit rxtx dll. You can probably dig through the Arduino files and get the dll and try using it it miltiwii_conf with 64 bit jvm.
by doughboy
Tue Jan 15, 2013 1:14 am
Forum: Software development
Topic: Why 64bit multiwii_conf not included anymore
Replies: 30
Views: 2550

Why 64bit multiwii_conf not included anymore

I am pretty sure 64 bit will not work. You probably got the GUI up and jumped to the conclusion that it works. Once a serial connection is made and the rxtx dll is accessed, you will get a java exception. 64 bit jvm cannot load 32 bit dll. Hence it is correct to not include 64 bit program as it give...
by doughboy
Mon Jan 14, 2013 6:32 am
Forum: Software development
Topic: Why 64bit multiwii_conf not included anymore
Replies: 30
Views: 2550

Why 64bit multiwii_conf not included anymore

Because the official Rxtx library only comes in 32 bit.
by doughboy
Fri Dec 21, 2012 2:49 am
Forum: ESCs, propellers , servos and radios
Topic: One hot ESC
Replies: 11
Views: 2540

One hot ESC

Is the BEC completely disconnected? If not then it is most likely shorted.
by doughboy
Fri Dec 21, 2012 1:39 am
Forum: Software development
Topic: Failsafe and Sum-PPM
Replies: 24
Views: 2311

Failsafe and Sum-PPM

Your video and your description is all right. The change in failsafe code is in _shared. I don't know if it is in official release version, but apparently it is not. There was a thread that resulted in the change to check for signal on all 4 sticks channels and this is one of the reason for the fix....
by doughboy
Thu Dec 20, 2012 5:08 pm
Forum: Software development
Topic: Failsafe and Sum-PPM
Replies: 24
Views: 2311

Failsafe and Sum-PPM

Correction: The Turnigy 9xBC version 2 maintains the last values received from the Transmitter on Channels 4 and 5 upon signal lost. I was going to just abandon this project however, it has revealed other problems else where. I will try to document this as best I can. Even if it does, it will occur...
by doughboy
Thu Dec 20, 2012 7:16 am
Forum: Software development
Topic: Failsafe and Sum-PPM
Replies: 24
Views: 2311

Failsafe and Sum-PPM

What is needed in my opinion is a pulse counter in the frame. What I mean about that is, at start up, the FC count the number of pulses in the stream and if that pulse count falls below, then active the failsafe. So if there is eight channels at start up and for some reason that count drops to six ...
by doughboy
Thu Dec 20, 2012 3:54 am
Forum: Software development
Topic: Failsafe and Sum-PPM
Replies: 24
Views: 2311

Failsafe and Sum-PPM

It has to be something else causing the problem. If the RX is only sending out channel 4 and 5 pulse then failsafe will still kick in. I'll check the failsafe code again just to make sure, but I know the code works fine last time I checked it. This is based on stock _shared code with no modification...
by doughboy
Wed Dec 12, 2012 2:32 am
Forum: Getting Started - MultiWii config and setup
Topic: Initialisation problem with 328P controller
Replies: 3
Views: 797

Initialisation problem with 328P controller

That's how mine is connected, BEC is powering my FC board.
by doughboy
Tue Dec 11, 2012 6:10 pm
Forum: Getting Started - MultiWii config and setup
Topic: Initialisation problem with 328P controller
Replies: 3
Views: 797

Re: Initialisation problem with 328P controller

if the firmware is bad, it will be bad regardless of how many times you reconnect the battery.
look for cold solder, particularly if you are using bullet connectors for esc.
by doughboy
Tue Dec 11, 2012 6:02 pm
Forum: Ideas
Topic: Gyro calibration (zeroing), movement detection
Replies: 33
Views: 5272

Re: Gyro calibration (zeroing), movement detection

If we all look at this objectively, MIS committed the original code, with no option to disable. Nils ran into some problem, then made the change to add a config option and disabled by default. m As far as I can tell from previous discussion, even Alex thinks the issue Nils encountered should be addr...
by doughboy
Mon Dec 10, 2012 8:40 pm
Forum: Ideas
Topic: Gyro calibration (zeroing), movement detection
Replies: 33
Views: 5272

Re: Gyro calibration (zeroing), movement detection

Good! But i can't imagine doing a gyro zero calibration without this movement check! Why is it not enabled by default ? Thanksmanu I agree. why it is not enabled? people with check in priviledge is turning mw source into their own personal source code. just look at trunk/multiwii, someone checked i...
by doughboy
Mon Dec 10, 2012 8:33 pm
Forum: MultiWii tweaking - flying experience
Topic: Max Throttle Lift issues
Replies: 17
Views: 2291

Re: Max Throttle Lift issues

I think if flashing using megapirate firmware resolves the issue, then this rules out hardware as the problem.
if subaru4wd can test flashing using latest mw dev, then this problem can be isolated.
by doughboy
Sat Dec 08, 2012 8:01 pm
Forum: Software development
Topic: An Official 2.2 Release soon?
Replies: 26
Views: 4305

An Official 2.2 Release soon?

Did it work fine before or is this the first time you are testing the low bat warning code? I think when I looked at your branch code the last time, that is the same code I have. You have all sensors right? Try disabling them one by one. Start with GPS.
by doughboy
Sat Dec 08, 2012 7:52 pm
Forum: Software development
Topic: An Official 2.2 Release soon?
Replies: 26
Views: 4305

An Official 2.2 Release soon?

I noticed some weird soouns withe battery level warnings and pilotlamp inflight... nils I have not flown recently, but I always rely on the pilot lamp low bat sound and it works fine for me. I fly it till I get the second level warning. I'll compare my code to the latest to see if there is any diff...
by doughboy
Wed Nov 28, 2012 7:18 am
Forum: Getting Started - MultiWii config and setup
Topic: PilotLamp + Spektrum Sat. + HK_MultiWii_328P not working!?
Replies: 8
Views: 1432

Re: PilotLamp + Spektrum Sat. + HK_MultiWii_328P not working

if you want to permanently not use the buzzer, then change in def.h from this #define PL_BZR_ON 175 // 700us #define PL_BZR_OFF 200 // 800us to this #define PL_BZR_ON 200 // force off #define PL_BZR_OFF 200 // 800us I'd say the buzzer is quite useful, particularly for letting you know when the batte...