Search found 28 matches

by haley0918
Fri Mar 29, 2013 3:57 pm
Forum: Shields, boards and sensors
Topic: XAircraft Pilot Lamp Accessory Hack
Replies: 96
Views: 15872

Re: XAircraft Pilot Lamp Accessory Hack

I'd just solved it. The problem was from my define of buzzer pin override. I'm using HK Multiwii 328 board that has no D8 so I have to re-route to A2. With the override defined, the normal buzzer functions were enabled and it's pulses interfere with the Pilotlamp pulses. But when the override undefi...
by haley0918
Fri Mar 29, 2013 3:19 pm
Forum: Shields, boards and sensors
Topic: XAircraft Pilot Lamp Accessory Hack
Replies: 96
Views: 15872

Re: XAircraft Pilot Lamp Accessory Hack

Hi, I'd just acquired a Pilotlamp for my quad. I'm loading my quad with v2.2. The arm indication with green LED works fine. But when I turn on Beeper, it occasionally skips the green LED. The buzzer on the Pilotlamp also seems to have trouble picking up the pulse signals. The Pilotlamp buzzer occasi...
by haley0918
Mon Mar 25, 2013 3:06 pm
Forum: Shields, boards and sensors
Topic: BMP085 sensor value stop update
Replies: 4
Views: 698

Re: BMP085 sensor value stop update

Hi, Yes, in some trails I'd had it over 2 hours before the freezing. I did a number of trails with their time recorded each time and some of them went over the 71 minutes limit as you said. If the error was caused by the code section that overflow I could only say that my board might have the clock ...
by haley0918
Thu Jan 17, 2013 10:55 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

Here's a demonstration on the issue.

http://youtu.be/GO_IrbIIy-A
by haley0918
Thu Jan 17, 2013 8:37 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

copterrichie wrote:I recall reading something about the voltage levels on some USB ports especially on a MAC, have you tried another computer or a USB Hub?


I'm not a MAC fan so yep, normal PC. Measured the voltage to be at 4.8V.

I don't see how is this is related to voltage supplied.
by haley0918
Thu Jan 17, 2013 8:21 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

Gimbal wrote:mayby check fuses?


May i know what are your fuse values?

I currently have:

lfuse - FF
hfuse - D8
efuse - FD
lock - FF
by haley0918
Thu Jan 17, 2013 8:15 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

I'm powering with default 5V from USB. I'd tried separate cable for power and serial data. Using terminal to send random data to the running Mega2560 and press reset. Still, stuck at bootloader until i stop sending in anything.
by haley0918
Thu Jan 17, 2013 8:07 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

Strange! I'd tried on both Crius AIO Pro and original Mega 2560 board. Both stuck at the bootloader.
by haley0918
Thu Jan 17, 2013 3:16 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

Just curious if using the ISP to program the ATMega2560 bypassing the Bootloader all together would resolve the problem? By right it should, but that won't be friendly for some of our flight controller setup where only horizontal USB entry is the solution. Looking through the bootloaders for Mega25...
by haley0918
Thu Jan 17, 2013 1:01 pm
Forum: Ideas
Topic: 0.96" SSD1306 128X64 OLED Display Module
Replies: 207
Views: 169066

Re: 0.96" SSD1306 128X64 OLED Display Module

Thanks! Will do once I whip out another frame.

I'm still comfortable with the old flight modes and settings for my current frame which has an important task coming up in a month.
by haley0918
Thu Jan 17, 2013 12:05 pm
Forum: Ideas
Topic: 0.96" SSD1306 128X64 OLED Display Module
Replies: 207
Views: 169066

Re: 0.96" SSD1306 128X64 OLED Display Module

So no one else has tried this on released 2.1?

Guess I'll just have to leave if off until 2.2.
by haley0918
Thu Jan 17, 2013 12:02 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

Hamburger wrote:cannot you use the modified bootloader from ronco for the promicro, replacing the leonardo bootloader?


I'm targeting this issue specifically at ATMega2560 which I have at hand. Leonardo and Ronco's bootloader does not work on this different MCU.
by haley0918
Thu Jan 17, 2013 10:31 am
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Re: Mega2650 reset freeze

I had been tracing down the fault. It turns out to be the bug on the Mega2560 bootloader. The Mega2560 has been know for issues with its bootloader. The bootloader contains a "monitor" function that allows to bring up by sending "!!!" during reset. Although not specified by anyon...
by haley0918
Thu Jan 17, 2013 5:00 am
Forum: Ideas
Topic: 0.96" SSD1306 128X64 OLED Display Module
Replies: 207
Views: 169066

Re: 0.96" SSD1306 128X64 OLED Display Module

Just tried a few devs, r1240, r1311 and r1315. They all worked.

So is this a bug for 2.1?
by haley0918
Wed Jan 16, 2013 8:39 pm
Forum: Ideas
Topic: 0.96" SSD1306 128X64 OLED Display Module
Replies: 207
Views: 169066

Re: 0.96" SSD1306 128X64 OLED Display Module

1. checked, endpoints going below 1100 and above 1900, reaching minimum 990 and maximum 2000 2. had held it for more than 2 seconds without response 3. commented that, still no go I'm now out of idea where does it went wrong. EDIT: I had debugged the "telemetry_auto" variable and there was...
by haley0918
Wed Jan 16, 2013 7:33 pm
Forum: Ideas
Topic: 0.96" SSD1306 128X64 OLED Display Module
Replies: 207
Views: 169066

Re: 0.96" SSD1306 128X64 OLED Display Module

Indecently, I cant get Telemetry auto to work. The stick combination of throttle low, roll left and pitch forward does not initiate the auto telemetry screen hopping (debug works though) I have the similar problem as above. Enabled LCD_TELEMETRY_AUTO and LCD_TELEMETRY_STEP in the code but the scree...
by haley0918
Wed Jan 16, 2013 4:57 pm
Forum: Shields, boards and sensors
Topic: Mega2650 reset freeze
Replies: 16
Views: 1990

Mega2650 reset freeze

Hi, I have a CRIUS AIO PRO with Mega2560 and loaded with firmware 2.1. Upon connection to the GUI, I have to stop the GUI from polling on the serial or the firmware would just freeze. Is this a normal behavior on Mega2560? Cause this doesn't happen on my Mega328 based board. It's not just GUI, anyth...
by haley0918
Wed Jan 09, 2013 3:35 pm
Forum: Shields, boards and sensors
Topic: BMP085 sensor value stop update
Replies: 4
Views: 698

Re: BMP085 sensor value stop update

Now I had acquired another 2 flight controllers from Hobbyking. They are: 1) MultiWii 328P Flight Controller w/FTDI & DSM2 Port http://www.hobbyking.com/hobbyking/store/__27033__MultiWii_328P_Flight_Controller_w_FTDI_DSM2_Port.html 2) Multiwii and Megapirate AIO Flight Controller w/FTDI http://w...
by haley0918
Tue Dec 25, 2012 1:02 pm
Forum: Shields, boards and sensors
Topic: BMP085 sensor value stop update
Replies: 4
Views: 698

BMP085 sensor value stop update

Hi all, I'd left my flight controller running for long time and connected to the GUI. After more than an hour, the BMP085 suddenly just stopped update. Mag, acc, gyro and GPS still work and there was no I2C error. My flight controller consists of an Arduino Nano with Allinone by CSG_EU and another A...
by haley0918
Sat Nov 10, 2012 1:56 pm
Forum: Shields, boards and sensors
Topic: 10Hz GPS thread
Replies: 84
Views: 58108

Re: 10Hz GPS thread

Hi, I have a UP501 module with MT3329. I've tested it previously in normal NMEA mode using previous version of I2C_GPS_NAV and it works with 10Hz. From what I see, most people use the GTPA010/GTPA013 modules that confirms with binary mode. Would UP501 be able to work in binary mode? I'm only getting...
by haley0918
Thu Nov 01, 2012 2:59 am
Forum: Boards
Topic: ST INEMO-M1 system on board
Replies: 6
Views: 1619

Re: ST INEMO-M1 system on board

timecop wrote:Not too much of a problem, at least with current impl, software is barely using 10% of the cpu :)


If you mean on 32bit flight controller, yes.
But what about the current 8bit arduino controllers?
by haley0918
Thu Nov 01, 2012 2:46 am
Forum: Boards
Topic: ST INEMO-M1 system on board
Replies: 6
Views: 1619

Re: ST INEMO-M1 system on board

Have to admit that I had only glance through the data brief and didn't look much in the I/Os.

Yes, it's possible for a basic quad without any extra stuff but I envision to offload filters of the sensors to this board, reducing load on the main controller.
by haley0918
Wed Oct 31, 2012 9:31 am
Forum: Boards
Topic: ST INEMO-M1 system on board
Replies: 6
Views: 1619

ST INEMO-M1 system on board

ST just sent me an email regarding this system on board.

INEMO_M1: http://www.st.com/internet/analog/product/253162.jsp
Data brief: http://www.st.com/internet/com/TECHNICA ... 046903.pdf

A 9DOF IMU with a 32bit ARM MCU on board. Though there's no normal I/O pins available. Possible use for advanced IMU in future Multiwii implementation.
by haley0918
Sat Mar 17, 2012 3:13 am
Forum: Software development
Topic: MultiWii 2.0 is coming
Replies: 256
Views: 53667

Re: MultiWii 2.0 is coming

karsten j. wrote:
When I tilted the system in all direction, the orientation initially follows and then slowly drifting back to level



Does your I2C error keep on increasing? If so, your acc can't be read and probably is because of wrong address.
by haley0918
Fri Mar 16, 2012 11:12 am
Forum: Software development
Topic: MultiWii 2.0 is coming
Replies: 256
Views: 53667

Re: MultiWii 2.0 is coming

I have also introduced a little idea on altitude hold using accelerometer Z axis. I like this idea of alt hold using acc Z, thumbs up. That means there's no measurement relative to anything to determine alt change. Unlike baro relative to sea level and sonar relative to nearest object. But of cours...
by haley0918
Sat Mar 10, 2012 11:10 am
Forum: Software development
Topic: MultiWii 2.0 is coming
Replies: 256
Views: 53667

Re: MultiWii 2.0 is coming

Is it possible to correct the I2C address of BMA180 for ALLINONE sensor board in the shared trunk?

I'm getting tired of manually adding the required line every time I update from the trunk
by haley0918
Thu Mar 08, 2012 9:52 am
Forum: Software development
Topic: MultiWii 2.0 is coming
Replies: 256
Views: 53667

Re: MultiWii 2.0 is coming

Hi! I'd just tried the 2.0 preversion1 and I found that the IMU orientation function, viewed through the conf, is different than 1.9 12/11/11. When I tilted the system in all direction, the orientation initially follows and then slowly drifting back to level. In 1.9, the orientation stays perfectly ...
by haley0918
Tue Mar 06, 2012 9:14 am
Forum: Ideas
Topic: Attemp to integrate sonar (ultrasonic sensor)
Replies: 265
Views: 137589

Re: Attemp to integrate sonar (ultrasonic sensor)

Bledi wrote:I just order an SR04. I ll try to use your works to add it to the arduino use for I2C GPS (EOSBandi)


I'm interested to include the SR04 into I2C_GPS_NAV too, possibly tying multiple SR04 together under one I2C address
Otherwise the arduino is kind of a waste for GPS only